aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-09-28 21:56:33 +0800
committertobez <tobez@FreeBSD.org>2005-09-28 21:56:33 +0800
commit7bf66ee4e59b4d4ab93651ebf38a0cfb08082478 (patch)
tree3fde5985f7f4878628f899a8005770f95def4eec
parent352a0a078ed7fe28e8ba2081a947bd40c88d5423 (diff)
downloadfreebsd-ports-gnome-7bf66ee4e59b4d4ab93651ebf38a0cfb08082478.tar.gz
freebsd-ports-gnome-7bf66ee4e59b4d4ab93651ebf38a0cfb08082478.tar.zst
freebsd-ports-gnome-7bf66ee4e59b4d4ab93651ebf38a0cfb08082478.zip
Add p5-JSON, a JavaScript Object Notation parser and converter for Perl.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-JSON/Makefile26
-rw-r--r--textproc/p5-JSON/distinfo2
-rw-r--r--textproc/p5-JSON/pkg-descr5
-rw-r--r--textproc/p5-JSON/pkg-plist10
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0e1f21b8612f..e7f712849291 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -292,6 +292,7 @@
SUBDIR += p5-Hash-Merge
SUBDIR += p5-IDNA-Punycode
SUBDIR += p5-IO-CSVHeaderFile
+ SUBDIR += p5-JSON
SUBDIR += p5-LJ-SpellCheck
SUBDIR += p5-Lingua-Conjunction
SUBDIR += p5-Lingua-EN-AddressParse
diff --git a/textproc/p5-JSON/Makefile b/textproc/p5-JSON/Makefile
new file mode 100644
index 000000000000..eb56a0c844f6
--- /dev/null
+++ b/textproc/p5-JSON/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-JSON
+# Date created: 28 September 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON
+PORTVERSION= 0.991
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MA/MAKAMAKA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= JavaScript Object Notation parser and converter for Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= JSON.3 \
+ JSON::Converter.3 \
+ JSON::Parser.3 \
+ JSONRPC.3 \
+ JSONRPC::Transport::HTTP.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-JSON/distinfo b/textproc/p5-JSON/distinfo
new file mode 100644
index 000000000000..b8166869fb2f
--- /dev/null
+++ b/textproc/p5-JSON/distinfo
@@ -0,0 +1,2 @@
+MD5 (JSON-0.991.tar.gz) = 96397ab8fa8bef9f233f0ea8205d6548
+SIZE (JSON-0.991.tar.gz) = 13929
diff --git a/textproc/p5-JSON/pkg-descr b/textproc/p5-JSON/pkg-descr
new file mode 100644
index 000000000000..a0d81aa17ffb
--- /dev/null
+++ b/textproc/p5-JSON/pkg-descr
@@ -0,0 +1,5 @@
+This module converts from JSON (JavaScript Object Notation) to Perl
+data structures, and the other way around.
+
+WWW: http://search.cpan.org/dist/JSON/
+WWW: http://www.crockford.com/JSON/
diff --git a/textproc/p5-JSON/pkg-plist b/textproc/p5-JSON/pkg-plist
new file mode 100644
index 000000000000..f2d875649974
--- /dev/null
+++ b/textproc/p5-JSON/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/JSON.pm
+%%SITE_PERL%%/JSON/Converter.pm
+%%SITE_PERL%%/JSON/Parser.pm
+%%SITE_PERL%%/JSONRPC.pm
+%%SITE_PERL%%/JSONRPC/Transport/HTTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/JSONRPC/Transport 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/JSONRPC 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/JSON 2>/dev/null || true