aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-07-01 16:19:45 +0800
committerijliao <ijliao@FreeBSD.org>2004-07-01 16:19:45 +0800
commit7ce4c950a0c4193ac86a0b1428476b3d976ff9b7 (patch)
tree1d7b3085a1c4d6877b0af6c902ff218ca46e7ffe
parentcdcd74a2f94ae703c8e5d175ed80b053524a20b3 (diff)
downloadfreebsd-ports-gnome-7ce4c950a0c4193ac86a0b1428476b3d976ff9b7.tar.gz
freebsd-ports-gnome-7ce4c950a0c4193ac86a0b1428476b3d976ff9b7.tar.zst
freebsd-ports-gnome-7ce4c950a0c4193ac86a0b1428476b3d976ff9b7.zip
add phpwebapp 1.0
A web application framework
-rw-r--r--www/Makefile1
-rw-r--r--www/phpwebapp/Makefile30
-rw-r--r--www/phpwebapp/distinfo2
-rw-r--r--www/phpwebapp/pkg-descr10
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 472439c9487f..9c7305514f37 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -521,6 +521,7 @@
SUBDIR += phpbb
SUBDIR += phpgedview
SUBDIR += phpnuke
+ SUBDIR += phpwebapp
SUBDIR += phpwiki
SUBDIR += plone
SUBDIR += plugger
diff --git a/www/phpwebapp/Makefile b/www/phpwebapp/Makefile
new file mode 100644
index 000000000000..f86b32750fb2
--- /dev/null
+++ b/www/phpwebapp/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: phpwebapp
+# Date created: Jul 1, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpwebapp
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A web application framework
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+PHPWEBAPP?= ${PREFIX}/www/data/web_app
+
+do-install:
+ ${CP} -R ${WRKSRC}/web_app/ ${PHPWEBAPP}
+ @${FIND} ${PHPWEBAPP} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PHPWEBAPP} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/phpwebapp/distinfo b/www/phpwebapp/distinfo
new file mode 100644
index 000000000000..135e40b33f2e
--- /dev/null
+++ b/www/phpwebapp/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpwebapp-1.0.tar.gz) = 0999b439c105f84762e71ec4654a1385
+SIZE (phpwebapp-1.0.tar.gz) = 304960
diff --git a/www/phpwebapp/pkg-descr b/www/phpwebapp/pkg-descr
new file mode 100644
index 000000000000..12dabb382466
--- /dev/null
+++ b/www/phpwebapp/pkg-descr
@@ -0,0 +1,10 @@
+phpWebApp is an application framework which makes easy and simple the task of
+building PHP web applications based on relational databases. It separates the
+task of designing and changing the layout of the application from the task of
+implementing the logic of the application, by using XML templates that are an
+extension of XHTML. It also simplifies the task of implementing the logic of
+the application by offering an event based programming model. In addition,
+phpWebApp tries to offer modularity and code reusability to the community of
+webApp developers.
+
+WWW: http://phpwebapp.sourceforge.net/