aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-01 06:38:40 +0800
committersat <sat@FreeBSD.org>2007-02-01 06:38:40 +0800
commit7de6eb2f23b3899bc9d11b5c978b688b68bbaf47 (patch)
treedb627e8cb120ac1a85efc08e09b058a19153fab8
parentc472fcb9f51c0a088876f24fc83161dd7e154b9d (diff)
downloadfreebsd-ports-gnome-7de6eb2f23b3899bc9d11b5c978b688b68bbaf47.tar.gz
freebsd-ports-gnome-7de6eb2f23b3899bc9d11b5c978b688b68bbaf47.tar.zst
freebsd-ports-gnome-7de6eb2f23b3899bc9d11b5c978b688b68bbaf47.zip
Add port graphics/unpaper:
unpaper is a post-processing tool for scanned sheets of paper, especially for book-pages scanned from previously created photocopies. unpaper tries to remove dark edges, corrects the rotation ("deskew"), and aligns the centering of pages. WWW: http://unpaper.berlios.de/ Author: Jens Gulden <unpaper@jensgulden.de>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/unpaper/Makefile34
-rw-r--r--graphics/unpaper/distinfo3
-rw-r--r--graphics/unpaper/pkg-descr7
-rw-r--r--graphics/unpaper/pkg-plist34
5 files changed, 79 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 075f2e17ed41..cf999229a246 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -673,6 +673,7 @@
SUBDIR += tulip
SUBDIR += uDrawGraph
SUBDIR += ufraw
+ SUBDIR += unpaper
SUBDIR += urt
SUBDIR += vcg
SUBDIR += vertex
diff --git a/graphics/unpaper/Makefile b/graphics/unpaper/Makefile
new file mode 100644
index 000000000000..cc4d0f73b3b1
--- /dev/null
+++ b/graphics/unpaper/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: unpaper
+# Date created: 01 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unpaper
+DISTVERSION= 0_2
+CATEGORIES= graphics
+MASTER_SITES= BERLIOS
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Post-processing tool for scanned sheets of paper
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|doc/||g' ${WRKSRC}/unpaper.html
+
+do-build:
+ @${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/src/${PORTNAME}.c -lm
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/unpaper.html ${WRKSRC}/readme.txt ${DOCSDIR}/
+ @${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/unpaper/distinfo b/graphics/unpaper/distinfo
new file mode 100644
index 000000000000..25cc0f3a5085
--- /dev/null
+++ b/graphics/unpaper/distinfo
@@ -0,0 +1,3 @@
+MD5 (unpaper-0_2.tgz) = 6e8abf05013488370ccbdc91b2239670
+SHA256 (unpaper-0_2.tgz) = c4cf8857fab7af9cdd467e83bfb29bc6a0bb8baa7e7b9d5fb00824c6e7b100a1
+SIZE (unpaper-0_2.tgz) = 639252
diff --git a/graphics/unpaper/pkg-descr b/graphics/unpaper/pkg-descr
new file mode 100644
index 000000000000..28ce7a91662e
--- /dev/null
+++ b/graphics/unpaper/pkg-descr
@@ -0,0 +1,7 @@
+unpaper is a post-processing tool for scanned sheets of paper,
+especially for book-pages scanned from previously created photocopies.
+unpaper tries to remove dark edges, corrects the rotation ("deskew"),
+and aligns the centering of pages.
+
+WWW: http://unpaper.berlios.de/
+Author: Jens Gulden <unpaper@jensgulden.de>
diff --git a/graphics/unpaper/pkg-plist b/graphics/unpaper/pkg-plist
new file mode 100644
index 000000000000..b095637b264b
--- /dev/null
+++ b/graphics/unpaper/pkg-plist
@@ -0,0 +1,34 @@
+%%PORTDOCS%%%%DOCSDIR%%/img/_after.png
+%%PORTDOCS%%%%DOCSDIR%%/img/_arrow.png
+%%PORTDOCS%%%%DOCSDIR%%/img/_before.png
+%%PORTDOCS%%%%DOCSDIR%%/img/blackfilter-detail.png
+%%PORTDOCS%%%%DOCSDIR%%/img/blackfilter.png
+%%PORTDOCS%%%%DOCSDIR%%/img/blurfilter-detail.png
+%%PORTDOCS%%%%DOCSDIR%%/img/blurfilter.png
+%%PORTDOCS%%%%DOCSDIR%%/img/border-align.png
+%%PORTDOCS%%%%DOCSDIR%%/img/border-scan.png
+%%PORTDOCS%%%%DOCSDIR%%/img/deskew-detail1.png
+%%PORTDOCS%%%%DOCSDIR%%/img/deskew-detail2.png
+%%PORTDOCS%%%%DOCSDIR%%/img/deskew.png
+%%PORTDOCS%%%%DOCSDIR%%/img/documentation.odg
+%%PORTDOCS%%%%DOCSDIR%%/img/input-pages.png
+%%PORTDOCS%%%%DOCSDIR%%/img/layout-templates.png
+%%PORTDOCS%%%%DOCSDIR%%/img/mask-center.png
+%%PORTDOCS%%%%DOCSDIR%%/img/mask-scan-detail1.png
+%%PORTDOCS%%%%DOCSDIR%%/img/mask-scan-detail2.png
+%%PORTDOCS%%%%DOCSDIR%%/img/mask-scan.png
+%%PORTDOCS%%%%DOCSDIR%%/img/multiple-input-files.png
+%%PORTDOCS%%%%DOCSDIR%%/img/multiple-output-files.png
+%%PORTDOCS%%%%DOCSDIR%%/img/noisefilter.png
+%%PORTDOCS%%%%DOCSDIR%%/img/nospam.js
+%%PORTDOCS%%%%DOCSDIR%%/img/output-pages.png
+%%PORTDOCS%%%%DOCSDIR%%/img/processing-order.png
+%%PORTDOCS%%%%DOCSDIR%%/img/sheetspages.png
+%%PORTDOCS%%%%DOCSDIR%%/img/standard-deviation.png
+%%PORTDOCS%%%%DOCSDIR%%/img/style.css
+%%PORTDOCS%%%%DOCSDIR%%/img/x-click-but04.gif
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/unpaper.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/img
+%%PORTDOCS%%@dirrm %%DOCSDIR%%