aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-16 20:01:58 +0800
committermiwi <miwi@FreeBSD.org>2007-03-16 20:01:58 +0800
commit7e32181048717f35184b4ddb587f38f5292f0a42 (patch)
tree92e71fb11fb54ad8c3fb61d287ae3b4957acd4cc
parent9d9099637f88c1e9e80e07f07a119b9bc7a3a7fe (diff)
downloadfreebsd-ports-gnome-7e32181048717f35184b4ddb587f38f5292f0a42.tar.gz
freebsd-ports-gnome-7e32181048717f35184b4ddb587f38f5292f0a42.tar.zst
freebsd-ports-gnome-7e32181048717f35184b4ddb587f38f5292f0a42.zip
- Update to 0.7.2
PR: 110276 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
-rw-r--r--graphics/gnash-devel/Makefile63
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/files/patch-configure11
-rw-r--r--graphics/gnash-devel/pkg-descr23
-rw-r--r--graphics/gnash-devel/pkg-plist26
-rw-r--r--graphics/gnash/Makefile63
-rw-r--r--graphics/gnash/distinfo6
-rw-r--r--graphics/gnash/files/patch-configure11
-rw-r--r--graphics/gnash/pkg-descr23
-rw-r--r--graphics/gnash/pkg-plist26
10 files changed, 170 insertions, 88 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index 636aad61a604..dbb4efb03125 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -15,47 +14,73 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= GNU Flash movie player
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- ogg.5:${PORTSDIR}/audio/libogg
+ curl.4:${PORTSDIR}/ftp/curl
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehier glib20 pkgconfig libxml2
-USE_SDL= sdl mixer
-USE_X_PREFIX= yes
-USE_GCC= 3.4+
+USE_GNOME= pkgconfig libxml2
+USE_XLIB= yes
PLUGIN_DIR= ${PREFIX}/lib/browser_plugins
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
- --with-plugindir=${PLUGIN_DIR}
+ --with-plugindir=${PLUGIN_DIR} \
+ --enable-jpeg
-OPTIONS= PLUGIN "Enable firefox plugin" on
+MAN1= gnash.1
+
+OPTIONS= PLUGIN "Enable browser plugin" on \
+ GTK "Enable GTK GUI" on \
+ SOUND "Enable sound" on \
+ GSTREAMER "Use GStreamer sound output instead of SDL" off \
+ MAD "Support mp3 decoding through libmad" on
.include <bsd.port.pre.mk>
-.if !defined(WITH_PLUGIN)
-CONFIGURE_ARGS+= --disable-plugin
+.if defined(WITHOUT_GTK)
+USE_SDL+= sdl
+CONFIGURE_ARGS+= --enable-gui=SDL
+.else
+CONFIGURE_ARGS+= --enable-gui=GTK
+USE_GNOME+= atk pango gtk20
+LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+.endif
+
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+= --enable-sound=NO
+.else
+. if defined(WITH_GSTREAMER)
+USE_GSTREAMER= yes
+CONFIGURE_ARGS+= --enable-sound=GST
+. else
+USE_SDL+= sdl
+CONFIGURE_ARGS+= --enable-sound=SDL
+. if defined(WITHOUT_MAD)
+CONFIGURE_ARGS+= --without-mp3-decoder
+. else
+CONFIGURE_ARGS+= --with-mp3-decoder=mad
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+. endif
+. endif
+.endif
+
+.if defined(WITHOUT_PLUGIN)
PLIST_SUB+= PLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-plugin
.else
-USE_GNOME+= atk pango gtk20
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
PLIST_SUB+= PLUGIN=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|gnash-dbg.log|.gnash-dbg.log|' ${WRKSRC}/libbase/log.h
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g;s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-.if !defined(WITH_PLUGIN)
- @${REINPLACE_CMD} -e '/STD_DIRS/ s|plugin||' ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index bd20ce887e05..ae85c44a00bb 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.7.1.tar.bz2) = d860981aeaac0fc941a28abc3c24223c
-SHA256 (gnash-0.7.1.tar.bz2) = 48fcb533e3989757c23af2b9130c8b490a4d40375be4813ce425efea82ae0f62
-SIZE (gnash-0.7.1.tar.bz2) = 1089794
+MD5 (gnash-0.7.2.tar.bz2) = ccef0f45be01a4c2992b46c2363a514f
+SHA256 (gnash-0.7.2.tar.bz2) = 12dccb4bc69488f516e0283e988412ba7db5dfad32744425f97d641392a2e98b
+SIZE (gnash-0.7.2.tar.bz2) = 1599810
diff --git a/graphics/gnash-devel/files/patch-configure b/graphics/gnash-devel/files/patch-configure
new file mode 100644
index 000000000000..3cb3452756e7
--- /dev/null
+++ b/graphics/gnash-devel/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Nov 17 22:09:10 2006
++++ configure Wed Jan 31 21:07:06 2007
+@@ -26598,7 +26598,7 @@
+ if test x"${with_atk_lib}" != x ; then
+ libname=atkatk-x11-${gnash_atk_version}
+ if test -f ${with_atk_lib}/lib${libname}.a -o -f ${with_atk_lib}/lib${libname}.so; then
+- ac_cv_path_atk_lib="`-L(cd ${with_atk_lib}; pwd)` -l${libname}"
++ ac_cv_path_atk_lib="-L`(cd ${with_atk_lib}; pwd)` -l${libname}"
+ else
+ { { echo "$as_me:$LINENO: error: ${with_atk_lib} directory doesn't contain libatkatk." >&5
+ echo "$as_me: error: ${with_atk_lib} directory doesn't contain libatkatk." >&2;}
diff --git a/graphics/gnash-devel/pkg-descr b/graphics/gnash-devel/pkg-descr
index a381f09fd134..e50c17388ccf 100644
--- a/graphics/gnash-devel/pkg-descr
+++ b/graphics/gnash-devel/pkg-descr
@@ -1,22 +1,27 @@
-Gnash is a GNU Flash movie player. Till now it has been possible
-to play flash movies with proprietary software. While there are a
-few free flash players, none supports anything higher than SWF v4
-at best. Gnash is based on GameSWF, and supports many SWF v7 features.
+Gnash is a GNU Flash movie player. Previously, it was only possible
+to play flash movies with proprietary software. While there are
+some other free flash players, none support anything beyond SWF v4.
+Gnash is based on GameSWF, and supports many SWF v7 features.
Features:
- Runs standalone
Gnash can run standalone to play flash movies.
-- Firefox plugin
- Gnash can also run as a plugin from within Firefox.
+- Browser plugin
+ Gnash can also run as a plugin from within most Mozilla derived
+ browsers, such as Firefox. Gnash also has support for Konqueror.
- SWF v7 compliant
Gnash can play many current flash movies.
- XML Message server
- Gnash also supports an XML based message system as is documented
- in the Flash Format specification.
+ Gnash also supports an XML based message system as documented in
+ the Flash Format specification.
- High Quality Output
- Gnash uses OpenGL for rendering the graphics.
+ Gnash uses OpenGL for rendering the graphics on the desktop, and
+ AntiGrain (AGG) for embedded framebuffer only devices.
- Free Software
Gnash is 100% free software. For more information on the GPL, go
to the Free Software Foundation web site.
+- Better Security
+ Gnash pays extra attention to all network connections, and allows
+ the user to control access.
WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index 97fb936a66b2..82208260dc94 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -2,25 +2,25 @@ bin/gnash
bin/gparser
bin/gprocessor
%%PLUGIN%%lib/browser_plugins/libgnashplugin.so
-lib/gnash/libgnashasobjs.a
-lib/gnash/libgnashasobjs.la
-lib/gnash/libgnashasobjs.so
-lib/gnash/libgnashasobjs.so.0
-lib/gnash/libgnashbackend.a
+lib/gnash/libgnashamf-0.7.2.so
+lib/gnash/libgnashamf.la
+lib/gnash/libgnashamf.so
+lib/gnash/libgnashbackend-0.7.2.so
lib/gnash/libgnashbackend.la
lib/gnash/libgnashbackend.so
-lib/gnash/libgnashbackend.so.0
-lib/gnash/libgnashbase.a
+lib/gnash/libgnashbase-0.7.2.so
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashbase.so.0
-lib/gnash/libgnashgeo.a
+lib/gnash/libgnashgeo-0.7.2.so
lib/gnash/libgnashgeo.la
lib/gnash/libgnashgeo.so
-lib/gnash/libgnashgeo.so.0
-lib/gnash/libgnashserver.a
+lib/gnash/libgnashgui-0.7.2.so
+lib/gnash/libgnashgui.la
+lib/gnash/libgnashgui.so
+lib/gnash/libgnashserver-0.7.2.so
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
-lib/gnash/libgnashserver.so.0
+%%DATADIR%%/gnash_128_96.ico
+@dirrm %%DATADIR%%
@dirrm lib/gnash
-%%PLUGIN%%@dirrmtry lib/browser_plugins
+%%PLUGIN%%@dirrm lib/browser_plugins
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 636aad61a604..dbb4efb03125 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -15,47 +14,73 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= GNU Flash movie player
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- ogg.5:${PORTSDIR}/audio/libogg
+ curl.4:${PORTSDIR}/ftp/curl
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehier glib20 pkgconfig libxml2
-USE_SDL= sdl mixer
-USE_X_PREFIX= yes
-USE_GCC= 3.4+
+USE_GNOME= pkgconfig libxml2
+USE_XLIB= yes
PLUGIN_DIR= ${PREFIX}/lib/browser_plugins
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
- --with-plugindir=${PLUGIN_DIR}
+ --with-plugindir=${PLUGIN_DIR} \
+ --enable-jpeg
-OPTIONS= PLUGIN "Enable firefox plugin" on
+MAN1= gnash.1
+
+OPTIONS= PLUGIN "Enable browser plugin" on \
+ GTK "Enable GTK GUI" on \
+ SOUND "Enable sound" on \
+ GSTREAMER "Use GStreamer sound output instead of SDL" off \
+ MAD "Support mp3 decoding through libmad" on
.include <bsd.port.pre.mk>
-.if !defined(WITH_PLUGIN)
-CONFIGURE_ARGS+= --disable-plugin
+.if defined(WITHOUT_GTK)
+USE_SDL+= sdl
+CONFIGURE_ARGS+= --enable-gui=SDL
+.else
+CONFIGURE_ARGS+= --enable-gui=GTK
+USE_GNOME+= atk pango gtk20
+LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+.endif
+
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+= --enable-sound=NO
+.else
+. if defined(WITH_GSTREAMER)
+USE_GSTREAMER= yes
+CONFIGURE_ARGS+= --enable-sound=GST
+. else
+USE_SDL+= sdl
+CONFIGURE_ARGS+= --enable-sound=SDL
+. if defined(WITHOUT_MAD)
+CONFIGURE_ARGS+= --without-mp3-decoder
+. else
+CONFIGURE_ARGS+= --with-mp3-decoder=mad
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+. endif
+. endif
+.endif
+
+.if defined(WITHOUT_PLUGIN)
PLIST_SUB+= PLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-plugin
.else
-USE_GNOME+= atk pango gtk20
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
PLIST_SUB+= PLUGIN=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|gnash-dbg.log|.gnash-dbg.log|' ${WRKSRC}/libbase/log.h
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g;s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-.if !defined(WITH_PLUGIN)
- @${REINPLACE_CMD} -e '/STD_DIRS/ s|plugin||' ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index bd20ce887e05..ae85c44a00bb 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.7.1.tar.bz2) = d860981aeaac0fc941a28abc3c24223c
-SHA256 (gnash-0.7.1.tar.bz2) = 48fcb533e3989757c23af2b9130c8b490a4d40375be4813ce425efea82ae0f62
-SIZE (gnash-0.7.1.tar.bz2) = 1089794
+MD5 (gnash-0.7.2.tar.bz2) = ccef0f45be01a4c2992b46c2363a514f
+SHA256 (gnash-0.7.2.tar.bz2) = 12dccb4bc69488f516e0283e988412ba7db5dfad32744425f97d641392a2e98b
+SIZE (gnash-0.7.2.tar.bz2) = 1599810
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
new file mode 100644
index 000000000000..3cb3452756e7
--- /dev/null
+++ b/graphics/gnash/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Nov 17 22:09:10 2006
++++ configure Wed Jan 31 21:07:06 2007
+@@ -26598,7 +26598,7 @@
+ if test x"${with_atk_lib}" != x ; then
+ libname=atkatk-x11-${gnash_atk_version}
+ if test -f ${with_atk_lib}/lib${libname}.a -o -f ${with_atk_lib}/lib${libname}.so; then
+- ac_cv_path_atk_lib="`-L(cd ${with_atk_lib}; pwd)` -l${libname}"
++ ac_cv_path_atk_lib="-L`(cd ${with_atk_lib}; pwd)` -l${libname}"
+ else
+ { { echo "$as_me:$LINENO: error: ${with_atk_lib} directory doesn't contain libatkatk." >&5
+ echo "$as_me: error: ${with_atk_lib} directory doesn't contain libatkatk." >&2;}
diff --git a/graphics/gnash/pkg-descr b/graphics/gnash/pkg-descr
index a381f09fd134..e50c17388ccf 100644
--- a/graphics/gnash/pkg-descr
+++ b/graphics/gnash/pkg-descr
@@ -1,22 +1,27 @@
-Gnash is a GNU Flash movie player. Till now it has been possible
-to play flash movies with proprietary software. While there are a
-few free flash players, none supports anything higher than SWF v4
-at best. Gnash is based on GameSWF, and supports many SWF v7 features.
+Gnash is a GNU Flash movie player. Previously, it was only possible
+to play flash movies with proprietary software. While there are
+some other free flash players, none support anything beyond SWF v4.
+Gnash is based on GameSWF, and supports many SWF v7 features.
Features:
- Runs standalone
Gnash can run standalone to play flash movies.
-- Firefox plugin
- Gnash can also run as a plugin from within Firefox.
+- Browser plugin
+ Gnash can also run as a plugin from within most Mozilla derived
+ browsers, such as Firefox. Gnash also has support for Konqueror.
- SWF v7 compliant
Gnash can play many current flash movies.
- XML Message server
- Gnash also supports an XML based message system as is documented
- in the Flash Format specification.
+ Gnash also supports an XML based message system as documented in
+ the Flash Format specification.
- High Quality Output
- Gnash uses OpenGL for rendering the graphics.
+ Gnash uses OpenGL for rendering the graphics on the desktop, and
+ AntiGrain (AGG) for embedded framebuffer only devices.
- Free Software
Gnash is 100% free software. For more information on the GPL, go
to the Free Software Foundation web site.
+- Better Security
+ Gnash pays extra attention to all network connections, and allows
+ the user to control access.
WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index 97fb936a66b2..82208260dc94 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -2,25 +2,25 @@ bin/gnash
bin/gparser
bin/gprocessor
%%PLUGIN%%lib/browser_plugins/libgnashplugin.so
-lib/gnash/libgnashasobjs.a
-lib/gnash/libgnashasobjs.la
-lib/gnash/libgnashasobjs.so
-lib/gnash/libgnashasobjs.so.0
-lib/gnash/libgnashbackend.a
+lib/gnash/libgnashamf-0.7.2.so
+lib/gnash/libgnashamf.la
+lib/gnash/libgnashamf.so
+lib/gnash/libgnashbackend-0.7.2.so
lib/gnash/libgnashbackend.la
lib/gnash/libgnashbackend.so
-lib/gnash/libgnashbackend.so.0
-lib/gnash/libgnashbase.a
+lib/gnash/libgnashbase-0.7.2.so
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashbase.so.0
-lib/gnash/libgnashgeo.a
+lib/gnash/libgnashgeo-0.7.2.so
lib/gnash/libgnashgeo.la
lib/gnash/libgnashgeo.so
-lib/gnash/libgnashgeo.so.0
-lib/gnash/libgnashserver.a
+lib/gnash/libgnashgui-0.7.2.so
+lib/gnash/libgnashgui.la
+lib/gnash/libgnashgui.so
+lib/gnash/libgnashserver-0.7.2.so
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
-lib/gnash/libgnashserver.so.0
+%%DATADIR%%/gnash_128_96.ico
+@dirrm %%DATADIR%%
@dirrm lib/gnash
-%%PLUGIN%%@dirrmtry lib/browser_plugins
+%%PLUGIN%%@dirrm lib/browser_plugins