aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-06-11 17:14:26 +0800
committerkwm <kwm@FreeBSD.org>2013-06-11 17:14:26 +0800
commit7e3f0c96e966673a6b0cc9d5eb73d72d49d22d15 (patch)
treecad22549b106b9b391fa7c85fc96088fb6799c08
parente816ca9bf5ca400fd05d36c252f8795d554fe71c (diff)
downloadfreebsd-ports-gnome-7e3f0c96e966673a6b0cc9d5eb73d72d49d22d15.tar.gz
freebsd-ports-gnome-7e3f0c96e966673a6b0cc9d5eb73d72d49d22d15.tar.zst
freebsd-ports-gnome-7e3f0c96e966673a6b0cc9d5eb73d72d49d22d15.zip
Add PORTSCOUT macro's to prevent from picking up development versions.
-rw-r--r--multimedia/gstreamer1-plugins/Makefile2
-rw-r--r--multimedia/gstreamer1/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index 967cb079e6bd..703962372084 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -26,6 +26,8 @@ LIB_DEPENDS+= gstreamer-1.0:${PORTSDIR}/multimedia/gstreamer1 \
orc-0.4:${PORTSDIR}/devel/orc
RUN_DEPENDS+= iso-codes>=0:${PORTSDIR}/misc/iso-codes
+PORTSCOUT= limitw:1,even
+
BASE_PORTVERSION= 1.0.7
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
index 7c89622f9683..ef5b9f8a712a 100644
--- a/multimedia/gstreamer1/Makefile
+++ b/multimedia/gstreamer1/Makefile
@@ -17,6 +17,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
gobject-introspection>=1.31.1:${PORTSDIR}/devel/gobject-introspection
RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-introspection
+PORTSCOUT= limitw:1,even
+
CFLAGS:= ${CFLAGS} -O2 -Wno-format
USES= bison gettext pathfix pkgconfig
# workaround a crash in clang 3.3 crash llvm bug # 15840