aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-09-06 01:09:34 +0800
committergarga <garga@FreeBSD.org>2005-09-06 01:09:34 +0800
commit7f6e3e3c242da9f6834c729706affa33fef7a300 (patch)
treeb35206d8a9baf6b7bcda3ce48ad2d6feeb91c20a
parent73b719e820e207eeaab8956371b23747d5ab7167 (diff)
downloadfreebsd-ports-gnome-7f6e3e3c242da9f6834c729706affa33fef7a300.tar.gz
freebsd-ports-gnome-7f6e3e3c242da9f6834c729706affa33fef7a300.tar.zst
freebsd-ports-gnome-7f6e3e3c242da9f6834c729706affa33fef7a300.zip
Move LOG_FILE code to after bsd.port.pre.mk
PR: ports/85687 Submitted by: maintainer
-rw-r--r--www/cgiwrap/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/www/cgiwrap/Makefile b/www/cgiwrap/Makefile
index c38799fd4ff9..ae3fb05b8e38 100644
--- a/www/cgiwrap/Makefile
+++ b/www/cgiwrap/Makefile
@@ -55,18 +55,6 @@ USER_CGIDIR?= public_html/cgi-bin
ALLOW_FILE?= ${PREFIX}/etc/${PORTNAME}.allow
DENY_FILE?= ${PREFIX}/etc/${PORTNAME}.deny
-##
-# LOG_FILE
-#
-# Enables cgiwrap logging (when a user called cgiwrap, its arguments,
-# and who ran it). Specify the full path to the logfile.
-#
-.if defined(LOG_FILE)
-CONFIGURE_ARGS+= --with-logging-file=${LOG_FILE}
-.else
-CONFIGURE_ARGS+= --without-logging-file
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-httpd-user=${WWWOWN} \
--with-install-group=${WWWGRP} \
@@ -78,6 +66,17 @@ CONFIGURE_ARGS= --with-httpd-user=${WWWOWN} \
.include <bsd.port.pre.mk>
+##
+# LOG_FILE
+#
+# Enables cgiwrap logging (when a user called cgiwrap, its arguments,
+# and who ran it). Specify the full path to the logfile.
+#
+.if defined(LOG_FILE)
+CONFIGURE_ARGS+= --with-logging-file=${LOG_FILE}
+.else
+CONFIGURE_ARGS+= --without-logging-file
+.endif
.if !defined(WITH_CGI_OWNER)
CONFIGURE_ARGS+= --without-check-owner
.endif