aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-02-01 20:42:54 +0800
committerantoine <antoine@FreeBSD.org>2015-02-01 20:42:54 +0800
commit809e32adbf5429b470e3be00a86a3fcff92c5164 (patch)
treef240c812d408e6ad3302f3252abf9eb95b6b9441
parent8b729ba3c410a4cd88b8ea819e359d5d133ed62f (diff)
downloadfreebsd-ports-gnome-809e32adbf5429b470e3be00a86a3fcff92c5164.tar.gz
freebsd-ports-gnome-809e32adbf5429b470e3be00a86a3fcff92c5164.tar.zst
freebsd-ports-gnome-809e32adbf5429b470e3be00a86a3fcff92c5164.zip
- Update textproc/py-pyelasticsearch to 1.0
- Adjust security/py-plaso dependencies and patch it to be less noisy
-rw-r--r--security/py-plaso/Makefile2
-rw-r--r--security/py-plaso/files/patch-plaso_output_elastic.py11
-rw-r--r--textproc/py-pyelasticsearch/Makefile9
-rw-r--r--textproc/py-pyelasticsearch/distinfo4
4 files changed, 20 insertions, 6 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index f82298c275fa..1088fc81439c 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plaso
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/final/ \
LOCAL/antoine
@@ -37,6 +38,7 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
${PYTHON_PKGNAMEPREFIX}pyelasticsearch>=0:${PORTSDIR}/textproc/py-pyelasticsearch \
${PYTHON_PKGNAMEPREFIX}pytsk>=0:${PORTSDIR}/sysutils/py-pytsk \
${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:${PORTSDIR}/www/py-requests \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
diff --git a/security/py-plaso/files/patch-plaso_output_elastic.py b/security/py-plaso/files/patch-plaso_output_elastic.py
new file mode 100644
index 000000000000..b722012a9dc8
--- /dev/null
+++ b/security/py-plaso/files/patch-plaso_output_elastic.py
@@ -0,0 +1,11 @@
+--- plaso/output/elastic.py.orig 2014-12-20 17:43:35 UTC
++++ plaso/output/elastic.py
+@@ -81,6 +81,8 @@ class Elastic(output.LogOutputFormatter)
+ elastic_port = getattr(config, 'elastic_port', 9200)
+ self._elastic_db = pyelasticsearch.ElasticSearch(
+ u'http://{0:s}:{1:d}'.format(elastic_host, elastic_port))
++ logging.getLogger('elasticsearch.trace').setLevel(logging.WARNING)
++ logging.getLogger('elasticsearch').setLevel(logging.WARNING)
+
+ case_name = getattr(config, 'case_name', u'')
+ document_type = getattr(config, 'document_type', u'')
diff --git a/textproc/py-pyelasticsearch/Makefile b/textproc/py-pyelasticsearch/Makefile
index 1e8ce7cf876b..9fe6093a9226 100644
--- a/textproc/py-pyelasticsearch/Makefile
+++ b/textproc/py-pyelasticsearch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pyelasticsearch
-PORTVERSION= 0.7.1
+PORTVERSION= 1.0
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +12,10 @@ COMMENT= Flexible, high-scale API to elasticsearch
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.1.0:${PORTSDIR}/devel/py-simplejson \
- ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}requests>=1.0:${PORTSDIR}/www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}elasticsearch-py>=1.0.0:${PORTSDIR}/textproc/py-elasticsearch-py \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=3.0:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4.0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.8:${PORTSDIR}/net/py-urllib3
USES= python
USE_PYTHON= distutils autoplist
diff --git a/textproc/py-pyelasticsearch/distinfo b/textproc/py-pyelasticsearch/distinfo
index 67a9a97a4530..a3511d55b387 100644
--- a/textproc/py-pyelasticsearch/distinfo
+++ b/textproc/py-pyelasticsearch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pyelasticsearch-0.7.1.tar.gz) = df7a7ef0be35a8632f8e0cf53f5c8f7cd7456daa2470bb5a683feeff983d52a8
-SIZE (pyelasticsearch-0.7.1.tar.gz) = 42244
+SHA256 (pyelasticsearch-1.0.tar.gz) = 44ddfb1225054d7d6b1d02e9338e7d4809be94edbe9929a2ec0807d38df993fa
+SIZE (pyelasticsearch-1.0.tar.gz) = 42432