aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-20 09:29:20 +0800
committeredwin <edwin@FreeBSD.org>2003-01-20 09:29:20 +0800
commit832a15c56fc031b0acb36a188ece2fff061471ef (patch)
tree1cc1ea6443cef23926c0c1ec5863e281dcc3f2a1
parentcfe4a6a5d5e6c968372f9cd7148fca7ad994e086 (diff)
downloadfreebsd-ports-gnome-832a15c56fc031b0acb36a188ece2fff061471ef.tar.gz
freebsd-ports-gnome-832a15c56fc031b0acb36a188ece2fff061471ef.tar.zst
freebsd-ports-gnome-832a15c56fc031b0acb36a188ece2fff061471ef.zip
New port: IMCom command-line Jabber client
IMCom is a command-line Jabber client written in Python. Its original goal was to replace mICQ as my instant messenger. To that end it looks very similar to mICQ, though the actual command interpreter is a bit different. Commands are issued to IMCom in a style similar to IRC. PR: ports/39059 Submitted by: Martijn Lina <martijn@pacno.net>
-rw-r--r--net-im/imcom/Makefile21
-rw-r--r--net-im/imcom/distinfo1
-rw-r--r--net-im/imcom/files/patch-aa25
-rw-r--r--net-im/imcom/pkg-comment1
-rw-r--r--net-im/imcom/pkg-descr7
-rw-r--r--net-im/imcom/pkg-plist35
-rw-r--r--net/Makefile1
-rw-r--r--net/imcom/Makefile21
-rw-r--r--net/imcom/distinfo1
-rw-r--r--net/imcom/files/patch-aa25
-rw-r--r--net/imcom/pkg-comment1
-rw-r--r--net/imcom/pkg-descr7
-rw-r--r--net/imcom/pkg-plist35
13 files changed, 181 insertions, 0 deletions
diff --git a/net-im/imcom/Makefile b/net-im/imcom/Makefile
new file mode 100644
index 000000000000..94d34addf50a
--- /dev/null
+++ b/net-im/imcom/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: imcom
+# Date created: Jun 09 2002
+# Whom: Martijn Lina
+#
+# $FreeBSD$
+
+PORTNAME= imcom
+PORTVERSION= 0.93
+CATEGORIES= net
+MASTER_SITES= http://imcom.floobin.cx/files/
+
+MAINTAINER= martijn@pacno.net
+
+USE_PYTHON= yes
+
+pre-install:
+ @cd ${WRKSRC} ; \
+ ${RM} -rf docs/CVS; \
+ ${RM} -rf docs/*~
+
+.include <bsd.port.mk>
diff --git a/net-im/imcom/distinfo b/net-im/imcom/distinfo
new file mode 100644
index 000000000000..2790cbe5aa0f
--- /dev/null
+++ b/net-im/imcom/distinfo
@@ -0,0 +1 @@
+MD5 (imcom-0.93.tar.gz) = 0e63d044c48490cb84a326a64b2760c9
diff --git a/net-im/imcom/files/patch-aa b/net-im/imcom/files/patch-aa
new file mode 100644
index 000000000000..7dfdf1d2cfa1
--- /dev/null
+++ b/net-im/imcom/files/patch-aa
@@ -0,0 +1,25 @@
+--- Makefile.orig Wed May 22 02:45:56 2002
++++ Makefile Wed May 22 02:47:12 2002
+@@ -1,13 +1,13 @@
+ all:
+
+ install:
+- mkdir -p /usr/local/share/imcom
+- mkdir -p /usr/local/share/imcom/docs
+- cp AutoStatus.API CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW /usr/local/share/imcom/docs
+- cp docs/* /usr/local/share/imcom/docs
+- cp *.py /usr/local/share/imcom
+- cp imcom /usr/local/bin
++ mkdir -p ${LOCALBASE}/share/imcom
++ mkdir -p ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_DATA} AutoStatus.API CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_DATA} docs/* ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_SCRIPT} *.py ${LOCALBASE}/share/imcom
++ ${BSD_INSTALL_SCRIPT} imcom ${LOCALBASE}/bin
+
+ uninstall:
+- rm -rf /usr/local/share/imcom
+- rm -f /usr/local/bin/imcom
++ rm -rf ${LOCALBASE}/share/imcom
++ rm -rf ${LOCALBASE}/share/doc/imcom
++ rm -f ${LOCALBASE}/bin/imcom
diff --git a/net-im/imcom/pkg-comment b/net-im/imcom/pkg-comment
new file mode 100644
index 000000000000..24eff892a759
--- /dev/null
+++ b/net-im/imcom/pkg-comment
@@ -0,0 +1 @@
+IMCom is a command-line Jabber client written in Python
diff --git a/net-im/imcom/pkg-descr b/net-im/imcom/pkg-descr
new file mode 100644
index 000000000000..fd7dcc6bf895
--- /dev/null
+++ b/net-im/imcom/pkg-descr
@@ -0,0 +1,7 @@
+IMCom is a command-line Jabber client written in Python.
+
+Its original goal was to replace mICQ as my instant messenger. To that end it
+looks very similar to mICQ, though the actual command interpreter is a bit
+different. Commands are issued to IMCom in a style similar to IRC.
+
+WWW: http://imcom.floobin.cx/
diff --git a/net-im/imcom/pkg-plist b/net-im/imcom/pkg-plist
new file mode 100644
index 000000000000..e59db2f703b7
--- /dev/null
+++ b/net-im/imcom/pkg-plist
@@ -0,0 +1,35 @@
+bin/imcom
+share/doc/imcom/AutoStatus.API
+share/doc/imcom/CONTRIBUTORS
+share/doc/imcom/LICENSE
+share/doc/imcom/README
+share/doc/imcom/README.autostatus
+share/doc/imcom/TODO
+share/doc/imcom/WHATSNEW
+share/doc/imcom/CHANGELOG
+share/doc/imcom/advanced.html
+share/doc/imcom/commands.html
+share/doc/imcom/download.html
+share/doc/imcom/imcomrc.html
+share/doc/imcom/index.html
+share/doc/imcom/news.html
+share/doc/imcom/rosterlist.jpg
+share/doc/imcom/statuschange.jpg
+share/doc/imcom/style.css
+share/doc/imcom/template.html
+share/doc/imcom/whatis.html
+share/imcom/AccountCreator.py
+share/imcom/SocketWrapper.py
+share/imcom/Preferences.py
+share/imcom/LogHandler.py
+share/imcom/JabberTags.py
+share/imcom/JabberHandler.py
+share/imcom/IMCom.py
+share/imcom/IHTTPServer.py
+share/imcom/Colors.py
+share/imcom/CLI.py
+share/imcom/CICommands.py
+share/imcom/AutoStatus.py
+share/imcom/VCardTags.py
+@dirrm share/doc/imcom
+@dirrm share/imcom
diff --git a/net/Makefile b/net/Makefile
index 0b12b0f9ee19..ea23fb9c4b86 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -204,6 +204,7 @@
SUBDIR += icqlib0
SUBDIR += icqnix
SUBDIR += icukrell
+ SUBDIR += imcom
SUBDIR += ip-tun
SUBDIR += ip6_int
SUBDIR += ipcad
diff --git a/net/imcom/Makefile b/net/imcom/Makefile
new file mode 100644
index 000000000000..94d34addf50a
--- /dev/null
+++ b/net/imcom/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: imcom
+# Date created: Jun 09 2002
+# Whom: Martijn Lina
+#
+# $FreeBSD$
+
+PORTNAME= imcom
+PORTVERSION= 0.93
+CATEGORIES= net
+MASTER_SITES= http://imcom.floobin.cx/files/
+
+MAINTAINER= martijn@pacno.net
+
+USE_PYTHON= yes
+
+pre-install:
+ @cd ${WRKSRC} ; \
+ ${RM} -rf docs/CVS; \
+ ${RM} -rf docs/*~
+
+.include <bsd.port.mk>
diff --git a/net/imcom/distinfo b/net/imcom/distinfo
new file mode 100644
index 000000000000..2790cbe5aa0f
--- /dev/null
+++ b/net/imcom/distinfo
@@ -0,0 +1 @@
+MD5 (imcom-0.93.tar.gz) = 0e63d044c48490cb84a326a64b2760c9
diff --git a/net/imcom/files/patch-aa b/net/imcom/files/patch-aa
new file mode 100644
index 000000000000..7dfdf1d2cfa1
--- /dev/null
+++ b/net/imcom/files/patch-aa
@@ -0,0 +1,25 @@
+--- Makefile.orig Wed May 22 02:45:56 2002
++++ Makefile Wed May 22 02:47:12 2002
+@@ -1,13 +1,13 @@
+ all:
+
+ install:
+- mkdir -p /usr/local/share/imcom
+- mkdir -p /usr/local/share/imcom/docs
+- cp AutoStatus.API CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW /usr/local/share/imcom/docs
+- cp docs/* /usr/local/share/imcom/docs
+- cp *.py /usr/local/share/imcom
+- cp imcom /usr/local/bin
++ mkdir -p ${LOCALBASE}/share/imcom
++ mkdir -p ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_DATA} AutoStatus.API CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_DATA} docs/* ${LOCALBASE}/share/doc/imcom
++ ${BSD_INSTALL_SCRIPT} *.py ${LOCALBASE}/share/imcom
++ ${BSD_INSTALL_SCRIPT} imcom ${LOCALBASE}/bin
+
+ uninstall:
+- rm -rf /usr/local/share/imcom
+- rm -f /usr/local/bin/imcom
++ rm -rf ${LOCALBASE}/share/imcom
++ rm -rf ${LOCALBASE}/share/doc/imcom
++ rm -f ${LOCALBASE}/bin/imcom
diff --git a/net/imcom/pkg-comment b/net/imcom/pkg-comment
new file mode 100644
index 000000000000..24eff892a759
--- /dev/null
+++ b/net/imcom/pkg-comment
@@ -0,0 +1 @@
+IMCom is a command-line Jabber client written in Python
diff --git a/net/imcom/pkg-descr b/net/imcom/pkg-descr
new file mode 100644
index 000000000000..fd7dcc6bf895
--- /dev/null
+++ b/net/imcom/pkg-descr
@@ -0,0 +1,7 @@
+IMCom is a command-line Jabber client written in Python.
+
+Its original goal was to replace mICQ as my instant messenger. To that end it
+looks very similar to mICQ, though the actual command interpreter is a bit
+different. Commands are issued to IMCom in a style similar to IRC.
+
+WWW: http://imcom.floobin.cx/
diff --git a/net/imcom/pkg-plist b/net/imcom/pkg-plist
new file mode 100644
index 000000000000..e59db2f703b7
--- /dev/null
+++ b/net/imcom/pkg-plist
@@ -0,0 +1,35 @@
+bin/imcom
+share/doc/imcom/AutoStatus.API
+share/doc/imcom/CONTRIBUTORS
+share/doc/imcom/LICENSE
+share/doc/imcom/README
+share/doc/imcom/README.autostatus
+share/doc/imcom/TODO
+share/doc/imcom/WHATSNEW
+share/doc/imcom/CHANGELOG
+share/doc/imcom/advanced.html
+share/doc/imcom/commands.html
+share/doc/imcom/download.html
+share/doc/imcom/imcomrc.html
+share/doc/imcom/index.html
+share/doc/imcom/news.html
+share/doc/imcom/rosterlist.jpg
+share/doc/imcom/statuschange.jpg
+share/doc/imcom/style.css
+share/doc/imcom/template.html
+share/doc/imcom/whatis.html
+share/imcom/AccountCreator.py
+share/imcom/SocketWrapper.py
+share/imcom/Preferences.py
+share/imcom/LogHandler.py
+share/imcom/JabberTags.py
+share/imcom/JabberHandler.py
+share/imcom/IMCom.py
+share/imcom/IHTTPServer.py
+share/imcom/Colors.py
+share/imcom/CLI.py
+share/imcom/CICommands.py
+share/imcom/AutoStatus.py
+share/imcom/VCardTags.py
+@dirrm share/doc/imcom
+@dirrm share/imcom