aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2009-05-17 11:00:11 +0800
committernork <nork@FreeBSD.org>2009-05-17 11:00:11 +0800
commit84d41f53f7546ebe914b3833efbc1dc63425c75c (patch)
treed4fb8886461da56654e64487bbcb0037ae57c346
parentf5f24786ec61f0f9b4545b61a64a6d49125788ef (diff)
downloadfreebsd-ports-gnome-84d41f53f7546ebe914b3833efbc1dc63425c75c.tar.gz
freebsd-ports-gnome-84d41f53f7546ebe914b3833efbc1dc63425c75c.tar.zst
freebsd-ports-gnome-84d41f53f7546ebe914b3833efbc1dc63425c75c.zip
Fix HPN crash issue by using aes128-ctr, aes192-ctr and aes256-ctr.
Approved by: pav
-rw-r--r--security/openssh-portable/Makefile1
-rw-r--r--security/openssh-portable/files/openssh-5.2p1-hpn.patch6
2 files changed, 4 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 5775808665c9..e4ced895533e 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
DISTVERSION= 5.2p1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security ipv6
.if defined(OPENSSH_SNAPSHOT)
diff --git a/security/openssh-portable/files/openssh-5.2p1-hpn.patch b/security/openssh-portable/files/openssh-5.2p1-hpn.patch
index cf97fe5b0154..8faf1f9ef28c 100644
--- a/security/openssh-portable/files/openssh-5.2p1-hpn.patch
+++ b/security/openssh-portable/files/openssh-5.2p1-hpn.patch
@@ -932,9 +932,9 @@ diff -urN cipher.c cipher.c
- { "aes128-ctr", SSH_CIPHER_SSH2, 16, 16, 0, 0, evp_aes_128_ctr },
- { "aes192-ctr", SSH_CIPHER_SSH2, 16, 24, 0, 0, evp_aes_128_ctr },
- { "aes256-ctr", SSH_CIPHER_SSH2, 16, 32, 0, 0, evp_aes_128_ctr },
-+ { "aes128-ctr", SSH_CIPHER_SSH2, 16, 16, 0, evp_aes_ctr_mt },
-+ { "aes192-ctr", SSH_CIPHER_SSH2, 16, 24, 0, evp_aes_ctr_mt },
-+ { "aes256-ctr", SSH_CIPHER_SSH2, 16, 32, 0, evp_aes_ctr_mt },
++ { "aes128-ctr", SSH_CIPHER_SSH2, 16, 16, 0, 0, evp_aes_ctr_mt },
++ { "aes192-ctr", SSH_CIPHER_SSH2, 16, 24, 0, 0, evp_aes_ctr_mt },
++ { "aes256-ctr", SSH_CIPHER_SSH2, 16, 32, 0, 0, evp_aes_ctr_mt },
#ifdef USE_CIPHER_ACSS
{ "acss@openssh.org", SSH_CIPHER_SSH2, 16, 5, 0, 0, EVP_acss },
#endif