aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2011-05-13 00:56:02 +0800
committeritetcu <itetcu@FreeBSD.org>2011-05-13 00:56:02 +0800
commit8506220dd3422fcb59b118c7ee1eb6c3f3a2e8d4 (patch)
tree9630dc91ed21c87476cc384b6275a002e7ba2449
parente6b730f7d6beac14cfa89073db81b24ed64732db (diff)
downloadfreebsd-ports-gnome-8506220dd3422fcb59b118c7ee1eb6c3f3a2e8d4.tar.gz
freebsd-ports-gnome-8506220dd3422fcb59b118c7ee1eb6c3f3a2e8d4.tar.zst
freebsd-ports-gnome-8506220dd3422fcb59b118c7ee1eb6c3f3a2e8d4.zip
- Complete the move from net to net-im
- update to 2.2.0.25 - set conflicts with the otehr skype ports - OPTIONify Many thanks to: avg@, nox@, kwm@, miwi@, netchild@ and many others
-rw-r--r--MOVED1
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/skype-devel/Makefile90
-rw-r--r--net-im/skype-devel/distinfo4
-rw-r--r--net-im/skype-devel/files/pkg-message.in10
-rw-r--r--net-im/skype-devel/files/skype.sh.in3
-rw-r--r--net-im/skype-devel/pkg-descr2
-rw-r--r--net-im/skype-devel/pkg-message106
-rw-r--r--net-im/skype-devel/pkg-plist2
-rw-r--r--net/Makefile1
-rw-r--r--net/skype-devel/Makefile68
-rw-r--r--net/skype-devel/distinfo2
-rw-r--r--net/skype-devel/files/pkg-message.in10
-rw-r--r--net/skype-devel/pkg-descr5
-rw-r--r--net/skype-devel/pkg-plist134
15 files changed, 177 insertions, 262 deletions
diff --git a/MOVED b/MOVED
index 232a193744d1..0a5c3c302939 100644
--- a/MOVED
+++ b/MOVED
@@ -2177,3 +2177,4 @@ devel/hs-uvector-algorithms||2011-05-08|Removed: It is deprecated by devel/hs-ve
devel/jude-community|devel/astah-community|2011-05-09|Project was renamed
net/skype12|net-im/skype12|2011-05-09|Moved to better category
net/skype|net-im/skype|2011-05-09|Moved to better category
+net/skype-devel|net-im/skype-devel|2011-05-12|Moved to better category
diff --git a/net-im/Makefile b/net-im/Makefile
index 159f9fe5ce4c..ddb026f64e11 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -160,6 +160,7 @@
SUBDIR += sim-im
SUBDIR += sim-im-devel
SUBDIR += skype
+ SUBDIR += skype-devel
SUBDIR += skype20
SUBDIR += skype12
SUBDIR += tapioca-qt
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
index 10c22bb83ac2..6a8f1fa3a08f 100644
--- a/net-im/skype-devel/Makefile
+++ b/net-im/skype-devel/Makefile
@@ -6,63 +6,93 @@
#
PORTNAME= skype
-PORTVERSION= 2.0.0.68
-PORTREVISION= 2
-CATEGORIES= net
+PORTVERSION= 2.2.0.25
+CATEGORIES= net-im
MASTER_SITES= http://download.skype.com/linux/
PKGNAMESUFFIX= -devel
-DISTNAME= skype_static-${DISTVERSION}-oss
+DISTNAME= skype_static-${DISTVERSION}
MAINTAINER= itetcu@FreeBSD.org
-COMMENT= P2P VoIP software
+COMMENT= P2P VoIP software, development version
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20 \
- ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
+OPTIONS= VIDEO "[broken] Video sending support via multimedia/webcamd" on \
+ NVIDIA_GL "Use libGL provided by NVidia binary drivers" off
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-USE_LINUX_APPS+=dri
-.endif
+CONFLICTS= skype-1* skype-2.0* skype-2.1*
+
+NO_BUILD= yes
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS+=alsalib alsa-plugins-oss expat fontconfig libasyncns \
+ libsigcpp20
RESTRICTED= Redistribution prohibited.
-IGNORE= has moved, use net/skype instead
-
-WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}
SKYPEDIR= share/skype
PORTDOCS= LICENSE README
-SUB_FILES= pkg-message
-SUB_LIST= SKYPEDIR=${SKYPEDIR}
-PLIST_SUB= SKYPEDIR=${SKYPEDIR}
+PLIST_SUB+= SKYPEDIR=${SKYPEDIR}
+SUB_FILES= skype.sh
+SUB_LIST+= SKYPEDIR=${SKYPEDIR}
.include <bsd.port.pre.mk>
-post-patch:
- @${MV} ${WRKSRC}/skype.desktop ${WRKSRC}/skype-devel.desktop
- @${REINPLACE_CMD} -e 's|Exec=skype|Exec=skype_devel --resources=${PREFIX}/${SKYPEDIR}|' \
- ${WRKSRC}/skype-devel.desktop
+.ifdef WITH_NVIDIA_GL
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+USE_LINUX_APPS+=xorglibs
+.else
+USE_LINUX_APPS+=dri
+.endif
+
+.ifdef WITH_VIDEO
+RUN_DEPENDS+= webcamd>0:${PORTSDIR}/multimedia/webcamd
+USE_LINUX_APPS+=libv4l
+SUB_LIST+= VIDEO="LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so "
+. if ${OSVERSION} < 900036
+RUN_DEPENDS+= linux_v4l2wrapper-kmod>=1.0:${PORTSDIR}/multimedia/linux_v4l2wrapper-kmod
+. endif
+.else
+SUB_LIST+= VIDEO=""
+.endif
-do-build:
- @${BRANDELF} -t Linux ${WRKSRC}/skype
+### FIX ME, once they get bumped:
+# for 7: 704102
+# for 8: 802504
+# for HEAD: 900037
+# we need src/sys/dev/sound/pcm/dsp.c r221388
+IGNORE_MSG= needs sys/dev/sound/pcm/dsp.c r221388 (and other changes).\
+ Please update your system post
+.if ${OSVERSION} < 704102
+OUTDATED= true
+IGNORE_MSG+= r221584 / Sat May 7 09:33:37 2011 UTC
+.elif (${OSVERSION} > 800000 && ${OSVERSION} < 802503)
+OUTDATED= true
+IGNORE_MSG+= r221583 / Sat May 7 09:26:11 2011 UTC
+.elif (${OSVERSION} > 900000 && ${OSVERSION} < 900036)
+OUTDATED= true
+IGNORE_MSG+= r221388 / Tue May 3 15:50:22 2011 UTC
+.endif
+.ifdef OUTDATED
+IGNORE= ${IGNORE_MSG}
+.endif
do-install:
@${INSTALL} -d ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype-devel.desktop ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/skype-devel.desktop ${PREFIX}/share/applications/
@${INSTALL_DATA} ${WRKSRC}/icons/SkypeBlue_48x48.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype_devel
+ @cd ${WRKSRC}/ && ${MKDIR} ${PREFIX}/${SKYPEDIR} && ${COPYTREE_SHARE} "avatars icons sounds lang" ${PREFIX}/${SKYPEDIR}/
+
+# The binary main program
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/${SKYPEDIR}/
+
+# The wrapper for main program
+ @${INSTALL_SCRIPT} ${WRKDIR}/skype.sh ${PREFIX}/bin/skype-devel
@${CHMOD} a+rx ${PREFIX}/bin/skype_devel
- @cd ${WRKSRC}/&&${COPYTREE_SHARE} "avatars icons sounds lang" ${PREFIX}/${SKYPEDIR}/
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net-im/skype-devel/distinfo b/net-im/skype-devel/distinfo
index fd4524e85da6..7202cdf9dfc8 100644
--- a/net-im/skype-devel/distinfo
+++ b/net-im/skype-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (skype_static-2.0.0.68-oss.tar.bz2) = c90106e8b85af3af620ecb27e542016d1459751025a94c32466b0be73b0989f4
-SIZE (skype_static-2.0.0.68-oss.tar.bz2) = 21568297
+SHA256 (skype_static-2.2.0.25.tar.bz2) = 1025952445bd7ce97bafdb0f74decc66d217ff183ee06621eaa3a033cb910e44
+SIZE (skype_static-2.2.0.25.tar.bz2) = 30882910
diff --git a/net-im/skype-devel/files/pkg-message.in b/net-im/skype-devel/files/pkg-message.in
deleted file mode 100644
index 320c5fd18814..000000000000
--- a/net-im/skype-devel/files/pkg-message.in
+++ /dev/null
@@ -1,10 +0,0 @@
-
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
-skype_devel has been installed in:
-
-%%PREFIX%%/bin/skype_devel
-
-If you are starting from a terminal, please use the following command:
- skype_devel --resources=%%DATADIR%%
-
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/net-im/skype-devel/files/skype.sh.in b/net-im/skype-devel/files/skype.sh.in
new file mode 100644
index 000000000000..12470c8afc27
--- /dev/null
+++ b/net-im/skype-devel/files/skype.sh.in
@@ -0,0 +1,3 @@
+#!/compat/linux/bin/sh
+%%VIDEO%%%%PREFIX%%/%%SKYPEDIR%%/skype --resources=%%PREFIX%%/%%SKYPEDIR%% $@
+
diff --git a/net-im/skype-devel/pkg-descr b/net-im/skype-devel/pkg-descr
index 06e936789071..229f932bfd31 100644
--- a/net-im/skype-devel/pkg-descr
+++ b/net-im/skype-devel/pkg-descr
@@ -2,4 +2,6 @@ Skype is a free program that uses the latest P2P technology to bring
affordable and high-quality voice communications to people all over
the world.
+This is the development / beta / ... version.
+
WWW: http://www.skype.com/
diff --git a/net-im/skype-devel/pkg-message b/net-im/skype-devel/pkg-message
new file mode 100644
index 000000000000..030c4ce9c3ad
--- /dev/null
+++ b/net-im/skype-devel/pkg-message
@@ -0,0 +1,106 @@
+*******************************************************************************
+In the current version, video doesn't work. The instructions below are left in
+for completness.
+*******************************************************************************
+
+1. Minimum OS version.
+
+Skype is a Linux binary package that we run on FreeBSD via our Linux compat.
+In order for Skype to work OK, you need your kernel and modules to be:
+- post 2011-05-03 in on HEAD
+- post 2011-05-08 in on 7,8-STABLE
+The port tries to check for this, but there is a smaller or bigger interval for
+which this can't be done automatically. So in case of any trouble please make
+sure you run kernel/modules built from sources after above dates.
+Tests were only done on HEAD and 8-STALBE with linux-fc10, and I don't think it
+can work with fc4.
+
+
+2. Sound
+
+Since the OSS interface was removed, Skype now uses linux-alsa compat packages.
+By default you get one device corresponding to your default OSS dsp device (so
+Skype will use it for ringing, incoming voice and mic). If that doesn't suit
+needs, you can map the other dsp devices for example by editing
+/compat/linux/etc/alsa/pcm/pcm-oss.conf. You need to (re)start Skype after you
+edit this file in order to get Skype pick up the changes.
+Adding the following to the stock file, and then starting Skype and choosing
+in Options-->Sound Devices: Speakers: oss1
+will let you use the second dsp (usually the front panel connectors for your
+headphones, while still hearing the call ringing and other notification on the
+first dsp device (presumably the one you connect your speakers to).
+pcm.oss1 {
+ type oss
+ device /dev/dsp1
+ hint {
+ description "Open Sound System"
+ }
+}
+
+ctl.oss1 {
+ type oss
+ device /dev/mixer1
+ hint {
+ description "Open Sound System"
+ }
+}
+
+
+3. Video
+
+3.1. Receiving video
+Should work out of the box. Please make sure you have
+Options --> Video Devices --> Enable Skype Video checked.
+
+3.2. Sending video
+Skype uses /dev/videoX (usually /dev/video0). This device node is created by
+the drivers for your webcam (eg. multimedia/webcamd). If you selected the VIDEO
+option (default) multimedia/webcamd will be pulled in.
+First please make sure your webcam works with the drivers webcamd provides; you
+can use multimedia/pwcview's pwcview(1) to check that you get a good image from
+your webcam; if you get a good image, you will get video in Skype also.
+
+It also uses v4l2 interface hence you very likely need to have linux_v4l2wrapper
+kernel module (which you either have in base on recent HEAD or the port will
+install for you); you need to load the module before stating Skype:
+# kldload linux_v4l2wrapper
+To make it permanent you can:
+# echo 'linux_v4l2wrapper_load="YES"' >> /boot/loader.conf
+
+
+4. SMSes
+
+You can send SMSes with this version (provided you have Skype credit, of course).
+Check Options --> SMS for details.
+
+
+5. Screen sharing
+
+You should be able to receive and send.
+Please make sure you have Options --> Video Devices --> Enable Skype Video
+checked to use this feature (yes, even if you don't use video).
+
+
+6. Skype Access
+
+Doesn't work and it is likely not very probable it will ever work since it
+uses a lot of Linux-specific things.
+
+
+7. Next version ...
+
+.. is in net-im/skype-devel. It probably works worse that this version. Use it
+at your own risk.
+
+
+8. Problems and bug reports
+
+First of all, please understand that this is a closed, binary Linux application
+that makes use for some more-or-less cutting edge Linux features/interfaces,
+etc. As such, making it work on FreeBSD is mainly a question of keeping our
+linuxulator as close as possible to the Linux kernel, and our Linux compat
+ports up to date.
+
+When reporting problems at very least we need to know the output of:
+$ uname -a; sysctl compat.linux | head -2; grep OVERRIDE_LINUX_ /etc/make.conf
+the skype version you are using, and hardware details (eg. webcam) if related.
diff --git a/net-im/skype-devel/pkg-plist b/net-im/skype-devel/pkg-plist
index 9f1be48485d7..902444ee53b4 100644
--- a/net-im/skype-devel/pkg-plist
+++ b/net-im/skype-devel/pkg-plist
@@ -100,6 +100,8 @@ share/applications/skype-devel.desktop
%%SKYPEDIR%%/lang/skype_th.ts
%%SKYPEDIR%%/lang/skype_tr.qm
%%SKYPEDIR%%/lang/skype_tr.ts
+%%SKYPEDIR%%/lang/skype_uk.qm
+%%SKYPEDIR%%/lang/skype_uk.ts
%%SKYPEDIR%%/lang/skype_zh_s.qm
%%SKYPEDIR%%/lang/skype_zh_s.ts
%%SKYPEDIR%%/lang/skype_zh_t.qm
diff --git a/net/Makefile b/net/Makefile
index 618dfa206331..8f89fc16a0fe 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1010,7 +1010,6 @@
SUBDIR += sixxs-aiccu
SUBDIR += skstream
SUBDIR += skyfish
- SUBDIR += skype-devel
SUBDIR += skystar2
SUBDIR += sl2tps
SUBDIR += slbd
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
deleted file mode 100644
index 10c22bb83ac2..000000000000
--- a/net/skype-devel/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# New ports collection makefile for: skype-devel
-# Date created: Jun 21. 2004
-# Whom: netchild@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= skype
-PORTVERSION= 2.0.0.68
-PORTREVISION= 2
-CATEGORIES= net
-MASTER_SITES= http://download.skype.com/linux/
-PKGNAMESUFFIX= -devel
-DISTNAME= skype_static-${DISTVERSION}-oss
-
-MAINTAINER= itetcu@FreeBSD.org
-COMMENT= P2P VoIP software
-
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20 \
- ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
-
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-USE_LINUX_APPS+=dri
-.endif
-
-USE_BZIP2= yes
-USE_LINUX= yes
-RESTRICTED= Redistribution prohibited.
-
-IGNORE= has moved, use net/skype instead
-
-WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
-SKYPEDIR= share/skype
-PORTDOCS= LICENSE README
-SUB_FILES= pkg-message
-SUB_LIST= SKYPEDIR=${SKYPEDIR}
-PLIST_SUB= SKYPEDIR=${SKYPEDIR}
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${MV} ${WRKSRC}/skype.desktop ${WRKSRC}/skype-devel.desktop
- @${REINPLACE_CMD} -e 's|Exec=skype|Exec=skype_devel --resources=${PREFIX}/${SKYPEDIR}|' \
- ${WRKSRC}/skype-devel.desktop
-
-do-build:
- @${BRANDELF} -t Linux ${WRKSRC}/skype
-
-do-install:
- @${INSTALL} -d ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype-devel.desktop ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons/SkypeBlue_48x48.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype_devel
- @${CHMOD} a+rx ${PREFIX}/bin/skype_devel
- @cd ${WRKSRC}/&&${COPYTREE_SHARE} "avatars icons sounds lang" ${PREFIX}/${SKYPEDIR}/
-
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
-
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/net/skype-devel/distinfo b/net/skype-devel/distinfo
deleted file mode 100644
index fd4524e85da6..000000000000
--- a/net/skype-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (skype_static-2.0.0.68-oss.tar.bz2) = c90106e8b85af3af620ecb27e542016d1459751025a94c32466b0be73b0989f4
-SIZE (skype_static-2.0.0.68-oss.tar.bz2) = 21568297
diff --git a/net/skype-devel/files/pkg-message.in b/net/skype-devel/files/pkg-message.in
deleted file mode 100644
index 320c5fd18814..000000000000
--- a/net/skype-devel/files/pkg-message.in
+++ /dev/null
@@ -1,10 +0,0 @@
-
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
-skype_devel has been installed in:
-
-%%PREFIX%%/bin/skype_devel
-
-If you are starting from a terminal, please use the following command:
- skype_devel --resources=%%DATADIR%%
-
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/net/skype-devel/pkg-descr b/net/skype-devel/pkg-descr
deleted file mode 100644
index 06e936789071..000000000000
--- a/net/skype-devel/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Skype is a free program that uses the latest P2P technology to bring
-affordable and high-quality voice communications to people all over
-the world.
-
-WWW: http://www.skype.com/
diff --git a/net/skype-devel/pkg-plist b/net/skype-devel/pkg-plist
deleted file mode 100644
index 9f1be48485d7..000000000000
--- a/net/skype-devel/pkg-plist
+++ /dev/null
@@ -1,134 +0,0 @@
-bin/skype_devel
-share/pixmaps/skype.png
-share/applications/skype-devel.desktop
-%%SKYPEDIR%%/avatars/Angel Skype.png
-%%SKYPEDIR%%/avatars/Architect Skype.png
-%%SKYPEDIR%%/avatars/Beach Skype.png
-%%SKYPEDIR%%/avatars/Behind Skype.png
-%%SKYPEDIR%%/avatars/Business Skype.png
-%%SKYPEDIR%%/avatars/Call Me Sweetheart.png
-%%SKYPEDIR%%/avatars/Call Me.png
-%%SKYPEDIR%%/avatars/Carnaval Skype.png
-%%SKYPEDIR%%/avatars/Chic Skype.png
-%%SKYPEDIR%%/avatars/Christmas Skype.png
-%%SKYPEDIR%%/avatars/College Skype.png
-%%SKYPEDIR%%/avatars/DIY Skype.png
-%%SKYPEDIR%%/avatars/DJ Skype.png
-%%SKYPEDIR%%/avatars/Desert Skype.png
-%%SKYPEDIR%%/avatars/Designer Skype.png
-%%SKYPEDIR%%/avatars/Devil Skype.png
-%%SKYPEDIR%%/avatars/Earbud Skype.png
-%%SKYPEDIR%%/avatars/Empire Skype.png
-%%SKYPEDIR%%/avatars/Fax Skype.png
-%%SKYPEDIR%%/avatars/Geisha Skype.png
-%%SKYPEDIR%%/avatars/Hula Skype.png
-%%SKYPEDIR%%/avatars/Make Skype Not War.png
-%%SKYPEDIR%%/avatars/Metal Skype.png
-%%SKYPEDIR%%/avatars/Ninja Skype.png
-%%SKYPEDIR%%/avatars/Party Skype.png
-%%SKYPEDIR%%/avatars/Pop Skype.png
-%%SKYPEDIR%%/avatars/Rice Skype.png
-%%SKYPEDIR%%/avatars/Skypahontas.png
-%%SKYPEDIR%%/avatars/Skype 502.png
-%%SKYPEDIR%%/avatars/Skype Aid.png
-%%SKYPEDIR%%/avatars/Skype Artiste.png
-%%SKYPEDIR%%/avatars/Skype Beauty.png
-%%SKYPEDIR%%/avatars/Skype Bling.png
-%%SKYPEDIR%%/avatars/Skype Boarder.png
-%%SKYPEDIR%%/avatars/Skype Brrr... .png
-%%SKYPEDIR%%/avatars/Skype Candy.png
-%%SKYPEDIR%%/avatars/Skype Cola.png
-%%SKYPEDIR%%/avatars/Skype Cool Shades.png
-%%SKYPEDIR%%/avatars/Skype Extreme.png
-%%SKYPEDIR%%/avatars/Skype Goaaaaal.png
-%%SKYPEDIR%%/avatars/Skype Headset.png
-%%SKYPEDIR%%/avatars/Skype Jah.png
-%%SKYPEDIR%%/avatars/Skype Jyve.png
-%%SKYPEDIR%%/avatars/Skype Safety.png
-%%SKYPEDIR%%/avatars/Skype San.png
-%%SKYPEDIR%%/avatars/Skype Shorty.png
-%%SKYPEDIR%%/avatars/Skype Smiley.png
-%%SKYPEDIR%%/avatars/Skype Time.png
-%%SKYPEDIR%%/avatars/Skype in a Bag.png
-%%SKYPEDIR%%/avatars/Skype-a-Manger.png
-%%SKYPEDIR%%/avatars/Skype-ahoy.png
-%%SKYPEDIR%%/avatars/Skype-in-one.png
-%%SKYPEDIR%%/avatars/Skype.png
-%%SKYPEDIR%%/avatars/Skypers of the Caribbean.png
-%%SKYPEDIR%%/avatars/Star Skype.png
-%%SKYPEDIR%%/avatars/Sushi Skype.png
-%%SKYPEDIR%%/avatars/The Skypeness.png
-%%SKYPEDIR%%/avatars/Travel Skype.png
-%%SKYPEDIR%%/avatars/Wetsuit Skype.png
-%%SKYPEDIR%%/avatars/Yin Yang Skype.png
-%%SKYPEDIR%%/icons/SkypeBlue_16x16.png
-%%SKYPEDIR%%/icons/SkypeBlue_32x32.png
-%%SKYPEDIR%%/icons/SkypeBlue_48x48.png
-%%SKYPEDIR%%/lang/skype_bg.qm
-%%SKYPEDIR%%/lang/skype_bg.ts
-%%SKYPEDIR%%/lang/skype_de.qm
-%%SKYPEDIR%%/lang/skype_de.ts
-%%SKYPEDIR%%/lang/skype_en.qm
-%%SKYPEDIR%%/lang/skype_en.ts
-%%SKYPEDIR%%/lang/skype_es.qm
-%%SKYPEDIR%%/lang/skype_es.ts
-%%SKYPEDIR%%/lang/skype_et.qm
-%%SKYPEDIR%%/lang/skype_et.ts
-%%SKYPEDIR%%/lang/skype_fr.qm
-%%SKYPEDIR%%/lang/skype_fr.ts
-%%SKYPEDIR%%/lang/skype_it.qm
-%%SKYPEDIR%%/lang/skype_it.ts
-%%SKYPEDIR%%/lang/skype_ja.qm
-%%SKYPEDIR%%/lang/skype_ja.ts
-%%SKYPEDIR%%/lang/skype_ko.qm
-%%SKYPEDIR%%/lang/skype_ko.ts
-%%SKYPEDIR%%/lang/skype_lt.qm
-%%SKYPEDIR%%/lang/skype_lt.ts
-%%SKYPEDIR%%/lang/skype_lv.qm
-%%SKYPEDIR%%/lang/skype_lv.ts
-%%SKYPEDIR%%/lang/skype_pl.qm
-%%SKYPEDIR%%/lang/skype_pl.ts
-%%SKYPEDIR%%/lang/skype_pt_br.qm
-%%SKYPEDIR%%/lang/skype_pt_br.ts
-%%SKYPEDIR%%/lang/skype_pt_pt.qm
-%%SKYPEDIR%%/lang/skype_pt_pt.ts
-%%SKYPEDIR%%/lang/skype_ro.qm
-%%SKYPEDIR%%/lang/skype_ro.ts
-%%SKYPEDIR%%/lang/skype_ru.qm
-%%SKYPEDIR%%/lang/skype_ru.ts
-%%SKYPEDIR%%/lang/skype_th.qm
-%%SKYPEDIR%%/lang/skype_th.ts
-%%SKYPEDIR%%/lang/skype_tr.qm
-%%SKYPEDIR%%/lang/skype_tr.ts
-%%SKYPEDIR%%/lang/skype_zh_s.qm
-%%SKYPEDIR%%/lang/skype_zh_s.ts
-%%SKYPEDIR%%/lang/skype_zh_t.qm
-%%SKYPEDIR%%/lang/skype_zh_t.ts
-%%SKYPEDIR%%/sounds/CallBusy.wav
-%%SKYPEDIR%%/sounds/CallConnecting.wav
-%%SKYPEDIR%%/sounds/CallFailed.wav
-%%SKYPEDIR%%/sounds/CallHangup.wav
-%%SKYPEDIR%%/sounds/CallHold.wav
-%%SKYPEDIR%%/sounds/CallRemoteHangup.wav
-%%SKYPEDIR%%/sounds/CallResume.wav
-%%SKYPEDIR%%/sounds/CallRingingIn.wav
-%%SKYPEDIR%%/sounds/CallRingingOut.wav
-%%SKYPEDIR%%/sounds/ChatIncoming.wav
-%%SKYPEDIR%%/sounds/ChatIncomingInitial.wav
-%%SKYPEDIR%%/sounds/ChatOutgoing.wav
-%%SKYPEDIR%%/sounds/ContactAdded.wav
-%%SKYPEDIR%%/sounds/ContactAuthRequest.wav
-%%SKYPEDIR%%/sounds/ContactOffline.wav
-%%SKYPEDIR%%/sounds/ContactOnline.wav
-%%SKYPEDIR%%/sounds/SkypeLogin.wav
-%%SKYPEDIR%%/sounds/SkypeLogout.wav
-%%SKYPEDIR%%/sounds/TransferComplete.wav
-%%SKYPEDIR%%/sounds/TransferFailed.wav
-%%SKYPEDIR%%/sounds/TransferRequest.wav
-%%SKYPEDIR%%/sounds/VoicemailReceived.wav
-@dirrm %%SKYPEDIR%%/sounds
-@dirrm %%SKYPEDIR%%/lang
-@dirrm %%SKYPEDIR%%/icons
-@dirrm %%SKYPEDIR%%/avatars
-@dirrm %%SKYPEDIR%%
-@dirrmtry share/applications