aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-03-04 01:30:15 +0800
committerswills <swills@FreeBSD.org>2012-03-04 01:30:15 +0800
commit864c252dcbd785394706c95e9f045c8c578a7685 (patch)
treed23e4c5aa7a082bf02b98ce43de017d3f5b4471b
parent0faefa44bf030fbeb56a8b752d3cecae77522f6c (diff)
downloadfreebsd-ports-gnome-864c252dcbd785394706c95e9f045c8c578a7685.tar.gz
freebsd-ports-gnome-864c252dcbd785394706c95e9f045c8c578a7685.tar.zst
freebsd-ports-gnome-864c252dcbd785394706c95e9f045c8c578a7685.zip
Perl module to allow writing your unit tests in other modules than *.t
WWW: http://search.cpan.org/dist/Test-Classy/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Classy/Makefile31
-rw-r--r--devel/p5-Test-Classy/distinfo2
-rw-r--r--devel/p5-Test-Classy/pkg-descr3
-rw-r--r--devel/p5-Test-Classy/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0327747c9608..38adfe54bb3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2489,6 +2489,7 @@
SUBDIR += p5-Test-Block
SUBDIR += p5-Test-Class
SUBDIR += p5-Test-ClassAPI
+ SUBDIR += p5-Test-Classy
SUBDIR += p5-Test-Cmd
SUBDIR += p5-Test-Command
SUBDIR += p5-Test-Command-Simple
diff --git a/devel/p5-Test-Classy/Makefile b/devel/p5-Test-Classy/Makefile
new file mode 100644
index 000000000000..eacaf418bbf5
--- /dev/null
+++ b/devel/p5-Test-Classy/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Test-Classy
+# Date created: 2012-03-02
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Classy
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR= CPAN:ISHIGAKI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module to allow writing your unit tests in other modules than *.t
+
+BUILD_DEPENDS= p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-Module-Find>=0.05:${PORTSDIR}/devel/p5-Module-Find \
+ p5-Sub-Install>=0.920:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Term-Encoding>=0:${PORTSDIR}/devel/p5-Term-Encoding \
+ p5-Test-UseAllModules>=0:${PORTSDIR}/devel/p5-Test-UseAllModules
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Classy.3 Test::Classy::Base.3 Test::Classy::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Classy/distinfo b/devel/p5-Test-Classy/distinfo
new file mode 100644
index 000000000000..003c74db14d0
--- /dev/null
+++ b/devel/p5-Test-Classy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Classy-0.09.tar.gz) = eda39762825bab509728153198632f694f2b63446fc337b96c7748535756f3b6
+SIZE (Test-Classy-0.09.tar.gz) = 9827
diff --git a/devel/p5-Test-Classy/pkg-descr b/devel/p5-Test-Classy/pkg-descr
new file mode 100644
index 000000000000..34e9f583ec83
--- /dev/null
+++ b/devel/p5-Test-Classy/pkg-descr
@@ -0,0 +1,3 @@
+Perl module to allow writing your unit tests in other modules than *.t
+
+WWW: http://search.cpan.org/dist/Test-Classy/
diff --git a/devel/p5-Test-Classy/pkg-plist b/devel/p5-Test-Classy/pkg-plist
new file mode 100644
index 000000000000..186e0ecc019d
--- /dev/null
+++ b/devel/p5-Test-Classy/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Test/Classy/Base.pm
+%%SITE_PERL%%/Test/Classy/Util.pm
+%%SITE_PERL%%/Test/Classy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Classy/.packlist
+@dirrmtry %%SITE_PERL%%/Test/Classy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Classy