aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-29 11:46:06 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-29 11:46:06 +0800
commit870eb6dae99b1acbb4c3247fae0d32d27f5e091d (patch)
treefdd7d0b8934accdbc88943599f07e6c2efb5f5b6
parenta5f6236e376d27c58256f27937f28d46daf05b5b (diff)
downloadfreebsd-ports-gnome-870eb6dae99b1acbb4c3247fae0d32d27f5e091d.tar.gz
freebsd-ports-gnome-870eb6dae99b1acbb4c3247fae0d32d27f5e091d.tar.zst
freebsd-ports-gnome-870eb6dae99b1acbb4c3247fae0d32d27f5e091d.zip
Fix the CONFIGURE_ENV anti-foot-shooting measure to have the correct
quoting. It turns out that this is only an issue for ports that torture CONFIGURE_ENV to run a command as well as just set the environment (often, used to echo 'N' to fool an interactive script.) Tested on: pointyhat
-rw-r--r--Mk/bsd.perl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 55beb46bc617..408fbccfadc9 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -213,7 +213,7 @@ USE_PERL5= yes
# Disable AutoInstall from attempting to install from CPAN directly in
# the case of missing dependencies. This causes the build to loop on
# the build cluster asking for interactive input.
-CONFIGURE_ENV+= "PERL_EXTUTILS_AUTOINSTALL=--skipdeps"
+CONFIGURE_ENV+= PERL_EXTUTILS_AUTOINSTALL="--skipdeps"
.if defined(BATCH) && !defined(IS_INTERACTIVE)
CONFIGURE_ENV+= PERL_MM_USE_DEFAULT="YES"
.endif # defined(BATCH) && !defined(IS_INTERACTIVE)