aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-08 20:12:17 +0800
committermiwi <miwi@FreeBSD.org>2007-10-08 20:12:17 +0800
commit88f5ec87f1a0ab3599c41b2780c1190391ea552f (patch)
tree02d7f71728d45685568d7eb649b0635970096a7b
parent42fb7de6ca3362178aae22c870fd4abec61d46a1 (diff)
downloadfreebsd-ports-gnome-88f5ec87f1a0ab3599c41b2780c1190391ea552f.tar.gz
freebsd-ports-gnome-88f5ec87f1a0ab3599c41b2780c1190391ea552f.tar.zst
freebsd-ports-gnome-88f5ec87f1a0ab3599c41b2780c1190391ea552f.zip
- Add PulseAudio to the options
PR: 116161 Submitted by: Romain Tartiere <romain@blogreen.org> Approved by: maintainer
-rw-r--r--audio/musicpd/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 7a0c6690e63b..ea73372d08e0 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.13.0
+PORTREVISION= 1
CATEGORIES= audio ipv6
MASTER_SITES= http://musicpd.org/uploads/files/ \
http://redundancy.redundancy.org/mirror/
@@ -32,11 +33,11 @@ OPTIONS= FLAC "Support for FLAC Audio" on \
ICONV "Support for international characters" on \
ID3TAG "Support for id3v1 tag encoding" off \
IPV6 "Support for IPV6" on \
- AO "Support for libao" off
+ AO "Support for libao" off \
+ PULSE "Support for PulseAudio" off
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-pulse \
- --disable-shout
+CONFIGURE_ARGS= --disable-shout
.include <bsd.port.pre.mk>
@@ -97,6 +98,12 @@ CONFIGURE_ARGS+=--enable-ao
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
.endif
+.ifdef(WITHOUT_PULSE)
+CONFIGURE_ARGS+=--disable-pulse
+.else
+LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+.endif
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"