aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-12-09 19:19:52 +0800
committergarga <garga@FreeBSD.org>2005-12-09 19:19:52 +0800
commit8a78b3ea8c5ca0911e8fd45ec82869ababab82b7 (patch)
treea8afa3eeb6b39f14422b2d1a8ca33866187cf049
parent62fbd59a85e3275219f4fe4f80c5b23597a8d587 (diff)
downloadfreebsd-ports-gnome-8a78b3ea8c5ca0911e8fd45ec82869ababab82b7.tar.gz
freebsd-ports-gnome-8a78b3ea8c5ca0911e8fd45ec82869ababab82b7.tar.zst
freebsd-ports-gnome-8a78b3ea8c5ca0911e8fd45ec82869ababab82b7.zip
- Changed doom-data/Makefile.include to be more similar to bsd.*.mk files,
also it doesn't override port's variables. - Change dependant ports PR: ports/90123 Submitted by: maintainer
-rw-r--r--games/doom-data/Makefile2
-rw-r--r--games/doom-data/Makefile.include51
-rw-r--r--games/doom-freedoom/Makefile5
-rw-r--r--games/doom-hacx/Makefile3
-rw-r--r--games/doom-hr/Makefile5
-rw-r--r--games/doom-hr2/Makefile5
-rw-r--r--games/doom-wolfendoom/Makefile3
7 files changed, 41 insertions, 33 deletions
diff --git a/games/doom-data/Makefile b/games/doom-data/Makefile
index 4a3e9c9b5042..521ae5554a4a 100644
--- a/games/doom-data/Makefile
+++ b/games/doom-data/Makefile
@@ -9,6 +9,7 @@ PORTNAME= data
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
EXTRACT_SUFX= .bz2
DISTFILES= #
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -29,6 +30,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+DATADIR= ${DMDIR}
LIST= DOOM HERETIC HEXEN STRIFE
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
index 56fbf31b7dcc..9e40dcf3489f 100644
--- a/games/doom-data/Makefile.include
+++ b/games/doom-data/Makefile.include
@@ -1,42 +1,33 @@
# Makefile for defining variables used by other Doom related ports.
-# Determine if the port is a Doom engine.
+# Set variables.
-DMENGINES= deng doom doomlegacy prboom vavoom
+DMPKGNAMEPREFIX?=doom-
+DMDIR?= ${LOCALBASE}/share/doom
-.for f in ${DMENGINES}
-. if ${PORTNAME} == ${f}
-ENGINE= yes
-. endif
-.endfor
-
-# Package name prefix.
+# Add them to the environment.
-DMPKGNAMEPREFIX=doom-
-
-.if !defined(ENGINE)
-PKGNAMEPREFIX?= ${DMPKGNAMEPREFIX}
-.endif
+MAKE_ENV+= DMDIR="${DMDIR}"
+PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
+SUB_LIST+= DMDIR="${DMDIR}"
-# Dependency to "games/doom-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${DMDIR}:${PORTSDIR}/games/doom-data
.endif
-# Installation directories.
-
-DMDIR= ${PREFIX}/share/doom
-
-.if ${PORTNAME} == "data"
-DATADIR?= ${DMDIR}
-.endif
-
-.if ${PORTNAME} != "data" && !defined(ENGINE)
-DATADIR?= ${DMDIR}/${PORTNAME}
+# DOS to Unix text conversion.
+
+.if defined(USE_CRLF)
+. if defined(USE_ZIP)
+EXTRACT_BEFORE_ARGS= -aqo
+. else
+USE_REINPLACE= yes
+pre-patch:
+ @${FIND} ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
+ ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
+ ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+. endif
.endif
-
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= DMDIR="${DMDIR:S/${PREFIX}\///}"
-SUB_LIST+= DMDIR="${DMDIR}"
diff --git a/games/doom-freedoom/Makefile b/games/doom-freedoom/Makefile
index 441d29703ef0..cf7db7cdd25a 100644
--- a/games/doom-freedoom/Makefile
+++ b/games/doom-freedoom/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-iwad-${PORTVERSION}
MAINTAINER= alejandro@varnet.biz
@@ -18,6 +19,8 @@ COMMENT= Complete Doom-based game IWAD that is Free Software
USE_ZIP= yes
NO_BUILD= yes
+DATADIR= ${DMDIR}/${PORTNAME}
+
PLIST_FILES= %%DATADIR%%/doom2.wad
PLIST_DIRS= %%DATADIR%%
@@ -25,6 +28,6 @@ do-install:
@${MKDIR} ${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/doom2.wad ${DATADIR}
-.include "${.CURDIR}/../../games/doom-data/Makefile.include"
+.include "${.CURDIR}/../doom-data/Makefile.include"
.include <bsd.port.mk>
diff --git a/games/doom-hacx/Makefile b/games/doom-hacx/Makefile
index 00fe87bdd34f..0563d5d1fbf1 100644
--- a/games/doom-hacx/Makefile
+++ b/games/doom-hacx/Makefile
@@ -9,6 +9,7 @@ PORTNAME= hacx
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
DISTNAME= ${PORTNAME}.wad
EXTRACT_SUFX= .bz2
@@ -19,6 +20,8 @@ USE_BZIP2= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATADIR= ${DMDIR}/${PORTNAME}
+
PLIST_FILES= %%DATADIR%%/${DISTNAME}
PLIST_DIRS= %%DATADIR%%
diff --git a/games/doom-hr/Makefile b/games/doom-hr/Makefile
index 252a46db0a5d..a9add14d77df 100644
--- a/games/doom-hr/Makefile
+++ b/games/doom-hr/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= ftp://ftp.planetmirror.com/pub/idgames/themes/hr/ \
ftp://ftp.ntua.gr/pub/vendors/idgames/themes/hr/ \
http://ftp.sunet.se/pub/pc/games/idgames/themes/hr/ \
ftp://3darchives.in-span.net/pub/idgames/themes/hr/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
DISTFILES= ${PORTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -20,13 +21,15 @@ MAINTAINER= alejandro@varnet.biz
COMMENT= Hell Revealed is a megawad, a 32-level replacement for DooM II
USE_ZIP= yes
-EXTRACT_BEFORE_ARGS= -aqo
+USE_CRLF= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
OPTIONS= DEMO_NM "Install demos with -nomonsters" on \
DEMO_UV "Install Ultra-Violence demos" on
+DATADIR= ${DMDIR}/${PORTNAME}
+
post-extract:
@(cd ${WRKDIR} && ${SH} ${SCRIPTDIR}/lowercase.sh)
diff --git a/games/doom-hr2/Makefile b/games/doom-hr2/Makefile
index 0994859bba7f..99f514f6149f 100644
--- a/games/doom-hr2/Makefile
+++ b/games/doom-hr2/Makefile
@@ -9,16 +9,19 @@ PORTNAME= hr2
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.doomworld.com/hr2/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
DISTNAME= hr2final
MAINTAINER= alejandro@varnet.biz
COMMENT= Hell Revealed II is a megawad, a 32-level replacement for DooM II
USE_ZIP= yes
-EXTRACT_BEFORE_ARGS= -aqo
+USE_CRLF= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATADIR= ${DMDIR}/${PORTNAME}
+
PLIST_FILES= %%DATADIR%%/hr2final.wad
PLIST_DIRS= %%DATADIR%%
PORTDOCS= hr2final.txt
diff --git a/games/doom-wolfendoom/Makefile b/games/doom-wolfendoom/Makefile
index cc64d338b1a6..5c4e15e094b9 100644
--- a/games/doom-wolfendoom/Makefile
+++ b/games/doom-wolfendoom/Makefile
@@ -9,6 +9,7 @@ PORTNAME= wolfendoom
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
DISTNAME= ${PORTNAME}
MAINTAINER= alejandro@varnet.biz
@@ -18,6 +19,8 @@ USE_BZIP2= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATADIR= ${DMDIR}/${PORTNAME}
+
.include "${.CURDIR}/../doom-data/Makefile.include"
.include <bsd.port.pre.mk>