aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2000-12-18 18:17:22 +0800
committerdemon <demon@FreeBSD.org>2000-12-18 18:17:22 +0800
commit8ad28e239e06d409f4402b007c5a73fbb55ec6e3 (patch)
tree7a88969d8c2836ba50ea1d41fc1eb774892cb7c1
parentd45ec6b4ab7137bcf3529a0e381595caa1e9385d (diff)
downloadfreebsd-ports-gnome-8ad28e239e06d409f4402b007c5a73fbb55ec6e3.tar.gz
freebsd-ports-gnome-8ad28e239e06d409f4402b007c5a73fbb55ec6e3.tar.zst
freebsd-ports-gnome-8ad28e239e06d409f4402b007c5a73fbb55ec6e3.zip
GLPK -- GNU Linear Programming Kit.
Approved by: sobomax
-rw-r--r--math/Makefile1
-rw-r--r--math/glpk/Makefile18
-rw-r--r--math/glpk/distinfo1
-rw-r--r--math/glpk/files/patch-Makefile.in11
-rw-r--r--math/glpk/pkg-comment1
-rw-r--r--math/glpk/pkg-descr8
-rw-r--r--math/glpk/pkg-plist16
7 files changed, 56 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 12aff69347d4..c9c1478d0aed 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -22,6 +22,7 @@
SUBDIR += fudgit
SUBDIR += geg
SUBDIR += glove
+ SUBDIR += glpk
SUBDIR += gnumeric
SUBDIR += gnuplot
SUBDIR += gnuplot+
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
new file mode 100644
index 000000000000..032e7def8d31
--- /dev/null
+++ b/math/glpk/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: GLPK
+# Date created: 16 December 2000
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glpk
+PORTVERSION= 1.1.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= glpk
+
+MAINTAINER= demon@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/glpk/distinfo b/math/glpk/distinfo
new file mode 100644
index 000000000000..7ae6676fdf35
--- /dev/null
+++ b/math/glpk/distinfo
@@ -0,0 +1 @@
+MD5 (glpk-1.1.1.tar.gz) = 284ad7adab12efc6d4a2648d9fb322d0
diff --git a/math/glpk/files/patch-Makefile.in b/math/glpk/files/patch-Makefile.in
new file mode 100644
index 000000000000..9a4cd80416ec
--- /dev/null
+++ b/math/glpk/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Dec 16 23:18:41 2000
++++ Makefile.in Sat Dec 16 23:19:44 2000
+@@ -294,8 +294,6 @@
+ for i in $(HDRS); do \
+ $(INSTALL_DATA) $(srcdir)/include/$$i \
+ $(DESTDIR)$(includedir)/$$i; \
+- $(INSTALL_DATA) $(srcdir)/include/$$i \
+- $(DESTDIR)$(oldincludedir)/$$i; \
+ done
+ $(INSTALL_DATA) libglpk.a $(DESTDIR)$(libdir)/libglpk.a
+
diff --git a/math/glpk/pkg-comment b/math/glpk/pkg-comment
new file mode 100644
index 000000000000..080e181fc15f
--- /dev/null
+++ b/math/glpk/pkg-comment
@@ -0,0 +1 @@
+A GNU Linear Programming Kit
diff --git a/math/glpk/pkg-descr b/math/glpk/pkg-descr
new file mode 100644
index 000000000000..3d6ef5852581
--- /dev/null
+++ b/math/glpk/pkg-descr
@@ -0,0 +1,8 @@
+GLPK -- GNU Linear Programming Kit.
+
+The GLPK package is intended for solving large scale linear programming
+problems by means of the revised simplex method. It is a set of routines
+organized in the form of a library and written in the ANSI C programming
+language.
+
+WWW: http://www.gnu.org/software/glpk/glpk.html
diff --git a/math/glpk/pkg-plist b/math/glpk/pkg-plist
new file mode 100644
index 000000000000..61f41ebdaba7
--- /dev/null
+++ b/math/glpk/pkg-plist
@@ -0,0 +1,16 @@
+include/glpapi.h
+include/glpavl.h
+include/glpduff.h
+include/glpefi.h
+include/glpeta.h
+include/glpgel.h
+include/glphbsm.h
+include/glpimg.h
+include/glpk.h
+include/glpmat.h
+include/glpmps.h
+include/glprfi.h
+include/glprsm.h
+include/glpset.h
+include/glpstr.h
+lib/libglpk.a