aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-02-18 19:41:57 +0800
committergarga <garga@FreeBSD.org>2009-02-18 19:41:57 +0800
commit8ff6deb4a093ccf1e10b33c313bc97d19fc632ed (patch)
tree232bbab37eee219ab5dbfef68ecbf0f216a2b453
parent26506dff5fdcda6798b6fdb00dd61b1c976f79e0 (diff)
downloadfreebsd-ports-gnome-8ff6deb4a093ccf1e10b33c313bc97d19fc632ed.tar.gz
freebsd-ports-gnome-8ff6deb4a093ccf1e10b33c313bc97d19fc632ed.tar.zst
freebsd-ports-gnome-8ff6deb4a093ccf1e10b33c313bc97d19fc632ed.zip
- Update to 20090218
- All clamav-milter command line parameters were moved to clamav-milter.conf, modify startup script acordingly - Remove pidfile from clamd startup script since this can be changed in clamav-clamd.conf
-rw-r--r--security/clamav-devel/Makefile15
-rw-r--r--security/clamav-devel/distinfo6
-rw-r--r--security/clamav-devel/files/clamav-clamd.in1
-rw-r--r--security/clamav-devel/files/clamav-milter.in8
-rw-r--r--security/clamav-devel/files/patch-etc_Makefile.in11
-rw-r--r--security/clamav-devel/pkg-plist3
6 files changed, 27 insertions, 17 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index fcd0bbb42c19..237178c587c0 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 20090107
+PORTVERSION= 20090218
CATEGORIES= security
MASTER_SITES= http://www.clamav.net/snapshot/ \
${MASTER_SITE_LOCAL}
@@ -93,7 +93,7 @@ SUB_LIST+= DBDIR=${DBDIR} \
SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?((Update)?LogFile) .*/([a-z]+\.log)$$|\1 ${LOGDIR}/\3|' \
- -e 's|^\#?(PidFile) .*/([a-z]+\.pid)$$|\1 ${RUNDIR}/\2|' \
+ -e 's|^\#?(PidFile) .*/([a-z\-]+\.pid)$$|\1 ${RUNDIR}/\2|' \
-e 's|^\#?(LocalSocket) .*$$|\1 ${CLAMAV_CLAMD_SOCKET}|' \
-e 's|^\#?(User) .*$$|\1 ${CLAMAVUSER}|' \
-e 's|^\#?(AllowSupplementaryGroups).*$$|\1 yes|' \
@@ -101,7 +101,9 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(DatabaseDirectory) .*$$|\1 ${DBDIR}|' \
-e 's|^\#?(DatabaseOwner) .*$$|\1 ${CLAMAVUSER}|' \
-e 's|^\#?(FixStaleSocket).*$$|\1 yes|' \
- -e 's|^\#?(NotifyClamd) .*$$|\1 ${PREFIX}/etc/clamd.conf|'
+ -e 's|^\#?(NotifyClamd) .*$$|\1 ${PREFIX}/etc/clamd.conf|' \
+ -e 's|^\#?(MilterSocket) */tmp.*$$|\1 ${CLAMAV_MILTER_SOCKET}|' \
+ -e 's|^\#?(ClamdSocket).*$$|\1 unix:${CLAMAV_CLAMD_SOCKET}|'
PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
CLAMAVGROUP=${CLAMAVGROUP}
@@ -162,9 +164,12 @@ post-patch:
${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -E 's,^(pkgconfigdir = ).*$$,\1$$(prefix)/libdata/pkgconfig,g' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/PidFile *\/var\/run\/clamd.pid/ s,clamd.pid,clamav-milter.pid,' \
+ ${WRKSRC}/etc/clamav-milter.conf
@${REINPLACE_CMD} ${SED_CONF} \
${WRKSRC}/etc/clamd.conf \
- ${WRKSRC}/etc/freshclam.conf
+ ${WRKSRC}/etc/freshclam.conf \
+ ${WRKSRC}/etc/clamav-milter.conf
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
@@ -173,7 +178,7 @@ pre-su-install:
post-install:
${INSTALL_DATA} ${WRKSRC}/clamav-config.h ${PREFIX}/include
-.for c in clamd freshclam
+.for c in clamd freshclam clamav-milter
@[ -f ${PREFIX}/etc/${c}.conf ] || \
${CP} -v ${PREFIX}/etc/${c}.conf.default ${PREFIX}/etc/${c}.conf
.endfor
diff --git a/security/clamav-devel/distinfo b/security/clamav-devel/distinfo
index c0914a72a63b..396ea1db275d 100644
--- a/security/clamav-devel/distinfo
+++ b/security/clamav-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (clamav-devel-20090107.tar.gz) = 6b32406df64abf8bb699bb9b97c4a54d
-SHA256 (clamav-devel-20090107.tar.gz) = f1c66e8776fa5f64e154c77535fc9728a9a023670c8177c1de80105a003822c1
-SIZE (clamav-devel-20090107.tar.gz) = 3652856
+MD5 (clamav-devel-20090218.tar.gz) = 0dcf2c59a71b5935c79f8a9c5aa085c0
+SHA256 (clamav-devel-20090218.tar.gz) = 39fa1c127c0c94a4abd65bf75e41b1c7327147731fb20ed65db81193320253e5
+SIZE (clamav-devel-20090218.tar.gz) = 3788073
diff --git a/security/clamav-devel/files/clamav-clamd.in b/security/clamav-devel/files/clamav-clamd.in
index 657c2619398a..d6302f77d397 100644
--- a/security/clamav-devel/files/clamav-clamd.in
+++ b/security/clamav-devel/files/clamav-clamd.in
@@ -22,7 +22,6 @@ name=clamav_clamd
rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/clamd
-pidfile=%%RUNDIR%%/clamd.pid
required_dirs=%%DBDIR%%
required_files=%%PREFIX%%/etc/clamd.conf
diff --git a/security/clamav-devel/files/clamav-milter.in b/security/clamav-devel/files/clamav-milter.in
index cb467c53f333..53450d44903e 100644
--- a/security/clamav-devel/files/clamav-milter.in
+++ b/security/clamav-devel/files/clamav-milter.in
@@ -21,10 +21,10 @@
name=clamav_milter
rcvar=`set_rcvar`
+conf_file=%%PREFIX%%/etc/clamav-milter.conf
command=%%PREFIX%%/sbin/clamav-milter
-pidfile=%%RUNDIR%%/clamav-milter.pid
required_dirs=%%DBDIR%%
-required_files=%%PREFIX%%/etc/clamd.conf
+required_files=${conf_file}
start_precmd=start_precmd
start_postcmd=start_postcmd
@@ -35,7 +35,7 @@ start_precmd()
warn "Stale socket $clamav_milter_socket removed."
rm "$clamav_milter_socket"
fi
- rc_flags="--pidfile ${pidfile} ${flags:-$clamav_milter_flags} $clamav_milter_socket"
+ rc_flags="${flags:-$clamav_milter_flags}"
clamav_clamd_socket_prefix=${clamav_clamd_socket%:*}
# We can have inet or inet6, try to remove 6
@@ -93,7 +93,7 @@ start_postcmd()
load_rc_config $name
: ${clamav_milter_enable="NO"}
: ${clamav_milter_socket="%%CLAMAV_MILTER_SOCKET%%"}
-: ${clamav_milter_flags="--postmaster-only --local --outgoing --timeout=0 --max-children=50"}
+: ${clamav_milter_flags="-c ${conf_file}"}
: ${clamav_milter_socktimeout="60"}
: ${clamav_milter_socket_mode="755"}
: ${clamav_milter_socket_user="%%CLAMAVUSER%%"}
diff --git a/security/clamav-devel/files/patch-etc_Makefile.in b/security/clamav-devel/files/patch-etc_Makefile.in
index e47b65443c8e..336f5667c3e3 100644
--- a/security/clamav-devel/files/patch-etc_Makefile.in
+++ b/security/clamav-devel/files/patch-etc_Makefile.in
@@ -1,15 +1,18 @@
---- etc/Makefile.in.orig Thu Feb 19 14:17:02 2004
-+++ etc/Makefile.in Thu Feb 19 14:17:36 2004
-@@ -333,10 +333,8 @@
+--- etc/Makefile.in.orig 2009-02-17 22:43:14.000000000 -0300
++++ etc/Makefile.in 2009-02-18 08:14:54.000000000 -0300
+@@ -393,12 +393,9 @@
- install:
+ install-data-local:
$(mkinstalldirs) $(DESTDIR)$(CFGINST)
- @test -f $(DESTDIR)$(CFGINST)/clamd.conf || \
- $(INSTALL_DATA) $(srcdir)/clamd.conf $(DESTDIR)$(CFGINST)
- @test -f $(DESTDIR)$(CFGINST)/freshclam.conf || \
- $(INSTALL_DATA) $(srcdir)/freshclam.conf $(DESTDIR)$(CFGINST)
+-@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@ @test -f $(DESTDIR)$(CFGINST)/clamav-milter.conf || \
+-@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@ $(INSTALL_DATA) $(srcdir)/clamav-milter.conf $(DESTDIR)$(CFGINST)
+ $(INSTALL_DATA) $(srcdir)/clamd.conf $(DESTDIR)$(CFGINST)/clamd.conf.default
+ $(INSTALL_DATA) $(srcdir)/freshclam.conf $(DESTDIR)$(CFGINST)/freshclam.conf.default
++@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@ $(INSTALL_DATA) $(srcdir)/clamav-milter.conf $(DESTDIR)$(CFGINST)/clamav-milter.conf.default
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
diff --git a/security/clamav-devel/pkg-plist b/security/clamav-devel/pkg-plist
index 14782ee9bb4c..77bf2009df5a 100644
--- a/security/clamav-devel/pkg-plist
+++ b/security/clamav-devel/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/clamav-config
+bin/clamconf
bin/clamscan
bin/clamdscan
bin/freshclam
@@ -26,6 +27,8 @@ etc/clamd.conf.default
@exec [ -f %B/clamd.conf ] || cp %B/%f %B/clamd.conf
@unexec if cmp -s %D/etc/freshclam.conf %D/etc/freshclam.conf.default; then rm -f %D/etc/freshclam.conf; fi
etc/freshclam.conf.default
+%%CLAMAV-MILTER%%@unexec if cmp -s %D/etc/clamav-milter.conf %D/etc/clamav-milter.conf.default; then rm -f %D/etc/clamav-milter.conf; fi
+%%CLAMAV-MILTER%%etc/clamav-milter.conf.default
@exec [ -f %B/freshclam.conf ] || cp %B/%f %B/freshclam.conf
@unexec [ -s %%DBDIR%%/daily.cvd ] || rm -f %%DBDIR%%/daily.cvd || true
@unexec [ -s %%DBDIR%%/main.cvd ] || rm -f %%DBDIR%%/main.cvd || true