aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-02-25 11:47:55 +0800
committerkoobs <koobs@FreeBSD.org>2015-02-25 11:47:55 +0800
commit9013dfe4554c1c8d9c5a9222a469a39e14d00150 (patch)
tree1b96687e3e788a30311b4b8b59d5a4e2044037ff
parent35d758ac025ff9831703ba119a8ac3e3b5ab004b (diff)
downloadfreebsd-ports-gnome-9013dfe4554c1c8d9c5a9222a469a39e14d00150.tar.gz
freebsd-ports-gnome-9013dfe4554c1c8d9c5a9222a469a39e14d00150.tar.zst
freebsd-ports-gnome-9013dfe4554c1c8d9c5a9222a469a39e14d00150.zip
devel/py-pytest: Update to 2.6.4
- Update to 2.6.4 - Update COMMENT to reflect upstream description (setup.py) - Update RUN_DEPENDS and TEST_DEPENDS - Add TESTS option - Update pkg-descr for more detail on features Approved by: python (with hat)
-rw-r--r--devel/py-pytest/Makefile16
-rw-r--r--devel/py-pytest/distinfo4
-rw-r--r--devel/py-pytest/pkg-descr15
3 files changed, 27 insertions, 8 deletions
diff --git a/devel/py-pytest/Makefile b/devel/py-pytest/Makefile
index c94dee708940..9e08b23e02fd 100644
--- a/devel/py-pytest/Makefile
+++ b/devel/py-pytest/Makefile
@@ -1,24 +1,30 @@
# $FreeBSD$
PORTNAME= pytest
-PORTVERSION= 2.6.1
-PORTREVISION= 1
+PORTVERSION= 2.6.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
-COMMENT= Mature full-featured Python testing tool
+COMMENT= Simple powerful testing with Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.4.22:${PORTSDIR}/devel/py-py
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.4.25:${PORTSDIR}/devel/py-py
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}pexpect>0:${PORTSDIR}/misc/py-pexpect
USES= python
USE_PYTHON= autoplist distutils
+OPTIONS_DEFINE= TESTS
+
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/devel/py-pytest/distinfo b/devel/py-pytest/distinfo
index 31a7c8bfff0e..ab6e0d68b35a 100644
--- a/devel/py-pytest/distinfo
+++ b/devel/py-pytest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pytest-2.6.1.tar.gz) = 994dabcb3149659d259add2aa7d11bff4d35efb7cf4c8233fa9b0b62c1255c3c
-SIZE (pytest-2.6.1.tar.gz) = 627761
+SHA256 (pytest-2.6.4.tar.gz) = 550883b98184cef6cbb980d4d90051330aeae41075092f98ef0215719af8ef33
+SIZE (pytest-2.6.4.tar.gz) = 512090
diff --git a/devel/py-pytest/pkg-descr b/devel/py-pytest/pkg-descr
index 597bbc7a5e65..d8c79689f189 100644
--- a/devel/py-pytest/pkg-descr
+++ b/devel/py-pytest/pkg-descr
@@ -1,3 +1,16 @@
-py.test is a simple and popular testing tool for Python.
+The pytest testing tool makes it easy to write small tests, yet scales to
+support complex functional testing.
+
+Features:
+
+ * Auto-discovery of test modules and functions
+ * Detailed info on failing assert statements
+ * Modular fixtures for managing small or parametrized long-lived test
+ resources
+ * Multi-paradigm support: you can use pytest to run test suites based on
+ unittest (or trial), nose
+ * Single-source compatibility from Python2.6 all the way up to Python3.4,
+ PyPy-2.3, (jython-2.5 untested)
+ * Many external plugins
WWW: http://pytest.org