aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2010-11-02 07:15:59 +0800
committerrene <rene@FreeBSD.org>2010-11-02 07:15:59 +0800
commit906c4275976f5b33113b5b825e5e21e0097ab637 (patch)
tree70bf74f51b0ca8914879d720c6b163fc11298f29
parent58df413787cdbbd822af378ac47303977c5d3690 (diff)
downloadfreebsd-ports-gnome-906c4275976f5b33113b5b825e5e21e0097ab637.tar.gz
freebsd-ports-gnome-906c4275976f5b33113b5b825e5e21e0097ab637.tar.zst
freebsd-ports-gnome-906c4275976f5b33113b5b825e5e21e0097ab637.zip
- Fix build on CURRENT
- Borrow sources from dns/libbind instead of dns/bind95 - Add license PR: ports/151873 Submitted by: maintainer
-rw-r--r--mail/enma/Makefile18
-rw-r--r--mail/enma/files/patch-enma_src_addr_util.c10
2 files changed, 18 insertions, 10 deletions
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 81bb9eeb15a2..43b4477f02c6 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= SF/${PORTNAME}/ENMA/${PORTVERSION}
MAINTAINER= umq@ueo.co.jp
COMMENT= A sender authentication milter supporting SPF and Sender ID
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/dns/bind95:checksum
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/dns/libbind:checksum
.if defined(WITH_POSTFIX_MILTER) || defined(WITH_POSTFIX) || defined(WITH_POSTFIX_CURRENT)
CONF_SUB= ${REINPLACE_CMD} -e '/milter\.postfix/s/false/true/' ${WRKSRC}/enma/etc/enma.conf.sample
@@ -24,7 +24,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
.endif
.endif
-BIND_PATH_CMD= cd ${PORTSDIR}/dns/bind95 && ${MAKE} -V WRKSRC
+BIND_PATH_CMD= cd ${PORTSDIR}/dns/libbind && ${MAKE} -V WRKSRC
BIND_SRC_DIR= ${BASENAME} $$(${BIND_PATH_CMD})
HAS_CONFIGURE= yes
@@ -32,6 +32,8 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PREFIX}/man \
--with-libbind=${WRKSRC}/build/tmp_build
USE_RC_SUBR= milter-enma
USE_GMAKE= yes
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
MANLANG= "" ja_JP.UTF-8
MAN1= enma.1
MANCOMPRESSED= no
@@ -42,10 +44,6 @@ SUB_FILES= milter-enma
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
-.if ${OSVERSION} >= 900007
-BROKEN= does not build
-.endif
-
USE_OPENSSL= yes
.if ${OSVERSION} < 700000
WITH_OPENSSL_PORT= yes
@@ -53,9 +51,9 @@ WITH_OPENSSL_PORT= yes
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
pre-configure:
- cd ${PORTSDIR}/dns/bind95 && ${MAKE} -DBATCH patch && \
+ cd ${PORTSDIR}/dns/libbind && ${MAKE} -DBATCH patch && \
${LN} -s $$(${BIND_PATH_CMD}) ${WRKSRC}/build && \
- cd ${WRKSRC}/build/$$(${BIND_SRC_DIR})/lib/bind && \
+ cd ${WRKSRC}/build/$$(${BIND_SRC_DIR}) && \
./configure --prefix=${WRKSRC}/build/tmp_build --enable-threads && ${MAKE} && ${MAKE} install
$$(${CONF_SUB})
@@ -67,7 +65,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
- @${ECHO_CMD} "@unexec rmdir %D/man/ja_JP.UTF-8/man1 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/man/ja_JP.UTF-8 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} %D/man/ja_JP.UTF-8/man1 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} %D/man/ja_JP.UTF-8 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/mail/enma/files/patch-enma_src_addr_util.c b/mail/enma/files/patch-enma_src_addr_util.c
new file mode 100644
index 000000000000..e02d6a9c923d
--- /dev/null
+++ b/mail/enma/files/patch-enma_src_addr_util.c
@@ -0,0 +1,10 @@
+--- ./enma/src/addr_util.c.orig 2009-03-27 15:06:08.000000000 +0900
++++ ./enma/src/addr_util.c 2010-10-21 09:28:43.000000000 +0900
+@@ -18,6 +18,7 @@
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>