aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-03-19 20:00:09 +0800
committermakc <makc@FreeBSD.org>2009-03-19 20:00:09 +0800
commit918561dca84dcf5b229d283ef5443a318e6e180b (patch)
tree3b84262a10da6e0f79bc7dfb34fe01bf04afbfe2
parenteda06de155f7a2b45330e6291d465ac11cc13af3 (diff)
downloadfreebsd-ports-gnome-918561dca84dcf5b229d283ef5443a318e6e180b.tar.gz
freebsd-ports-gnome-918561dca84dcf5b229d283ef5443a318e6e180b.tar.zst
freebsd-ports-gnome-918561dca84dcf5b229d283ef5443a318e6e180b.zip
Add new port security/qca-cyrus-sasl:
QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions. This port installs Cyrus SASL plugin. WWW: http://delta.affinix.com/qca/
-rw-r--r--security/qca-cyrus-sasl/Makefile37
-rw-r--r--security/qca-cyrus-sasl/distinfo3
-rw-r--r--security/qca-cyrus-sasl/pkg-descr6
-rw-r--r--security/qca-cyrus-sasl/pkg-plist5
4 files changed, 51 insertions, 0 deletions
diff --git a/security/qca-cyrus-sasl/Makefile b/security/qca-cyrus-sasl/Makefile
new file mode 100644
index 000000000000..7d1fbd02fc71
--- /dev/null
+++ b/security/qca-cyrus-sasl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: qca-cyrus-sasl
+# Date created: 2009-03-19
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qca-cyrus-sasl
+DISTVERSION= 2.0.0-beta3
+CATEGORIES= security
+MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= QCA Cyrus SASL plugin
+
+LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca \
+ sasl2:${PORTSDIR}/security/cyrus-sasl2
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib qmake_build moc_build
+HAS_CONFIGURE= yes
+QT_NONSTANDARD= yes
+CONFIGURE_ARGS+=--plugins-path=${PREFIX}/${QT_PLUGINDIR_REL}
+
+.if !defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--release --no-separate-debug-info
+PLIST_SUB+= DEBUG="@comment "
+.else
+CONFIGURE_ARGS+=--debug
+PLIST_SUB+= DEBUG=""
+.endif
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/${QT_PLUGINDIR_REL}/libqca-cyrus-sasl.so
+
+.include <bsd.port.mk>
diff --git a/security/qca-cyrus-sasl/distinfo b/security/qca-cyrus-sasl/distinfo
new file mode 100644
index 000000000000..d2d3e8dafc4a
--- /dev/null
+++ b/security/qca-cyrus-sasl/distinfo
@@ -0,0 +1,3 @@
+MD5 (qca-cyrus-sasl-2.0.0-beta3.tar.bz2) = db51df751478f60416659809e11990fd
+SHA256 (qca-cyrus-sasl-2.0.0-beta3.tar.bz2) = d4370c238808811a0b5e9367069296a6330b169f091c5ea5d4d18eedb6bb11b9
+SIZE (qca-cyrus-sasl-2.0.0-beta3.tar.bz2) = 24075
diff --git a/security/qca-cyrus-sasl/pkg-descr b/security/qca-cyrus-sasl/pkg-descr
new file mode 100644
index 000000000000..8a947d048f34
--- /dev/null
+++ b/security/qca-cyrus-sasl/pkg-descr
@@ -0,0 +1,6 @@
+QCA aims to provide a straightforward and cross-platform crypto API,
+using Qt datatypes and conventions.
+
+This port installs Cyrus SASL plugin.
+
+WWW: http://delta.affinix.com/qca/
diff --git a/security/qca-cyrus-sasl/pkg-plist b/security/qca-cyrus-sasl/pkg-plist
new file mode 100644
index 000000000000..1790d984240b
--- /dev/null
+++ b/security/qca-cyrus-sasl/pkg-plist
@@ -0,0 +1,5 @@
+%%QT_PLUGINDIR_REL%%/crypto/libqca-cyrus-sasl.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/crypto/libqca-cyrus-sasl.so.debug
+@dirrmtry %%QT_PLUGINDIR_REL%%/crypto
+@dirrmtry %%QT_PLUGINDIR_REL%%
+