aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-05-16 11:31:46 +0800
committerperky <perky@FreeBSD.org>2003-05-16 11:31:46 +0800
commit92b744403f25ac5c434673317a5a36337a74ec6d (patch)
tree41742d91603d31c7d569db7635b4ad437c3e4aca
parented47a7d05caec4e0892308e95fc240ba52359881 (diff)
downloadfreebsd-ports-gnome-92b744403f25ac5c434673317a5a36337a74ec6d.tar.gz
freebsd-ports-gnome-92b744403f25ac5c434673317a5a36337a74ec6d.tar.zst
freebsd-ports-gnome-92b744403f25ac5c434673317a5a36337a74ec6d.zip
Add two build fixes for ia64 but still does not build for this:
t-asm.S:111: Error: Operand 3 of `cmp.eq' should be a general register So, mark BROKEN for ia64.
-rw-r--r--devel/py-ctypes/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/devel/py-ctypes/Makefile b/devel/py-ctypes/Makefile
index dd8213c63f05..861c0656fae1 100644
--- a/devel/py-ctypes/Makefile
+++ b/devel/py-ctypes/Makefile
@@ -30,6 +30,12 @@ LIBFFIWRKSRC= ${WRKDIR}/libffi-${LIBFFIVERSION}
CONFIGURE_ARGS= --enable-static --disable-shared
CONFIGURE_WRKSRC=${LIBFFIWRKSRC}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64"
+BROKEN= "does not build"
+.endif
+
post-patch:
${LN} -sf ${LIBFFIWRKSRC}/config-ml.in ${LIBFFIWRKSRC}/..
${REINPLACE_CMD} -e 's|\(include_dirs = \).*|\1["${LIBFFIWRKSRC}/include"]|' \
@@ -37,8 +43,13 @@ post-patch:
-e 's|\(Extension(.*\)$$|\1 define_macros=[("ffi_type_schar", \
"ffi_type_sint8"), ("ffi_type_sshort","ffi_type_sint16")],|' \
${WRKSRC}/setup.py
+.if ${ARCH} == "ia64"
+ ${LN} -sf ${LIBFFIWRKSRC}/${ARCH}/${ARCH}_flags.h ${LIBFFIWRKSRC}/
+ ${REINPLACE_CMD} -e 's|defined(IA64)|defined(__ia64__)|' \
+ ${LIBFFIWRKSRC}/include/ffi.h
+.endif
pre-build:
cd ${LIBFFIWRKSRC}; ${MAKE_ENV} ${GMAKE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>