aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-03-08 21:59:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-03-08 21:59:19 +0800
commit93e93124ebb909ccbe0cb35c0ef33593a6088bf7 (patch)
tree7ee29b7a69e711279c3fccdb56b061e97ab1fcc2
parentc1e4e2250f854495975d134dabfdb8e5c2af8291 (diff)
downloadfreebsd-ports-gnome-93e93124ebb909ccbe0cb35c0ef33593a6088bf7.tar.gz
freebsd-ports-gnome-93e93124ebb909ccbe0cb35c0ef33593a6088bf7.tar.zst
freebsd-ports-gnome-93e93124ebb909ccbe0cb35c0ef33593a6088bf7.zip
Fix build on 9.1+
-rw-r--r--games/diameter/Makefile11
-rw-r--r--games/diameter/files/patch-src-uni.h18
2 files changed, 21 insertions, 8 deletions
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
index e89004ce1221..4a812f026dc5 100644
--- a/games/diameter/Makefile
+++ b/games/diameter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: diameter
-# Date created: 15 Jun 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= diameter
PORTVERSION= 0.4.0.3
@@ -14,9 +10,8 @@ MASTER_SITES= SF/game${PORTNAME}/game${PORTNAME}/${PORTNAME}-0.4.0
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Arcade-style game with elements of economy and adventure
-BUILD_DEPENDS= guichan>=0.8.1:${PORTSDIR}/devel/guichan
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
+ guichan:${PORTSDIR}/devel/guichan
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/games/diameter/files/patch-src-uni.h b/games/diameter/files/patch-src-uni.h
new file mode 100644
index 000000000000..f9d5c5142ef0
--- /dev/null
+++ b/games/diameter/files/patch-src-uni.h
@@ -0,0 +1,18 @@
+--- src/uni.h.orig 2008-07-31 15:22:38.000000000 +0400
++++ src/uni.h 2013-03-04 02:09:01.580934046 +0400
+@@ -1,6 +1,7 @@
+ #ifndef UNI
+ #define UNI
+ #include <iostream>
++#include <stdint.h>
+
+ struct Options
+ {
+@@ -15,6 +16,7 @@
+ //#define DEBUG
+ //#define CVS
+
++#undef __WORDSIZE
+
+ #ifdef __WORDSIZE
+ #else