aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-10-18 05:34:35 +0800
committerjgh <jgh@FreeBSD.org>2012-10-18 05:34:35 +0800
commit94d39063535a4004781d74fedc93c07c6eaeffce (patch)
treee22cb9412b3e929b29252267ee770df3928cb8cf
parentf3d32439c86ed28520f105660acd7354fda80a01 (diff)
downloadfreebsd-ports-gnome-94d39063535a4004781d74fedc93c07c6eaeffce.tar.gz
freebsd-ports-gnome-94d39063535a4004781d74fedc93c07c6eaeffce.tar.zst
freebsd-ports-gnome-94d39063535a4004781d74fedc93c07c6eaeffce.zip
- unbreak rc script and cleanup, convert to optionsNG
PR: 172748 Submitted by: jgh@ Spotted by: lasse@bitmand.com (private mail) Approved by: maintainer, 5u623l20@gmail.com Feature safe: yes
-rw-r--r--www/resin3/Makefile16
-rw-r--r--www/resin3/files/resin3.in12
2 files changed, 13 insertions, 15 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 73392c1d7124..a8e1ae1d5511 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -1,20 +1,18 @@
-# New ports collection makefile for: resin3
-# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
-# Date Created: 2003-09-29 14:17:14
+# Created by: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
#
# $FreeBSD$
-#
PORTNAME= resin
PORTVERSION= 3.1.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
MAINTAINER= 5u623l20@gmail.com
-COMMENT= Resin, a Java-based Application Server, 3.x branch
+COMMENT= Java-based Application Server, 3.x branch
-OPTIONS= APACHE22 "Use Apache 2.2" off
+OPTIONS_DEFINE= APACHE22
+APACHE22_DESC= Use Apache 2.2
.include <bsd.port.options.mk>
@@ -59,7 +57,7 @@ LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
CONFIGURE_ENV= LD=${CC} PTHREAD_LIBS="${PTHREAD_LIBS}" LIBTOOL=${LIBTOOL}
# Install the Apache plugin if needed
-.if defined(WITH_APACHE22)
+.if ${PORT_OPTIONS:MAPACHE22}
BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache22
CONFIGURE_ARGS+= --with-apxs=${APXS}
PLIST_SUB+= MOD_DIR=libexec/apache22
@@ -115,7 +113,7 @@ do-install:
cd ${WRKSRC}/webapps && ${COPYTREE_SHARE} \* ${APP_HOME}/webapps
cd ${WRKSRC}/lib && ${COPYTREE_SHARE} \* ${APP_HOME}/lib
-.if defined(WITH_APACHE22)
+.if ${PORT_OPTIONS:MAPACHE22}
${APXS} -i -n caucho -a ${WRKSRC}/modules/c/src/apache2/.libs/mod_caucho.so
.endif
@${ECHO_MSG}
diff --git a/www/resin3/files/resin3.in b/www/resin3/files/resin3.in
index 003c0bbc423c..2df6840722fd 100644
--- a/www/resin3/files/resin3.in
+++ b/www/resin3/files/resin3.in
@@ -14,20 +14,20 @@
#
-%%APP_NAME%%_enable=${%%APP_NAME%%_enable:-"NO"}
-%%APP_NAME%%_user=${%%APP_NAME%%_user:"www"}
-%%APP_NAME%%_group=${%%APP_NAME%%_group:"www"}
+%%APP_NAME%%_enable="${%%APP_NAME%%_enable:-"NO"}"
+%%APP_NAME%%_user="${%%APP_NAME%%_user:-"www"}"
+%%APP_NAME%%_group="${%%APP_NAME%%_group:-"www"}"
. /etc/rc.subr
-name=%%APP_NAME%%
-rcvar=%%APP_NAME%%_enable
+name="%%APP_NAME%%"
+rcvar="%%APP_NAME%%"_enable
load_rc_config ${name}
command="%%PREFIX%%/sbin/%%APP_NAME%%ctl"
command_args="start"
-pidfile=%%PID_FILE%%
+pidfile="%%PID_FILE%%"
if test -n "${%%APP_NAME%%_java_version}" ; then
JAVA_HOME=$(JAVA_VERSION="${%%APP_NAME%%_java_version}" JAVAVM_DRYRUN=1 %%LOCALBASE%%/bin/java | grep JAVA_HOME | cut -d= -f2)