aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-06-07 04:46:20 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-06-07 04:46:20 +0800
commit955c98111289a9ee9a3b96be3d07b94981745fe3 (patch)
tree0eefeaccdf192bcf87dff6247fdd11f19845ec42
parenta60aa9161fa5196ed4cbb4215c1b907654a5ec0e (diff)
downloadfreebsd-ports-gnome-955c98111289a9ee9a3b96be3d07b94981745fe3.tar.gz
freebsd-ports-gnome-955c98111289a9ee9a3b96be3d07b94981745fe3.tar.zst
freebsd-ports-gnome-955c98111289a9ee9a3b96be3d07b94981745fe3.zip
Whois is an intelligent pure Ruby WHOIS client and parser.
It provides a flexible and programmable API to query WHOIS servers and look up IP/domain WHOIS information. It also offers command-line interface to run WHOIS queries from the console. It is a OS-independent library and does not require external C libraries or Gems. WWW: http://www.ruby-whois.org/ WWW: http://rubygems.org/gems/whois PR: ports/147563 Submitted by: Eric Freeman <freebsdports at chillibear.com>
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-whois/Makefile21
-rw-r--r--net/rubygem-whois/distinfo3
-rw-r--r--net/rubygem-whois/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 39446341269f..dfae55437555 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -919,6 +919,7 @@
SUBDIR += rubygem-rubytter
SUBDIR += rubygem-twitter
SUBDIR += rubygem-twitter4r
+ SUBDIR += rubygem-whois
SUBDIR += rubygem-yadis
SUBDIR += rude
SUBDIR += rwhoisd
diff --git a/net/rubygem-whois/Makefile b/net/rubygem-whois/Makefile
new file mode 100644
index 000000000000..5c07d168e608
--- /dev/null
+++ b/net/rubygem-whois/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-whois
+# Date created: 22 May 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whois
+PORTVERSION= 1.1.5
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Ruby whois library
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/ruby-whois
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-whois/distinfo b/net/rubygem-whois/distinfo
new file mode 100644
index 000000000000..37ef9df00bf2
--- /dev/null
+++ b/net/rubygem-whois/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/whois-1.1.5.gem) = 8207cdcd7ceae069da7d7ba6cb7f4bcc
+SHA256 (rubygem/whois-1.1.5.gem) = 069c33bd5130bd76d02ed2787db402402148723efdd1dcc89c8bd0572be38f9a
+SIZE (rubygem/whois-1.1.5.gem) = 158720
diff --git a/net/rubygem-whois/pkg-descr b/net/rubygem-whois/pkg-descr
new file mode 100644
index 000000000000..8235d013fb43
--- /dev/null
+++ b/net/rubygem-whois/pkg-descr
@@ -0,0 +1,12 @@
+Whois is an intelligent pure Ruby WHOIS client and parser.
+
+It provides a flexible and programmable API to query WHOIS
+servers and look up IP/domain WHOIS information. It also
+offers command-line interface to run WHOIS queries from
+the console.
+
+It is a OS-independent library and does not require external
+C libraries or Gems.
+
+WWW: http://www.ruby-whois.org/
+WWW: http://rubygems.org/gems/whois