aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-05-09 04:22:19 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-05-09 04:22:19 +0800
commit959c9ac45a0283c8f0f06994757a29462f5fae3f (patch)
tree5883a682ea8b0f523332859ad483d41ac0dd8001
parentab0838978266f8f13f9553e924d25f8feca83794 (diff)
downloadfreebsd-ports-gnome-959c9ac45a0283c8f0f06994757a29462f5fae3f.tar.gz
freebsd-ports-gnome-959c9ac45a0283c8f0f06994757a29462f5fae3f.tar.zst
freebsd-ports-gnome-959c9ac45a0283c8f0f06994757a29462f5fae3f.zip
- Add LICENSE
- Sort PLIST - Take maintainership - Update pkg-descr
-rw-r--r--net/p5-Net-OAuth/Makefile9
-rw-r--r--net/p5-Net-OAuth/pkg-descr21
-rw-r--r--net/p5-Net-OAuth/pkg-plist6
3 files changed, 25 insertions, 11 deletions
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
index 74b6e682b9a3..dce4457743b0 100644
--- a/net/p5-Net-OAuth/Makefile
+++ b/net/p5-Net-OAuth/Makefile
@@ -8,17 +8,20 @@ CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Implementation of the OAuth protocol
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-Data-Inheritable>=0.06:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
+TEST_DEPENDS= p5-Test-Warn>=0.21:${PORTSDIR}/devel/p5-Test-Warn
-USES= perl5
USE_PERL5= modbuild
+USES= perl5
.include <bsd.port.mk>
diff --git a/net/p5-Net-OAuth/pkg-descr b/net/p5-Net-OAuth/pkg-descr
index ef03854a0cb6..6bb30406a406 100644
--- a/net/p5-Net-OAuth/pkg-descr
+++ b/net/p5-Net-OAuth/pkg-descr
@@ -1,9 +1,20 @@
-Net::OAuth is an implementation of the OAuth protocol.
+Net::OAuth provides a low-level API for reading and writing OAuth messages.
-OAuth is:
+OAuth is an open protocol to allow secure API authentication in a simple and
+standard method from desktop and web applications. In practical terms, OAuth is
+a mechanism for a Consumer to request protected resources from a Service
+Provider on behalf of a user.
-An open protocol to allow secure API authentication in a simple and standard
-method from desktop and web applications.
+Net::OAuth provides:
+- classes that encapsulate OAuth messages (requests and responses).
+- message signing
+- message serialization and parsing.
+- 2-legged requests (aka. tokenless requests, aka. consumer requests), see
+ "CONSUMER REQUESTS"
+
+Net::OAuth does not provide:
+- Consumer or Service Provider encapsulation
+- token/nonce/key storage/management
-WWW: http://oauth.net/
WWW: http://search.cpan.org/dist/Net-OAuth/
+WWW: http://oauth.net/
diff --git a/net/p5-Net-OAuth/pkg-plist b/net/p5-Net-OAuth/pkg-plist
index a02c5ba37ad2..36c4f310f338 100644
--- a/net/p5-Net-OAuth/pkg-plist
+++ b/net/p5-Net-OAuth/pkg-plist
@@ -16,12 +16,12 @@
%%SITE_PERL%%/Net/OAuth/SignatureMethod/RSA_SHA1.pm
%%SITE_PERL%%/Net/OAuth/UserAuthRequest.pm
%%SITE_PERL%%/Net/OAuth/UserAuthResponse.pm
-%%SITE_PERL%%/Net/OAuth/XauthAccessTokenRequest.pm
-%%SITE_PERL%%/Net/OAuth/YahooAccessTokenRefreshRequest.pm
+%%SITE_PERL%%/Net/OAuth/V1_0A/AccessTokenRequest.pm
%%SITE_PERL%%/Net/OAuth/V1_0A/RequestTokenRequest.pm
%%SITE_PERL%%/Net/OAuth/V1_0A/RequestTokenResponse.pm
%%SITE_PERL%%/Net/OAuth/V1_0A/UserAuthResponse.pm
-%%SITE_PERL%%/Net/OAuth/V1_0A/AccessTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/XauthAccessTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/YahooAccessTokenRefreshRequest.pm
%%PERL5_MAN3%%/Net::OAuth.3.gz
%%PERL5_MAN3%%/Net::OAuth::AccessToken.3.gz
%%PERL5_MAN3%%/Net::OAuth::AccessTokenRequest.3.gz