aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-08-22 05:30:57 +0800
committerobraun <obraun@FreeBSD.org>2002-08-22 05:30:57 +0800
commit975e5d1027bd06859418b1a845483cca19c69e51 (patch)
treed918fe1fa83f3c8d903b9f3c9a7486e1b3db4bd0
parent78ad7c59c6a70042f54309e063035618dcb75800 (diff)
downloadfreebsd-ports-gnome-975e5d1027bd06859418b1a845483cca19c69e51.tar.gz
freebsd-ports-gnome-975e5d1027bd06859418b1a845483cca19c69e51.tar.zst
freebsd-ports-gnome-975e5d1027bd06859418b1a845483cca19c69e51.zip
Add variables WARNSENDER, WARNRECIP, WARNADMIN and SMTPPORT.
Add USE_PERL5. PR: ports/41695 Submitted by: maintainer Approved by: dwcjr (mentor)
-rw-r--r--security/amavisd/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/security/amavisd/Makefile b/security/amavisd/Makefile
index 49c586e30d16..0a1d17948fd7 100644
--- a/security/amavisd/Makefile
+++ b/security/amavisd/Makefile
@@ -33,14 +33,24 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc \
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
+USE_PERL5= yes
-AMAVISUSER?= vscan
AMAVISGROUP?= vscan
+AMAVISUSER?= vscan
+SMTPPORT?= 10025
+STARTSCRIPT= amavisd.sh
+WARNADMIN?= yes
+WARNRECIP?= no
+WARNSENDER?= no
-CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc --with-amavisuser=${AMAVISUSER}:${AMAVISGROUP}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc \
+ --with-amavisuser=${AMAVISUSER}:${AMAVISGROUP} \
+ --with-smtp-port=${SMTPPORT} \
+ --with-warnsender=${WARNSENDER} \
+ --with-warnrecip=${WARNRECIP} \
+ --with-warnadmin=${WARNADMIN}
-STARTSCRIPT= amavisd.sh
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WITH_POSTFIX)
CONFIGURE_ARGS+= --enable-postfix