aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-01-06 09:01:15 +0800
committermezz <mezz@FreeBSD.org>2007-01-06 09:01:15 +0800
commit97fb750af5dd9c9ceecbb3f93a72f4261fce6a47 (patch)
tree897121d4b3167bd86bec7ada10699ac93c97b54d
parent823d059d70ab8a90f701cad32283ae0355836615 (diff)
downloadfreebsd-ports-gnome-97fb750af5dd9c9ceecbb3f93a72f4261fce6a47.tar.gz
freebsd-ports-gnome-97fb750af5dd9c9ceecbb3f93a72f4261fce6a47.tar.zst
freebsd-ports-gnome-97fb750af5dd9c9ceecbb3f93a72f4261fce6a47.zip
Fix the /back and repeat /away if you are back. Also, it fixes in the Server ->
Away menu when you try to uncheck it. This patch was took from xchat2 CVS. Bump the PORTREVISION.
-rw-r--r--irc/xchat/Makefile1
-rw-r--r--irc/xchat/files/patch-src_common_cfgfiles.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index c699fca2d126..ddbe6adb02c9 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.0
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-src_common_cfgfiles.c b/irc/xchat/files/patch-src_common_cfgfiles.c
new file mode 100644
index 000000000000..b5f462f43698
--- /dev/null
+++ b/irc/xchat/files/patch-src_common_cfgfiles.c
@@ -0,0 +1,11 @@
+--- src/common/cfgfiles.c.orig Fri Jan 5 18:55:27 2007
++++ src/common/cfgfiles.c Fri Jan 5 18:55:40 2007
+@@ -45,7 +45,7 @@
+ int cmd_len = 1, name_len;
+
+ /* remove <2.8.0 stuff */
+- if (!strcmp (cmd, "AWAY") & !strcmp (name, "BACK"))
++ if (!strcmp (cmd, "away") & !strcmp (name, "BACK"))
+ return;
+
+ if (cmd)