aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-10-08 06:23:15 +0800
committertrevor <trevor@FreeBSD.org>2002-10-08 06:23:15 +0800
commit9ba6fe9c9b98b461381bcb7f5999945ec9066b8a (patch)
treeec70feb82dbde2da352060294e56535acb16b214
parent9f4c0a7aea4d4a6f9c1d12a2e25789ddd6ec944a (diff)
downloadfreebsd-ports-gnome-9ba6fe9c9b98b461381bcb7f5999945ec9066b8a.tar.gz
freebsd-ports-gnome-9ba6fe9c9b98b461381bcb7f5999945ec9066b8a.tar.zst
freebsd-ports-gnome-9ba6fe9c9b98b461381bcb7f5999945ec9066b8a.zip
new port, based on ports/www/mozilla, of Beonex Communicator
-rw-r--r--www/Makefile1
-rw-r--r--www/beonex/Makefile145
-rw-r--r--www/beonex/distinfo1
-rw-r--r--www/beonex/files/patch-Makefile.in16
-rw-r--r--www/beonex/files/patch-basebrowser-unix28
-rw-r--r--www/beonex/files/patch-rules.mk16
-rw-r--r--www/beonex/files/patch-unix.js18
-rw-r--r--www/beonex/files/patch-xptc_platforms_unixish_x86.h27
-rw-r--r--www/beonex/pkg-comment1
-rw-r--r--www/beonex/pkg-descr9
-rw-r--r--www/beonex/pkg-message4
11 files changed, 266 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2290b44c83dd..9acf69b0acab 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -27,6 +27,7 @@
SUBDIR += auth_ldap
SUBDIR += awstats
SUBDIR += bacon
+ SUBDIR += beonex
SUBDIR += bk2site
SUBDIR += bkmrkconv
SUBDIR += bluefish
diff --git a/www/beonex/Makefile b/www/beonex/Makefile
new file mode 100644
index 000000000000..6bbdf45efa08
--- /dev/null
+++ b/www/beonex/Makefile
@@ -0,0 +1,145 @@
+# New ports collection makefile for: beonex
+# Date created: 2002-09-26
+# Whom: trevor
+# based on ports/www/mozilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= beonex
+PORTVERSION= 0.8.1
+CATEGORIES= www
+MASTER_SITES= http://ftp.ibiblio.org/pub/packages/infosystems/WWW/clients/beonex/communicator/0.8/ \
+ ftp://ftp.ibiblio.org/pub/packages/infosystems/WWW/clients/beonex/communicator/0.8/
+DISTNAME= beonex-comm-${PORTVERSION}-stable-1-source-tarball
+
+MAINTAINER= trevor@FreeBSD.org
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+WRKSRC= ${WRKDIR}/mozilla
+
+WITHOUT_CHATZILLA="see <URL:http://online.securityfocus.com/archive/1/270249>"
+
+USE_BZIP2= yes
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* --exclude */macbuild/*\
+ --exclude */package/*
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= orbit gtk12
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= \
+ --disable-auto-deps \
+ --enable-chrome-format=jar \
+ --disable-cpp-exceptions \
+ --disable-cpp-rtti \
+ --enable-crypto \
+ --disable-debug \
+ --enable-default-toolkit=gtk \
+ --enable-double-buffer \
+ --enable-dtd-debug \
+ --enable-jsd \
+ --enable-mathml \
+ --disable-md \
+ --disable-optimize \
+ --disable-pedantic \
+ --disable-plaintext-editor-only \
+ --enable-strip \
+ --disable-tests \
+ --disable-xterm-updates \
+ --enable-xinerama \
+ --with-system-jpeg=${LOCALBASE} \
+ --with-system-mng=${LOCALBASE} \
+ --with-system-png=${LOCALBASE}
+# disabled due to compilation errors
+# --with-pthreads
+# --enable-svg
+
+PLIST= ${WRKDIR}/pkg-plist
+# LDAP is only used by mail and news so disable both together
+.if defined(WITHOUT_MAILNEWS)
+CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
+.else
+# mail and news desired, but not LDAP
+.if defined(WITHOUT_LDAP)
+CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
+.else
+CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
+.endif
+.endif
+
+.if !defined(WITHOUT_CHATZILLA)
+CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
+.else
+CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
+.endif
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 ${CC}=${CXX}
+
+.include <bsd.port.pre.mk>
+
+MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
+ MOZ_INTERNAL_LIBART_LGPL=1
+ALL_TARGET= default
+
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --enable-reorder
+.endif
+
+.if ${OSVERSION} > 500038
+BROKEN= "runtime error on FreeBSD -CURRENT"
+.endif
+
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
+pre-everything::
+ @ ${CAT} ${PKGMESSAGE}
+
+post-build:
+.if defined(WITHOUT_CHATZILLA)
+ ${RM} -f ${WRKSRC}/dist/bin/chrome/chatzilla.jar \
+ ${WRKSRC}/extensions/irc/js/lib/chatzilla-service.js
+.endif
+ (cd ${WRKSRC}/dist/bin && \
+ ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
+ ${ECHO_CMD} skin,install,select,classic/1.0 >> \
+ chrome/installed-chrome.txt; \
+ ${ECHO_CMD} locale,install,select,en-US >> \
+ chrome/installed-chrome.txt; \
+ ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
+
+pre-install:
+ ${ECHO_CMD} bin/beonex > ${PLIST}
+.for ii in component.reg components/xpti.dat
+ ${ECHO_CMD} '@unexec rm -f %D/lib/beonex/${ii} || true' >> ${PLIST}
+.endfor
+ cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
+ ${SED} -e 's:^:lib/beonex/:' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's:^:@dirrm lib/beonex/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm lib/beonex >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/beonex
+ ${CHMOD} 755 ${PREFIX}/lib/beonex
+ cd ${WRKSRC}/dist/bin && ${FIND} * | \
+ cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/beonex
+ cd ${WRKSRC} && pax -r -w * ${PREFIX}/lib/beonex
+ ${ECHO_CMD} "#!/bin/sh" > ${WRKDIR}/beonex
+ ${ECHO_CMD} 'cd ${PREFIX}/lib/beonex && exec ./mozilla "$$@"' >> \
+ ${WRKDIR}/beonex
+ ${INSTALL_SCRIPT} ${WRKDIR}/beonex ${PREFIX}/bin/
+ ${LN} -sf \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so\
+ ${PREFIX}/lib/beonex/plugins/libjavaplugin_oji.so
+
+.include <bsd.port.post.mk>
diff --git a/www/beonex/distinfo b/www/beonex/distinfo
new file mode 100644
index 000000000000..eac6e5fd38a6
--- /dev/null
+++ b/www/beonex/distinfo
@@ -0,0 +1 @@
+MD5 (beonex-comm-0.8.1-stable-1-source-tarball.tar.bz2) = 71ba6b57b063a02c5bd917c358b3ba61
diff --git a/www/beonex/files/patch-Makefile.in b/www/beonex/files/patch-Makefile.in
new file mode 100644
index 000000000000..7ea938ef0260
--- /dev/null
+++ b/www/beonex/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+Avoid compilation error.
+
+author: Trevor Johnson
+
+--- Makefile.in.orig Fri May 24 23:46:25 2002
++++ Makefile.in Thu Sep 26 23:45:58 2002
+@@ -169,7 +169,6 @@
+ endif
+
+ ifdef MOZ_INTERNAL_LIBART_LGPL
+-tier_9_dirs += other-licenses/libart_lgpl
+ endif
+
+ tier_9_dirs += \
diff --git a/www/beonex/files/patch-basebrowser-unix b/www/beonex/files/patch-basebrowser-unix
new file mode 100644
index 000000000000..b0ae51e2fc7e
--- /dev/null
+++ b/www/beonex/files/patch-basebrowser-unix
@@ -0,0 +1,28 @@
+$FreeBSD$
+
+"Install files necessary for viewing pages in Asian languages using
+ports based on mozilla-embedded (galeon, skipstone etc.)"
+
+author: Takashi KANAMARU <kanamaru@sekine-lab.ei.tuat.ac.jp>
+
+--- embedding/config/basebrowser-unix.orig Thu Feb 7 23:50:19 2002
++++ embedding/config/basebrowser-unix Tue Mar 12 17:06:08 2002
+@@ -203,12 +204,12 @@
+ components/unicharutil.xpt
+ components/libchardet.so
+ ; optional - on english only systems
+-; components/libucvja.so for japanese
+-; components/libucvko.so for korean
+-; components/libucvcn.so for simplified chinese
+-; components/libucvtw.so for traditional chinese
+-; components/libucvtw2.so for traditional chinese
+-; components/libucvibm.so for ibm
++components/libucvja.so
++components/libucvko.so
++components/libucvcn.so
++components/libucvtw.so
++components/libucvtw2.so
++components/libucvibm.so
+
+
+ res/language.properties
diff --git a/www/beonex/files/patch-rules.mk b/www/beonex/files/patch-rules.mk
new file mode 100644
index 000000000000..828b3ac3e3f1
--- /dev/null
+++ b/www/beonex/files/patch-rules.mk
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+Enable compilation under -CURRENT.
+
+author: Trevor Johnson
+
+--- config/rules.mk.orig Thu Aug 29 00:00:31 2002
++++ config/rules.mk Wed Oct 2 01:15:29 2002
+@@ -68,7 +68,6 @@
+ topsrcdir = $(DEPTH)
+ endif
+
+-CXX=gcc
+ LDFLAGS += -Wl,-Bstatic -Wl,-lstdc++ -Wl,-Bdynamic
+
+
diff --git a/www/beonex/files/patch-unix.js b/www/beonex/files/patch-unix.js
new file mode 100644
index 000000000000..3714c39003a2
--- /dev/null
+++ b/www/beonex/files/patch-unix.js
@@ -0,0 +1,18 @@
+$FreeBSD$
+
+"correct name of the freetype library, so that it is easier to get AA fonts
+working."
+
+author: Maxim Sobolev
+
+--- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
++++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
+@@ -227,7 +227,7 @@
+
+ // TrueType
+ pref("font.FreeType2.enable", false);
+-pref("font.freetype2.shared-library", "libfreetype.so.6");
++pref("font.freetype2.shared-library", "libfreetype.so.9");
+ // if libfreetype was built without hinting compiled in
+ // it is best to leave hinting off
+ pref("font.FreeType2.autohinted", false);
diff --git a/www/beonex/files/patch-xptc_platforms_unixish_x86.h b/www/beonex/files/patch-xptc_platforms_unixish_x86.h
new file mode 100644
index 000000000000..0a90befc070d
--- /dev/null
+++ b/www/beonex/files/patch-xptc_platforms_unixish_x86.h
@@ -0,0 +1,27 @@
+$FreeBSD$
+
+"Fix build on -CURRENT"
+
+author: Peter Kostouros <kpeter@melbpc.org.au>
+
+--- xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h.orig Fri Jun 21 01:12:40 2002
++++ xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h Fri Jun 21 01:41:51 2002
+@@ -94,8 +94,16 @@
+ * gcc is that the system gcc defines __FreeBSD_cc_version. This variable
+ * can also identify the period of time that 4.0-CURRENT used thunks.
+ */
+-#if defined(__FreeBSD_cc_version) && \
+- (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003)
++
++/* It seems we need to use thunks in FreeBSD -CURRENT after gcc-3.1 was merged.
++ * This solves a problem wherein regxpcom and/or regchrome would seg fault
++ * after running for a while. This problem has also exhibited itself on
++ * the alpha platform. Therefore, use thunks on all versions of
++ * -CURRENT that are using gcc-3.1.
++ */
++#if defined(__FreeBSD_cc_version) && \
++ (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003) && \
++ (__FreeBSD_cc_version < 500003)
+ #define CFRONT_STYLE_THIS_ADJUST
+ #else
+ #define THUNK_BASED_THIS_ADJUST
diff --git a/www/beonex/pkg-comment b/www/beonex/pkg-comment
new file mode 100644
index 000000000000..f50fd078bab1
--- /dev/null
+++ b/www/beonex/pkg-comment
@@ -0,0 +1 @@
+Open-source browser, HTML editor, mail and news client
diff --git a/www/beonex/pkg-descr b/www/beonex/pkg-descr
new file mode 100644
index 000000000000..f5294a716a73
--- /dev/null
+++ b/www/beonex/pkg-descr
@@ -0,0 +1,9 @@
+This is the Beonex Communicator suite (Web browser, HTML editor, e-mail user
+agent, news reader, address book, and spell-checker). It is based on Mozilla,
+but with extra emphasis on security and privacy.
+
+Because of a security bug, the Chatzilla IRC client is not included in this
+port. Support for SVG and threading are disabled because of compilation
+problems. Java has not been tested.
+
+WWW: http://beonex.com/
diff --git a/www/beonex/pkg-message b/www/beonex/pkg-message
new file mode 100644
index 000000000000..f592d23af753
--- /dev/null
+++ b/www/beonex/pkg-message
@@ -0,0 +1,4 @@
+*** WARNING ***
+* The beonex source code has not been reviewed
+* by the maintainer of the FreeBSD port.
+***