aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2007-05-29 03:52:47 +0800
committerdelphij <delphij@FreeBSD.org>2007-05-29 03:52:47 +0800
commit9c554beed06b1fb9ac87cadfba4168ce1f5b2866 (patch)
tree501399cd20eeb4e6508bc613ebe184fa8a32b59b
parent57e8b5969f2a3c72c9c75a20779c549849c282d0 (diff)
downloadfreebsd-ports-gnome-9c554beed06b1fb9ac87cadfba4168ce1f5b2866.tar.gz
freebsd-ports-gnome-9c554beed06b1fb9ac87cadfba4168ce1f5b2866.tar.zst
freebsd-ports-gnome-9c554beed06b1fb9ac87cadfba4168ce1f5b2866.zip
Fix python module build.
Approved by: demon (implict via private mail)
-rw-r--r--databases/rrdtool/files/patch-bindings-Makefile.in11
-rw-r--r--net/rrdtool/files/patch-bindings-Makefile.in11
2 files changed, 16 insertions, 6 deletions
diff --git a/databases/rrdtool/files/patch-bindings-Makefile.in b/databases/rrdtool/files/patch-bindings-Makefile.in
index cdbc0427e04d..09af0a5c23ca 100644
--- a/databases/rrdtool/files/patch-bindings-Makefile.in
+++ b/databases/rrdtool/files/patch-bindings-Makefile.in
@@ -1,6 +1,6 @@
---- bindings/Makefile.in.orig Thu May 3 02:06:59 2007
-+++ bindings/Makefile.in Tue May 8 13:20:37 2007
-@@ -539,14 +539,14 @@
+--- ./bindings/Makefile.in.orig Thu May 3 02:06:59 2007
++++ ./bindings/Makefile.in Tue May 29 03:45:40 2007
+@@ -539,18 +539,18 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
@@ -19,3 +19,8 @@
# rules for buildung the pyton module
python:
+- cd python && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
++ cd python && env LIBDIR=../../src/.libs INCDIR=../../src $(PYTHON) setup.py build
+
+ # rules for building the perl module
+ perl_piped: perl-piped/Makefile
diff --git a/net/rrdtool/files/patch-bindings-Makefile.in b/net/rrdtool/files/patch-bindings-Makefile.in
index cdbc0427e04d..09af0a5c23ca 100644
--- a/net/rrdtool/files/patch-bindings-Makefile.in
+++ b/net/rrdtool/files/patch-bindings-Makefile.in
@@ -1,6 +1,6 @@
---- bindings/Makefile.in.orig Thu May 3 02:06:59 2007
-+++ bindings/Makefile.in Tue May 8 13:20:37 2007
-@@ -539,14 +539,14 @@
+--- ./bindings/Makefile.in.orig Thu May 3 02:06:59 2007
++++ ./bindings/Makefile.in Tue May 29 03:45:40 2007
+@@ -539,18 +539,18 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
@@ -19,3 +19,8 @@
# rules for buildung the pyton module
python:
+- cd python && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
++ cd python && env LIBDIR=../../src/.libs INCDIR=../../src $(PYTHON) setup.py build
+
+ # rules for building the perl module
+ perl_piped: perl-piped/Makefile