aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-01-30 03:01:29 +0800
committermakc <makc@FreeBSD.org>2009-01-30 03:01:29 +0800
commit9f6d1a4b7f59816366ed922a1c8f0111ec858c94 (patch)
treeb41d50ccb710b551b2a479d5c8f8a59b8c1ca873
parentaaa72ee9008c0a754e34e6ad851b368c8988450a (diff)
downloadfreebsd-ports-gnome-9f6d1a4b7f59816366ed922a1c8f0111ec858c94.tar.gz
freebsd-ports-gnome-9f6d1a4b7f59816366ed922a1c8f0111ec858c94.tar.zst
freebsd-ports-gnome-9f6d1a4b7f59816366ed922a1c8f0111ec858c94.zip
Add new port multimedia/mlt++.
The MLT++ wrapper is a C++ wrapper for the MLT C library. As such, it provides clean C++ access to the underlying library. WWW: http://www.mltframework.org PR: ports/129795 Submitted by: Alberto Villa <villa.alberto at gmail.com> Approved by: miwi (mentor)
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mlt++/Makefile38
-rw-r--r--multimedia/mlt++/distinfo3
-rw-r--r--multimedia/mlt++/pkg-descr4
-rw-r--r--multimedia/mlt++/pkg-plist29
5 files changed, 75 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 322f19f1caf2..a9a386b1deb2 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -156,6 +156,7 @@
SUBDIR += mkvtoolnix
SUBDIR += mkxvcd
SUBDIR += mlt
+ SUBDIR += mlt++
SUBDIR += mmpython
SUBDIR += mmsclient
SUBDIR += mmsrip
diff --git a/multimedia/mlt++/Makefile b/multimedia/mlt++/Makefile
new file mode 100644
index 000000000000..d161692b7627
--- /dev/null
+++ b/multimedia/mlt++/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mlt++
+# Date created: 14 October 2008
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= mlt++
+PORTVERSION= 0.3.2
+CATEGORIES= multimedia
+MASTER_SITES= SFE
+MASTER_SITE_SUBDIR= mlt
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= C++ wrapping for the MLT library
+
+LIB_DEPENDS= mlt.1:${PORTSDIR}/multimedia/mlt
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS COPYING CUSTOMISING \
+ HOWTO README
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/swig/*/build
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/mlt++/distinfo b/multimedia/mlt++/distinfo
new file mode 100644
index 000000000000..5fd120d2ccda
--- /dev/null
+++ b/multimedia/mlt++/distinfo
@@ -0,0 +1,3 @@
+MD5 (mlt++-0.3.2.tar.gz) = bfcb9c1a3af8030eacf346db8171454e
+SHA256 (mlt++-0.3.2.tar.gz) = adba85bab64da0a3c3fb5bf8a2024d39b36daf33ff6e51884567ea563c0fcc70
+SIZE (mlt++-0.3.2.tar.gz) = 52594
diff --git a/multimedia/mlt++/pkg-descr b/multimedia/mlt++/pkg-descr
new file mode 100644
index 000000000000..16c2cede741b
--- /dev/null
+++ b/multimedia/mlt++/pkg-descr
@@ -0,0 +1,4 @@
+The MLT++ wrapper is a C++ wrapper for the MLT C library. As such, it
+provides clean C++ access to the underlying library.
+
+WWW: http://www.mltframework.org
diff --git a/multimedia/mlt++/pkg-plist b/multimedia/mlt++/pkg-plist
new file mode 100644
index 000000000000..69ab2f03ae47
--- /dev/null
+++ b/multimedia/mlt++/pkg-plist
@@ -0,0 +1,29 @@
+include/mlt++/Mlt.h
+include/mlt++/MltConsumer.h
+include/mlt++/MltDeque.h
+include/mlt++/MltEvent.h
+include/mlt++/MltFactory.h
+include/mlt++/MltField.h
+include/mlt++/MltFilter.h
+include/mlt++/MltFilteredConsumer.h
+include/mlt++/MltFrame.h
+include/mlt++/MltGeometry.h
+include/mlt++/MltMiracle.h
+include/mlt++/MltMultitrack.h
+include/mlt++/MltParser.h
+include/mlt++/MltPlaylist.h
+include/mlt++/MltProducer.h
+include/mlt++/MltProfile.h
+include/mlt++/MltProperties.h
+include/mlt++/MltPushConsumer.h
+include/mlt++/MltRepository.h
+include/mlt++/MltResponse.h
+include/mlt++/MltService.h
+include/mlt++/MltTokeniser.h
+include/mlt++/MltTractor.h
+include/mlt++/MltTransition.h
+include/mlt++/config.h
+lib/libmlt++.so
+lib/libmlt++.so.0.3.2
+lib/libmlt++.so.1
+@dirrm include/mlt++