aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-02-21 07:46:25 +0800
committerasami <asami@FreeBSD.org>2000-02-21 07:46:25 +0800
commita191d3ef40e7f5e8c789bdcb58e093e49b0be561 (patch)
tree984d5c26ccad5644aa37b3d82a2d9b2ef31fc54e
parentef224940941a492771a07231f4fd8b06a79bbf73 (diff)
downloadfreebsd-ports-gnome-a191d3ef40e7f5e8c789bdcb58e093e49b0be561.tar.gz
freebsd-ports-gnome-a191d3ef40e7f5e8c789bdcb58e093e49b0be561.tar.zst
freebsd-ports-gnome-a191d3ef40e7f5e8c789bdcb58e093e49b0be561.zip
A small hack to work around bsd.port.mk's problem -- add USE_BZIP2 so
the DEPENDS=pm3-base:configure will work on the package building machine. (It won't make any difference for ordinary users.) Reviewed by: maintainer
-rw-r--r--lang/pm3-forms/Makefile2
-rw-r--r--lang/pm3-gui/Makefile2
-rw-r--r--lang/pm3-m3tk/Makefile2
-rw-r--r--lang/pm3-net/Makefile2
-rw-r--r--lang/pm3-netobj/Makefile2
5 files changed, 10 insertions, 0 deletions
diff --git a/lang/pm3-forms/Makefile b/lang/pm3-forms/Makefile
index c67976969b8b..011b35e508c2 100644
--- a/lang/pm3-forms/Makefile
+++ b/lang/pm3-forms/Makefile
@@ -33,6 +33,8 @@ L1= ${PREFIX}/lib/m3/${TARGET}/
PROGS= bin/formsedit
SOVERSION= 7
VERSION= 1.1.13
+# hack to work around bsd.port.mk problem
+USE_BZIP2= yes
.include <bsd.port.pre.mk>
diff --git a/lang/pm3-gui/Makefile b/lang/pm3-gui/Makefile
index 474b758630db..78314d9c5c41 100644
--- a/lang/pm3-gui/Makefile
+++ b/lang/pm3-gui/Makefile
@@ -30,6 +30,8 @@ BUILDDIRS= graphics/gr-libs/X11 \
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
VERSION= 1.1.13
+# hack to work around bsd.port.mk problem
+USE_BZIP2= yes
.include <bsd.port.pre.mk>
diff --git a/lang/pm3-m3tk/Makefile b/lang/pm3-m3tk/Makefile
index 2e893bce8842..c0745827a8a5 100644
--- a/lang/pm3-m3tk/Makefile
+++ b/lang/pm3-m3tk/Makefile
@@ -26,6 +26,8 @@ BUILDDIRS= language/modula3/m3tools/m3tk
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
VERSION= 1.1.13
+# hack to work around bsd.port.mk problem
+USE_BZIP2= yes
.include <bsd.port.pre.mk>
diff --git a/lang/pm3-net/Makefile b/lang/pm3-net/Makefile
index 67d8696ca945..920244646485 100644
--- a/lang/pm3-net/Makefile
+++ b/lang/pm3-net/Makefile
@@ -28,6 +28,8 @@ BUILDDIRS= network/tcplibs/tcp \
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
VERSION= 1.1.13
+# hack to work around bsd.port.mk problem
+USE_BZIP2= yes
.include <bsd.port.pre.mk>
diff --git a/lang/pm3-netobj/Makefile b/lang/pm3-netobj/Makefile
index acd49fe37073..db47cb95287c 100644
--- a/lang/pm3-netobj/Makefile
+++ b/lang/pm3-netobj/Makefile
@@ -33,6 +33,8 @@ PROGS= bin/netobjd \
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
VERSION= 1.1.13
+# hack to work around bsd.port.mk problem
+USE_BZIP2= yes
.include <bsd.port.pre.mk>