aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-03-03 00:00:21 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 19:56:51 +0800
commita196fff1da5ecebd5b1c8bfb83e08f35edf86910 (patch)
tree4fb59566b62423bd422aba158e53225113c475e3
parent022f662e6d3a80eb6b0ea1e70596fa9a79e11008 (diff)
downloadfreebsd-ports-gnome-a196fff1da5ecebd5b1c8bfb83e08f35edf86910.tar.gz
freebsd-ports-gnome-a196fff1da5ecebd5b1c8bfb83e08f35edf86910.tar.zst
freebsd-ports-gnome-a196fff1da5ecebd5b1c8bfb83e08f35edf86910.zip
devel/lua-cjson: set USES to default lua version (5.2).
Also clone a slave port as lua51-cjson. Reviewed by: feld, mat Approved by: feld, mat (mentors) Differential Revision: https://reviews.freebsd.org/D9810
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lua-cjson/Makefile6
-rw-r--r--devel/lua51-cjson/Makefile13
-rw-r--r--devel/lua51-cjson/distinfo2
-rw-r--r--devel/lua51-cjson/pkg-descr12
5 files changed, 31 insertions, 3 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f9ecd8aae75..433f97548603 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1571,6 +1571,7 @@
SUBDIR += lua-posix
SUBDIR += lua-pty
SUBDIR += lua-sysctl
+ SUBDIR += lua51-cjson
SUBDIR += lua51-libevent
SUBDIR += luabind
SUBDIR += luafilesystem
diff --git a/devel/lua-cjson/Makefile b/devel/lua-cjson/Makefile
index ba01b0b9aa6d..5dc8451430a7 100644
--- a/devel/lua-cjson/Makefile
+++ b/devel/lua-cjson/Makefile
@@ -9,13 +9,13 @@ PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
DISTNAME= lua-cjson-${PORTVERSION}
MAINTAINER= osa@FreeBSD.org
-COMMENT= Fast JSON parsing and encoding support for Lua
+COMMENT?= Fast JSON parsing and encoding support for Lua
-USES= lua:51
+USES?= lua
MAKE_ARGS= LUA_VERSION=${LUA_VER}
-PLIST_FILES= %%LUA_MODLIBDIR%%/cjson.so
+PLIST_FILES= ${LUA_MODLIBDIR}/cjson.so
post-patch:
@${REINPLACE_CMD} '16,18d; \
diff --git a/devel/lua51-cjson/Makefile b/devel/lua51-cjson/Makefile
new file mode 100644
index 000000000000..76fba0a6e59b
--- /dev/null
+++ b/devel/lua51-cjson/Makefile
@@ -0,0 +1,13 @@
+# Created by: osa
+# $FreeBSD$
+
+
+
+COMMENT= Fast JSON parsing and encoding support for Lua 5.1
+
+MASTERDIR= ${.CURDIR}/../lua-cjson
+PKGMESSAGE= ${.CURDIR}/pkg-message
+
+USES= lua:51
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/lua51-cjson/distinfo b/devel/lua51-cjson/distinfo
new file mode 100644
index 000000000000..35ced13be251
--- /dev/null
+++ b/devel/lua51-cjson/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lua-cjson-2.1.0.tar.gz) = 51bc69cd55931e0cba2ceae39e9efa2483f4292da3a88a1ed470eda829f6c778
+SIZE (lua-cjson-2.1.0.tar.gz) = 86024
diff --git a/devel/lua51-cjson/pkg-descr b/devel/lua51-cjson/pkg-descr
new file mode 100644
index 000000000000..3a87bea25f5d
--- /dev/null
+++ b/devel/lua51-cjson/pkg-descr
@@ -0,0 +1,12 @@
+Lua CJSON provides fast JSON parsing and encoding support for Lua. It
+has been tested under Linux, FreeBSD, OSX, Solaris and Windows.
+
+Features:
+
+- Fast, standards compliant encoding/parsing routines.
+- Full support for JSON with UTF-8, including decoding surrogate pairs.
+- Optional run-time support for common exceptions to the JSON specification
+ (NaN, Infinity,..).
+- No external dependencies.
+
+WWW: http://www.kyne.com.au/~mark/software/lua-cjson.php