aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-02-01 01:15:49 +0800
committerrm <rm@FreeBSD.org>2012-02-01 01:15:49 +0800
commita28a29cb07afe1dd5617bcacd8ebcc7de6fb7034 (patch)
tree0a85bb409476e4ada935a629e52fd043d89e5efe
parent4e0a4ef53d583194bfd521f40ac309fe7b6d4722 (diff)
downloadfreebsd-ports-gnome-a28a29cb07afe1dd5617bcacd8ebcc7de6fb7034.tar.gz
freebsd-ports-gnome-a28a29cb07afe1dd5617bcacd8ebcc7de6fb7034.tar.zst
freebsd-ports-gnome-a28a29cb07afe1dd5617bcacd8ebcc7de6fb7034.zip
- update to 1.0.1 [1]
- change ${MASTER_SITE_GOOGLE_CODE} with just GOOGLE_CODE - change manual user/group creating with ports framework one - since there is now only two entries in pkg-plist, move it's content to Makefile PR: 164658 Submitted by: Sten Spans <sten at blinkenlights dot nl> (maintainer)
-rw-r--r--net/ladvd/Makefile16
-rw-r--r--net/ladvd/distinfo4
-rw-r--r--net/ladvd/files/pkg-install.in32
-rw-r--r--net/ladvd/pkg-plist6
4 files changed, 12 insertions, 46 deletions
diff --git a/net/ladvd/Makefile b/net/ladvd/Makefile
index fd6adf5c1072..73a55684a82f 100644
--- a/net/ladvd/Makefile
+++ b/net/ladvd/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= ladvd
-PORTVERSION= 0.9.2
+PORTVERSION= 1.0.1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+MASTER_SITES= GOOGLE_CODE \
http://blinkenlights.nl/software/ladvd/
MAINTAINER= sten@blinkenlights.nl
COMMENT= A minimal LLDP/CDP daemon
+LICENSE= BSD
+
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
-LICENSE= BSD
+USERS= ladvd
+GROUPS= ${USERS}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-chroot-dir=/var/empty
@@ -24,7 +27,10 @@ CONFIGURE_ARGS= --with-chroot-dir=/var/empty
PORTDOCS= *
MAN8= ladvd.8 ladvdc.8
USE_RC_SUBR+= ladvd
-SUB_FILES= pkg-message pkg-install
+SUB_FILES= pkg-message
+
+PLIST_FILES= sbin/ladvd \
+ sbin/ladvdc
post-patch:
.if defined(NOPORTDOCS)
@@ -33,8 +39,6 @@ post-patch:
.endif
post-install:
- @${ECHO} "==> Creating custom user to run ladvd..."
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/ladvd/distinfo b/net/ladvd/distinfo
index bbe3dce0d494..e1f4cc7a4f1c 100644
--- a/net/ladvd/distinfo
+++ b/net/ladvd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ladvd-0.9.2.tar.gz) = 1721649c64d2568ab724f7b80bfbca1c7972f5847a11f5d6d09612ee9908c68a
-SIZE (ladvd-0.9.2.tar.gz) = 450906
+SHA256 (ladvd-1.0.1.tar.gz) = af90a9f74e4e7e21eeac42bb4b9db109261612b9ed1d5b2892d220cb934f079a
+SIZE (ladvd-1.0.1.tar.gz) = 463276
diff --git a/net/ladvd/files/pkg-install.in b/net/ladvd/files/pkg-install.in
deleted file mode 100644
index cf77763a41f2..000000000000
--- a/net/ladvd/files/pkg-install.in
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-LADVDUSER=${LADVDUSER:-ladvd}
-LADVDUID=${LADVDUID:-142}
-LADVDGROUP=${LADVDGROUP:-ladvd}
-LADVDGID=${LADVDGID:-142}
-
-if ! pw groupshow "$LADVDGROUP" 2>/dev/null 1>&2; then
- if pw groupadd $LADVDGROUP -g $LADVDGID; then
- echo "=> Added group \"$LADVDGROUP\"."
- else
- echo "=> Adding group \"$LADVDGROUP\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "$LADVDUSER" 2>/dev/null 1>&2; then
- if pw useradd $LADVDUSER -u $LADVDUID -g $LADVDGROUP -h - \
- -s "/sbin/nologin" -d "/nonexistent" \
- -c "ladvd pseudo-user"; \
- then
- echo "=> Added user \"$LADVDUSER\"."
- else
- echo "=> Adding user \"$LADVDUSER\" failed..."
- exit 1
- fi
-fi
-exit 0
diff --git a/net/ladvd/pkg-plist b/net/ladvd/pkg-plist
deleted file mode 100644
index 90704b177d0a..000000000000
--- a/net/ladvd/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-sbin/ladvd
-sbin/ladvdc
-@unexec echo ""
-@unexec echo "If you are permanently removing ladvd, you should also:" | /usr/bin/fmt
-@unexec echo "'remove user/group 'ladvd'." | /usr/bin/fmt
-@unexec echo ""