aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2011-10-29 06:54:58 +0800
committerpgollucci <pgollucci@FreeBSD.org>2011-10-29 06:54:58 +0800
commita2fd01466421ea7cab226640ac80cc1e1cb960b0 (patch)
tree75ff3fb3635c536a01341b118930ac250be5dd2d
parent8197e1e7914eb9af5e98abc7f48e05cbb302e452 (diff)
downloadfreebsd-ports-gnome-a2fd01466421ea7cab226640ac80cc1e1cb960b0.tar.gz
freebsd-ports-gnome-a2fd01466421ea7cab226640ac80cc1e1cb960b0.tar.zst
freebsd-ports-gnome-a2fd01466421ea7cab226640ac80cc1e1cb960b0.zip
This simple module serves one purpose - to provide a simple means to read (or
slurp) an entire file into memory for processing. This module allows the replacement of the prototypical foreach- or while- loops used for opening and reading of files with single-line constructs. Of note with this module is that the magic of the @ARGV variable and the input record separator, $/, are used to facilitate the reading of entire files into either an array or scalar using minimal code.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Slurp/Makefile29
-rw-r--r--devel/p5-Slurp/distinfo2
-rw-r--r--devel/p5-Slurp/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a04bce9faca7..158d743f63fa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2304,6 +2304,7 @@
SUBDIR += p5-Shell-Source
SUBDIR += p5-ShipIt
SUBDIR += p5-ShipIt-Step-Manifest
+ SUBDIR += p5-Slurp
SUBDIR += p5-Smart-Comments
SUBDIR += p5-Sort-Array
SUBDIR += p5-Sort-ArrayOfArrays
diff --git a/devel/p5-Slurp/Makefile b/devel/p5-Slurp/Makefile
new file mode 100644
index 000000000000..0c94acdc89c3
--- /dev/null
+++ b/devel/p5-Slurp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Slurp
+# Date created: October 28, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Slurp
+PORTVERSION= 0.4
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ROBAU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Slurp entire files into variables
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= YES
+
+MAN3= Slurp.3
+
+PLIST_FILES= %%SITE_PERL%%/Slurp.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Slurp/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Slurp
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Slurp/distinfo b/devel/p5-Slurp/distinfo
new file mode 100644
index 000000000000..3c955d4b88a1
--- /dev/null
+++ b/devel/p5-Slurp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Slurp-0.4.tar.gz) = a8e9d85ccea2d5693be6e86b7d6a90eba6e547cd76d7d52895da8ec23350209b
+SIZE (Slurp-0.4.tar.gz) = 2441
diff --git a/devel/p5-Slurp/pkg-descr b/devel/p5-Slurp/pkg-descr
new file mode 100644
index 000000000000..690c6a056980
--- /dev/null
+++ b/devel/p5-Slurp/pkg-descr
@@ -0,0 +1,8 @@
+This simple module serves one purpose - to provide a simple means to read (or
+slurp) an entire file into memory for processing. This module allows the
+replacement of the prototypical foreach- or while- loops used for opening
+and reading of files with single-line constructs.
+
+Of note with this module is that the magic of the @ARGV variable and the
+input record separator, $/, are used to facilitate the reading of entire
+files into either an array or scalar using minimal code.