aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-04 16:50:50 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-04 16:50:50 +0800
commita3b11f534f1ba2025acd6c0a7cd5a368c6c4261e (patch)
treecd18c60dbdb8087a83dff262fb9773875428db0b
parent4fc4d2f9d7642039728a6617549d35aee793a725 (diff)
downloadfreebsd-ports-gnome-a3b11f534f1ba2025acd6c0a7cd5a368c6c4261e.tar.gz
freebsd-ports-gnome-a3b11f534f1ba2025acd6c0a7cd5a368c6c4261e.tar.zst
freebsd-ports-gnome-a3b11f534f1ba2025acd6c0a7cd5a368c6c4261e.zip
Mark as broken with gcc4.2.
-rw-r--r--games/fwp/Makefile4
-rw-r--r--graphics/ffff/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/games/fwp/Makefile b/games/fwp/Makefile
index d23a2b5c6e77..9b024a094ed5 100644
--- a/games/fwp/Makefile
+++ b/games/fwp/Makefile
@@ -34,6 +34,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if ${ARCH} == "amd64" && ${OSVERSION} >= 700000
BROKEN= Doesn't build
.endif
diff --git a/graphics/ffff/Makefile b/graphics/ffff/Makefile
index f2bdfba96e83..b0defb3ff997 100644
--- a/graphics/ffff/Makefile
+++ b/graphics/ffff/Makefile
@@ -47,4 +47,10 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>