aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2009-10-29 09:27:53 +0800
committerclsung <clsung@FreeBSD.org>2009-10-29 09:27:53 +0800
commita4562b6fd2bcf6016120011cdf78dfc4ba94b083 (patch)
tree303b7f53e984e5bb77726c121aa60ac26ebee825
parentb3d468457eb6b4ddf026c8e9f701486c682518f7 (diff)
downloadfreebsd-ports-gnome-a4562b6fd2bcf6016120011cdf78dfc4ba94b083.tar.gz
freebsd-ports-gnome-a4562b6fd2bcf6016120011cdf78dfc4ba94b083.tar.zst
freebsd-ports-gnome-a4562b6fd2bcf6016120011cdf78dfc4ba94b083.zip
- fix default flags setting
- bump PORTREVISION Submitted by: Andrea Venturoli <ml_AT_netfence dot it>
-rw-r--r--security/snort/Makefile1
-rw-r--r--security/snort/files/snort.sh.in4
2 files changed, 3 insertions, 2 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 3517810a5aac..aeb1e3b6ce1b 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snort
PORTVERSION= 2.8.5.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.snort.org/dl/ \
http://dl.snort.org/snort-current/
diff --git a/security/snort/files/snort.sh.in b/security/snort/files/snort.sh.in
index ac28ce84315c..59ea342156c2 100644
--- a/security/snort/files/snort.sh.in
+++ b/security/snort/files/snort.sh.in
@@ -10,7 +10,7 @@
# snort_enable (bool): Set to YES to enable snort
# Default: NO
# snort_flags (str): Extra flags passed to snort
-# Default: -Dq
+# Default: -D -q
# snort_interface (str): Network interface to sniff
# Default: ""
# snort_conf (str): Snort configuration file
@@ -34,7 +34,7 @@ load_rc_config $name
[ -z "$snort_enable" ] && snort_enable="NO"
[ -z "$snort_conf" ] && snort_conf="%%PREFIX%%/etc/snort/snort.conf"
-[ -z "$snort_flags" ] && snort_flags="-Dq"
+[ -z "$snort_flags" ] && snort_flags="-D -q"
[ -n "$snort_interface" ] && snort_flags="$snort_flags -i $snort_interface" \
&& pidfile="/var/run/snort_${snort_interface}.pid"