aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-04-20 09:06:12 +0800
committerasami <asami@FreeBSD.org>2000-04-20 09:06:12 +0800
commita530ee7735456ee8718ab7a906d91af064301ece (patch)
tree598a2aa82f9f63a6bacd9f407711572f8c6df0da
parent653feea7f86673b1e0aec63397a92c25a77cc155 (diff)
downloadfreebsd-ports-gnome-a530ee7735456ee8718ab7a906d91af064301ece.tar.gz
freebsd-ports-gnome-a530ee7735456ee8718ab7a906d91af064301ece.tar.zst
freebsd-ports-gnome-a530ee7735456ee8718ab7a906d91af064301ece.zip
(1) Switch USE_QT2 to use qt21.
Submitted by: imura (2) Don't complain about distfiles not listed in files/md5 if we are doing "make makesum". Reported by: mharo, cpiazza Reviewed by: mharo
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4499d7b1cd81..ead6a8c82ebc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -686,7 +686,7 @@ USE_NEWGCC= yes
.endif
.if defined(USE_QT2)
-LIB_DEPENDS+= qt2.2:${PORTSDIR}/x11-toolkits/qt20
+LIB_DEPENDS+= qt2.3:${PORTSDIR}/x11-toolkits/qt21
USE_NEWGCC= yes
.endif
@@ -1566,7 +1566,7 @@ do-fetch:
${ECHO_MSG} ">> Please correct this problem and try again."; \
exit 1; \
fi ; \
- if [ -f ${MD5_FILE} ]; then \
+ if [ -f ${MD5_FILE} -a "x${FORCE_FETCH}" = "x" ]; then \
if ! ${GREP} -q "^MD5 (.*$$file)" ${MD5_FILE}; then \
${ECHO_MSG} ">> $$file is not in ${MD5_FILE}."; \
${ECHO_MSG} ">> Either ${MD5_FILE} is out of date, or"; \
@@ -2206,7 +2206,8 @@ fetch-list:
# Checksumming utilities
.if !target(makesum)
-makesum: fetch
+makesum:
+ @cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} fetch FORCE_FETCH=yes
@${MKDIR} ${FILESDIR}
@if [ -f ${MD5_FILE} ]; then ${RM} -f ${MD5_FILE}; fi
@(cd ${DISTDIR}; \