aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-04-17 00:00:08 +0800
committerrene <rene@FreeBSD.org>2013-04-17 00:00:08 +0800
commita57f7b2a1a41a7c35b798ee50fa885bbe942b7c8 (patch)
treed683b4286e3ae868a83258aed38ac332e1e1b481
parentf33fd8d037a580bc17cdf3b96e36038e7ddd4d6c (diff)
downloadfreebsd-ports-gnome-a57f7b2a1a41a7c35b798ee50fa885bbe942b7c8.tar.gz
freebsd-ports-gnome-a57f7b2a1a41a7c35b798ee50fa885bbe942b7c8.tar.zst
freebsd-ports-gnome-a57f7b2a1a41a7c35b798ee50fa885bbe942b7c8.zip
- Reset maintainer [1]
While here: - convert Makefile header - pet portlint (including USE_GNOME=pkgconfig -> USE_PKGCONFIG=yes) - drop support for unsupported FreeBSD versions - convert to optionsNG Submitted by: previous maintainer (tkjacobsen@gmail.com) [1] in http://lists.freebsd.org/pipermail/freebsd-ports/2013-April/082815.html Feature safe: yes
-rw-r--r--databases/akonadi-googledata/Makefile8
-rw-r--r--databases/akonadi-googledata/pkg-descr2
-rw-r--r--deskutils/libgcal/Makefile16
-rw-r--r--deskutils/libgcal/pkg-descr2
-rw-r--r--graphics/ipe/Makefile16
-rw-r--r--graphics/ipe/pkg-descr2
-rw-r--r--science/avogadro/Makefile10
7 files changed, 19 insertions, 37 deletions
diff --git a/databases/akonadi-googledata/Makefile b/databases/akonadi-googledata/Makefile
index 960500b59a1c..e6369dad382c 100644
--- a/databases/akonadi-googledata/Makefile
+++ b/databases/akonadi-googledata/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: akonadi-googledata
-# Date created: 2009-08-16
-# Whom: Troels Kofoed Jacobsen <tkjacobsen@gmail.com>
-#
+# Created by: Troels Kofoed Jacobsen <tkjacobsen@gmail.com>
# $FreeBSD$
-#
PORTNAME= akonadi-googledata
PORTVERSION= 1.2.0
@@ -11,7 +7,7 @@ PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://libgcal.googlecode.com/files/
-MAINTAINER= tkjacobsen@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Akonadi Resources for Google Contacts and Calendar
LIB_DEPENDS= gcal:${PORTSDIR}/deskutils/libgcal
diff --git a/databases/akonadi-googledata/pkg-descr b/databases/akonadi-googledata/pkg-descr
index 650f219f8b58..5fd679d09de5 100644
--- a/databases/akonadi-googledata/pkg-descr
+++ b/databases/akonadi-googledata/pkg-descr
@@ -1,4 +1,4 @@
Google contacts and calendar akonadi resource. It allows syncing your calendar
and contacts with your google account.
-WWW: http://code.google.com/p/libgcal/
+WWW: http://code.google.com/p/libgcal/
diff --git a/deskutils/libgcal/Makefile b/deskutils/libgcal/Makefile
index 3f35c80c20d6..92aabe191c8f 100644
--- a/deskutils/libgcal/Makefile
+++ b/deskutils/libgcal/Makefile
@@ -6,16 +6,16 @@ PORTVERSION= 0.9.6
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-MAINTAINER= tkjacobsen@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Library allowing communication with Google calendar and contacts
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
iconv:${PORTSDIR}/converters/libiconv \
xml2:${PORTSDIR}/textproc/libxml2
-LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/COPYING
-
USE_BZIP2= yes
USES= cmake
CMAKE_ARGS= -DLIB_INSTALL_DIR="${LOCALBASE}/lib" \
@@ -23,10 +23,4 @@ CMAKE_ARGS= -DLIB_INSTALL_DIR="${LOCALBASE}/lib" \
USE_LDCONFIG= yes
USE_GCC= 4.2+
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" && (${OSVERSION} >= 700000 && ${OSVERSION} < 800000)
-BROKEN= does not link
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/libgcal/pkg-descr b/deskutils/libgcal/pkg-descr
index bf891d606ed9..3cf2d666732e 100644
--- a/deskutils/libgcal/pkg-descr
+++ b/deskutils/libgcal/pkg-descr
@@ -1,4 +1,4 @@
An ANSI C library allowing communication with google calendar and contacts,
useful if you need to support this in a C or C++ application.
-WWW: http://code.google.com/p/libgcal/
+WWW: http://code.google.com/p/libgcal/
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 97f5075e862d..7902daddd2a1 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Ipe
-# Date created: October 25 2000
-# Whom: bremner@unb.ca
-#
+# Created by: bremner@unb.ca
# $FreeBSD$
-#
PORTNAME= ipe
DISTVERSION= 7.1.2
@@ -13,10 +9,10 @@ MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}7/${PORTNAME}/7.1.0
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
-MAINTAINER= tkjacobsen@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Extensible drawing editor
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}/src
@@ -24,11 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}/src
USE_LDCONFIG= yes
USE_LUA= 5.1
USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= yes
USE_QT4= gui qt3support qmake_build moc_build uic_build rcc_build
MAN1= ipe.1 ipe6upgrade.1 ipeextract.1 iperender.1 ipetoipe.1 ipescript.1
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-ipe__Makefile
.endif
diff --git a/graphics/ipe/pkg-descr b/graphics/ipe/pkg-descr
index ee51aba2a634..c9e0e94ae2b8 100644
--- a/graphics/ipe/pkg-descr
+++ b/graphics/ipe/pkg-descr
@@ -3,4 +3,4 @@ Postscript format. It supports making small figures for inclusion
into LaTeX-documents as well as making multi-page PDF presentations
that can be shown on-line with Acrobat Reader.
-WWW: http://tclab.kaist.ac.kr/ipe/
+WWW: http://tclab.kaist.ac.kr/ipe/
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index c0e24228a53b..0fdbd8a281f0 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= SF
-MAINTAINER= tkjacobsen@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Advanced molecular editor and viewer
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
@@ -44,13 +44,7 @@ CMAKE_ARGS+= -DENABLE_PYTHON=OFF
PLIST_SUB+= PYTHON="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700013
-BROKEN= requires posix_memalign
-.endif
-
post-patch:
@${REINPLACE_CMD} 's|share/man|man|' ${WRKSRC}/doc/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>