aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-04-14 20:19:51 +0800
committererwin <erwin@FreeBSD.org>2006-04-14 20:19:51 +0800
commita598707e4644b4b05c6fa6d0a8c89ea0b6c23cdd (patch)
treecedc1557f16780c0ed73c12d4967cabb242f993a
parent0b1035484cebd811bd648b69d8a247c1272caa6e (diff)
downloadfreebsd-ports-gnome-a598707e4644b4b05c6fa6d0a8c89ea0b6c23cdd.tar.gz
freebsd-ports-gnome-a598707e4644b4b05c6fa6d0a8c89ea0b6c23cdd.tar.zst
freebsd-ports-gnome-a598707e4644b4b05c6fa6d0a8c89ea0b6c23cdd.zip
Moose is an extension of the Perl 5 object system.
Another object system!?!? Yes, I know there has been an explosion recently of new ways to build objects in Perl 5, most of them based on inside-out objects, and other such things. Moose is different because it is not a new object system for Perl 5, but instead an extension of the existing object system. Moose is built on top of Class::MOP, which is a metaclass system for Perl 5. This means that Moose not only makes building normal Perl 5 objects better, but it also provides the power of metaclass programming. WWW: http://search.cpan.org/dist/Moose/ PR: ports/95741 Submitted by: Lars Balker Rasmussen <lars@balker.dk> Committed from: Sofia, Bulgaria
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Moose/Makefile51
-rw-r--r--devel/p5-Moose/distinfo3
-rw-r--r--devel/p5-Moose/pkg-descr14
-rw-r--r--devel/p5-Moose/pkg-plist20
5 files changed, 89 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e250e67dfe24..97d86a204a82 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1067,6 +1067,7 @@
SUBDIR += p5-Module-Starter
SUBDIR += p5-Module-Starter-PBP
SUBDIR += p5-Module-Versions-Report
+ SUBDIR += p5-Moose
SUBDIR += p5-NEXT
SUBDIR += p5-Net-DBus
SUBDIR += p5-OLE-Storage_Lite
diff --git a/devel/p5-Moose/Makefile b/devel/p5-Moose/Makefile
new file mode 100644
index 000000000000..e34432843872
--- /dev/null
+++ b/devel/p5-Moose/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: devel/p5-Moose
+# Date created: 14 Apr 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Moose
+PORTVERSION= 0.03.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/ST/STEVAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.03_02
+
+MAINTAINER= lars@balker.dk
+COMMENT= "Moose, it's the new Camel"
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= \
+ p5-Scalar-List-Utils>=1.18:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Class-MOP>=0.22:${PORTSDIR}/devel/p5-Class-MOP \
+ p5-Sub-Name>=0.02:${PORTSDIR}/devel/p5-Sub-Name \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_MODBUILD= yes
+
+MAN3= Moose.3 \
+ Moose::Cookbook.3 \
+ Moose::Cookbook::Recipe1.3 \
+ Moose::Cookbook::Recipe2.3 \
+ Moose::Cookbook::Recipe3.3 \
+ Moose::Cookbook::Recipe4.3 \
+ Moose::Cookbook::Recipe5.3 \
+ Moose::Cookbook::Recipe6.3 \
+ Moose::Meta::Attribute.3 \
+ Moose::Meta::Class.3 \
+ Moose::Meta::Role.3 \
+ Moose::Meta::TypeCoercion.3 \
+ Moose::Meta::TypeConstraint.3 \
+ Moose::Object.3 \
+ Moose::Role.3 \
+ Moose::Util::TypeConstraints.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Moose/distinfo b/devel/p5-Moose/distinfo
new file mode 100644
index 000000000000..dfb3f4480df1
--- /dev/null
+++ b/devel/p5-Moose/distinfo
@@ -0,0 +1,3 @@
+MD5 (Moose-0.03_02.tar.gz) = 7f4b012b0fc9b6af22973b7992c77f4f
+SHA256 (Moose-0.03_02.tar.gz) = 366bb2cc12c874347ae4d0adae6b25793a418bc51d84cf0d79dfcd520483ff04
+SIZE (Moose-0.03_02.tar.gz) = 41175
diff --git a/devel/p5-Moose/pkg-descr b/devel/p5-Moose/pkg-descr
new file mode 100644
index 000000000000..17935e166d71
--- /dev/null
+++ b/devel/p5-Moose/pkg-descr
@@ -0,0 +1,14 @@
+Moose is an extension of the Perl 5 object system.
+
+Another object system!?!?
+
+Yes, I know there has been an explosion recently of new ways to build
+objects in Perl 5, most of them based on inside-out objects, and other
+such things. Moose is different because it is not a new object system
+for Perl 5, but instead an extension of the existing object system.
+
+Moose is built on top of Class::MOP, which is a metaclass system for
+Perl 5. This means that Moose not only makes building normal Perl 5
+objects better, but it also provides the power of metaclass programming.
+
+WWW: http://search.cpan.org/dist/Moose/
diff --git a/devel/p5-Moose/pkg-plist b/devel/p5-Moose/pkg-plist
new file mode 100644
index 000000000000..c60f2ab2834e
--- /dev/null
+++ b/devel/p5-Moose/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Moose.pm
+%%SITE_PERL%%/Moose/Cookbook.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe1.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe2.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe3.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe4.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe5.pod
+%%SITE_PERL%%/Moose/Cookbook/Recipe6.pod
+%%SITE_PERL%%/Moose/Meta/Attribute.pm
+%%SITE_PERL%%/Moose/Meta/Class.pm
+%%SITE_PERL%%/Moose/Meta/Role.pm
+%%SITE_PERL%%/Moose/Meta/TypeCoercion.pm
+%%SITE_PERL%%/Moose/Meta/TypeConstraint.pm
+%%SITE_PERL%%/Moose/Object.pm
+%%SITE_PERL%%/Moose/Role.pm
+%%SITE_PERL%%/Moose/Util/TypeConstraints.pm
+@dirrmtry %%SITE_PERL%%/Moose/Util
+@dirrmtry %%SITE_PERL%%/Moose/Meta
+@dirrmtry %%SITE_PERL%%/Moose/Cookbook
+@dirrmtry %%SITE_PERL%%/Moose