aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-11 22:21:59 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-11 22:21:59 +0800
commita59a2fce3d514aacca48462768d7aca988802314 (patch)
treeaa9cb10c644c8c1fca1a67dfc6fa401ed0764b02
parentd448ba6350fe5f69a2383039d8f7f72e63fd4c1c (diff)
downloadfreebsd-ports-gnome-a59a2fce3d514aacca48462768d7aca988802314.tar.gz
freebsd-ports-gnome-a59a2fce3d514aacca48462768d7aca988802314.tar.zst
freebsd-ports-gnome-a59a2fce3d514aacca48462768d7aca988802314.zip
add OPTIONS_DEFINE, remove pkg-install.
-rw-r--r--devel/ocaml-sem/Makefile1
-rw-r--r--devel/ocaml-sem/pkg-install10
2 files changed, 1 insertions, 10 deletions
diff --git a/devel/ocaml-sem/Makefile b/devel/ocaml-sem/Makefile
index 7af8ea0ddfcc..45b9edc4f90e 100644
--- a/devel/ocaml-sem/Makefile
+++ b/devel/ocaml-sem/Makefile
@@ -21,6 +21,7 @@ MAKE_ENV= OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/sem" \
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= all
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+OPTIONS_DEFINE= DOCS
.if !defined(WITH_CUSTOM)
MAKE_ENV+= NO_CUSTOM=y
diff --git a/devel/ocaml-sem/pkg-install b/devel/ocaml-sem/pkg-install
deleted file mode 100644
index b765bfcc770b..000000000000
--- a/devel/ocaml-sem/pkg-install
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
- echo "${PKG_PREFIX}/lib/ocaml/site-lib/sem" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
-elif [ "$2" = "DEINSTALL" ]; then
- mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
- grep -v sem ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
- rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
- chmod 0644 ${PKG_PREFIX}/lib/ocaml/ld.conf
-fi