aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-05 23:58:25 +0800
committerkrion <krion@FreeBSD.org>2003-11-05 23:58:25 +0800
commita6078f40ef5d5d1e457da689be16b223d219c88f (patch)
tree53f4152e47f5b8eaab3a96428907e9a0763eabcb
parenta6897541bffc3b3a7c759cfed9d5961180a2a2e4 (diff)
downloadfreebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.tar.gz
freebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.tar.zst
freebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.zip
- Update to version 0.1.1
PR: 58962 Submitted by: Ports Fury
-rw-r--r--games/qgo/Makefile20
-rw-r--r--games/qgo/distinfo2
-rw-r--r--games/qgo/files/patch-board.cpp11
-rw-r--r--games/qgo/files/patch-boardhandler.cpp19
-rw-r--r--games/qgo/files/patch-noderesults.cpp15
-rw-r--r--games/qgo/files/patch-qgo::Makefile.in63
-rw-r--r--games/qgo/files/patch-qgo::src::wavfile.c19
-rw-r--r--games/qgo/files/patch-qgo::src::wavplay.c16
-rw-r--r--games/qgo/files/patch-tree.cpp16
-rw-r--r--games/qgo/pkg-plist50
10 files changed, 127 insertions, 104 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 7f0596d0c1df..3f8fe6436c89 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,24 +7,26 @@
#
PORTNAME= qgo
-PORTVERSION= 0.0.14
+PORTVERSION= 0.1.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A Go board and SGF editor written with the Qt library
-USE_REINPLACE= yes
USE_QT_VER= 3
-GNU_CONFIGURE= yes
-QTCPPFLAGS+= -DDONT_USE_GETOPT
-CONFIGURE_ENV= QTDIR=${X11BASE}
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR=${QT_PREFIX}
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
post-patch:
- ${REINPLACE_CMD} -e "s,libqt.so,libqt-mt.so,; \
- s,-O2, ${CFLAGS} ${PTHREAD_CFLAGS}," ${WRKSRC}/configure
- ${REINPLACE_CMD} -e "s,-lqt,-lqt-mt ${PTHREAD_LIBS}," ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-pedantic||g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|/usr/share|$${prefix}/share|g'
.include <bsd.port.mk>
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
index a733a9467b6f..772eed32ab92 100644
--- a/games/qgo/distinfo
+++ b/games/qgo/distinfo
@@ -1 +1 @@
-MD5 (qgo-0.0.14.tar.gz) = 4b64772b8b6ab5bc9919904db5e5ab0d
+MD5 (qgo-0.1.1.tar.gz) = e6c9f35fb0c24422b6b73f0bfb249ee7
diff --git a/games/qgo/files/patch-board.cpp b/games/qgo/files/patch-board.cpp
deleted file mode 100644
index 3b725e5cad22..000000000000
--- a/games/qgo/files/patch-board.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/board.cpp.orig Sat Feb 22 23:43:21 2003
-+++ src/board.cpp Sat Feb 22 23:43:35 2003
-@@ -2,6 +2,8 @@
- * board.cpp
- */
-
-+#include <qstack.h>
-+
- #include "config.h"
- #include "setting.h"
- #include "qgo.h"
diff --git a/games/qgo/files/patch-boardhandler.cpp b/games/qgo/files/patch-boardhandler.cpp
deleted file mode 100644
index f9013dd393bc..000000000000
--- a/games/qgo/files/patch-boardhandler.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/boardhandler.cpp.orig Sat Feb 22 23:15:42 2003
-+++ src/boardhandler.cpp Sat Feb 22 23:16:09 2003
-@@ -2,6 +2,8 @@
- * boardhandler.cpp
- */
-
-+#include <qstack.h>
-+
- #include "qgo.h"
- #include "boardhandler.h"
- #include "stonehandler.h"
-@@ -16,7 +18,6 @@
- #include "setting.h"
- #include <qapplication.h>
- #include <qclipboard.h>
--#include <qstack.h>
- #include <qlabel.h>
-
- #define MARK_TERRITORY_VISITED 99
diff --git a/games/qgo/files/patch-noderesults.cpp b/games/qgo/files/patch-noderesults.cpp
deleted file mode 100644
index 8cad8870f35c..000000000000
--- a/games/qgo/files/patch-noderesults.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/noderesults.cpp.orig Sat Feb 22 23:18:46 2003
-+++ src/noderesults.cpp Sat Feb 22 23:19:13 2003
-@@ -2,10 +2,11 @@
- * noderesults.cpp
- */
-
-+#include <qstack.h>
-+
- #include "noderesults.h"
- #include "move.h"
- #include "icons.h"
--#include <qstack.h>
- #include <qpixmap.h>
- #include <qiconview.h>
- #include <qpushbutton.h>
diff --git a/games/qgo/files/patch-qgo::Makefile.in b/games/qgo/files/patch-qgo::Makefile.in
new file mode 100644
index 000000000000..0924aa22979a
--- /dev/null
+++ b/games/qgo/files/patch-qgo::Makefile.in
@@ -0,0 +1,63 @@
+--- ../../Makefile.in Wed Sep 3 04:23:21 2003
++++ qgo/Makefile.in Mon Nov 3 02:02:16 2003
+@@ -251,6 +251,8 @@
+
+ # them while "make clean", use CLEANFILES
+ DISTCLEANFILES = $(qgo_METASOURCES)
++
++EXTRA_PROGRAMS = fubar
+ mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
+@@ -262,24 +264,36 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
++fubar_SOURCES = fubar.c
++#>- fubar_OBJECTS = fubar.$(OBJEXT)
++#>+ 1
++fubar_OBJECTS = fubar.$(OBJEXT)
++fubar_LDADD = $(LDADD)
++fubar_DEPENDENCIES =
++fubar_LDFLAGS =
+ #>- qgo_OBJECTS =
+ #>+ 1
+ qgo_OBJECTS =
+ qgo_DEPENDENCIES = ./src/libsrc.a
++CFLAGS = @CFLAGS@
++COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++CCLD = $(CC)
++LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+ DIST_COMMON = Makefile.am Makefile.in
+
+
+ #>- DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
+ #>+ 4
+-KDE_DIST=qgo.spec.in Doxyfile qgo.lsm.in qgo
++KDE_DIST=qgo.spec.in Doxyfile qgo.lsm.in
+
+ DISTFILES= $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
+
+
+-TAR = gtar
++TAR = tar
+ GZIP_ENV = --best
+-SOURCES = $(qgo_SOURCES)
+-OBJECTS = $(qgo_OBJECTS)
++SOURCES = fubar.c $(qgo_SOURCES)
++OBJECTS = fubar.$(OBJEXT) $(qgo_OBJECTS)
+
+ #>- all: all-redirect
+ #>+ 1
+@@ -366,6 +380,10 @@
+
+ maintainer-clean-libtool:
+
++fubar$(EXEEXT): $(fubar_OBJECTS) $(fubar_DEPENDENCIES)
++ @rm -f fubar$(EXEEXT)
++ $(LINK) $(fubar_LDFLAGS) $(fubar_OBJECTS) $(fubar_LDADD) $(LIBS)
++
+ qgo$(EXEEXT): $(qgo_OBJECTS) $(qgo_DEPENDENCIES)
+ @rm -f qgo$(EXEEXT)
+ $(LINK) $(qgo_LDFLAGS) $(qgo_OBJECTS) $(qgo_LDADD) $(LIBS)
diff --git a/games/qgo/files/patch-qgo::src::wavfile.c b/games/qgo/files/patch-qgo::src::wavfile.c
new file mode 100644
index 000000000000..68693e1b60da
--- /dev/null
+++ b/games/qgo/files/patch-qgo::src::wavfile.c
@@ -0,0 +1,19 @@
+--- qgo/src/wavfile.c.orig Tue Jun 24 06:57:08 2003
++++ qgo/src/wavfile.c Mon Nov 3 00:49:30 2003
+@@ -53,7 +53,6 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <malloc.h>
+ #include <string.h>
+ #include <memory.h>
+ #include <signal.h>
+@@ -61,7 +60,7 @@
+ #include <sys/ipc.h>
+ #include <sys/ioctl.h>
+ #include <assert.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+
+
+ // stop
diff --git a/games/qgo/files/patch-qgo::src::wavplay.c b/games/qgo/files/patch-qgo::src::wavplay.c
new file mode 100644
index 000000000000..a8a97afff099
--- /dev/null
+++ b/games/qgo/files/patch-qgo::src::wavplay.c
@@ -0,0 +1,16 @@
+--- qgo/src/wavplay.c.orig Tue Jun 24 06:57:09 2003
++++ qgo/src/wavplay.c Mon Nov 3 00:50:02 2003
+@@ -55,12 +55,11 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include <string.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <sys/stat.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include "wavplay.h"
+ //#include "server.h"
+
diff --git a/games/qgo/files/patch-tree.cpp b/games/qgo/files/patch-tree.cpp
deleted file mode 100644
index f6ff73558b3d..000000000000
--- a/games/qgo/files/patch-tree.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/tree.cpp.orig Sat Feb 22 23:13:45 2003
-+++ src/tree.cpp Sat Feb 22 23:13:52 2003
-@@ -2,11 +2,12 @@
- * tree.cpp
- */
-
-+#include <qstack.h>
-+
- #include "tree.h"
- #include "move.h"
- #include "qgo.h"
- #include <iostream.h>
--#include <qstack.h>
-
- Tree::Tree(int board_size)
- {
diff --git a/games/qgo/pkg-plist b/games/qgo/pkg-plist
index d5ed9e5d65af..6d2cd6b6685f 100644
--- a/games/qgo/pkg-plist
+++ b/games/qgo/pkg-plist
@@ -1,33 +1,17 @@
-bin/qGo
-share/qgo/sounds/enter.wav
-share/qgo/sounds/match.wav
-share/qgo/sounds/leave.wav
-share/qgo/sounds/say.wav
-share/qgo/sounds/gameend.wav
-share/qgo/sounds/pass.wav
-share/qgo/sounds/stone.wav
-share/qgo/sounds/talk.wav
-share/qgo/sounds/tictoc.wav
-share/qgo/translations/qgo_de.qm
-share/qgo/translations/qgo_fr.qm
-share/doc/qgo/html/images/note.png
-share/doc/qgo/html/images/tip.png
-share/doc/qgo/html/images/warning.png
-share/doc/qgo/html/ch01.html
-share/doc/qgo/html/ch01s04.html
-share/doc/qgo/html/ch02.html
-share/doc/qgo/html/ch02s02.html
-share/doc/qgo/html/ch02s03.html
-share/doc/qgo/html/ch03.html
-share/doc/qgo/html/ch03s02.html
-share/doc/qgo/html/ch03s23.html
-share/doc/qgo/html/ch03s28.html
-share/doc/qgo/html/ch03s31.html
-share/doc/qgo/html/index.html
-share/doc/qgo/html/pr01.html
-@dirrm share/doc/qgo/html/images
-@dirrm share/doc/qgo/html
-@dirrm share/doc/qgo
-@dirrm share/qgo/sounds
-@dirrm share/qgo/translations
-@dirrm share/qgo
+bin/qgo
+share/qGo/sounds/click.wav
+share/qGo/sounds/connect.wav
+share/qGo/sounds/enter.wav
+share/qGo/sounds/gameend.wav
+share/qGo/sounds/leave.wav
+share/qGo/sounds/match.wav
+share/qGo/sounds/pass.wav
+share/qGo/sounds/say.wav
+share/qGo/sounds/stone.wav
+share/qGo/sounds/talk.wav
+share/qGo/sounds/tictoc.wav
+share/qGo/translations/qgo_de.qm
+share/qGo/translations/qgo_fr.qm
+@dirrm share/qGo/translations
+@dirrm share/qGo/sounds
+@dirrm share/qGo