aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-05-13 20:10:25 +0800
committerknu <knu@FreeBSD.org>2002-05-13 20:10:25 +0800
commita8cd5f06c54fb88a19fd5dd5659e1d3da84e6ce9 (patch)
treeffba18b7282765d8e7bb808439818716fdeb20f7
parentfff1c977c2e74a1415e5397ad53cd7b67b6c88ab (diff)
downloadfreebsd-ports-gnome-a8cd5f06c54fb88a19fd5dd5659e1d3da84e6ce9.tar.gz
freebsd-ports-gnome-a8cd5f06c54fb88a19fd5dd5659e1d3da84e6ce9.tar.zst
freebsd-ports-gnome-a8cd5f06c54fb88a19fd5dd5659e1d3da84e6ce9.zip
Add ruby-image_size version 20020105, a Ruby library to measure the
size of a given image file.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ruby-image_size/Makefile49
-rw-r--r--graphics/ruby-image_size/distinfo1
-rw-r--r--graphics/ruby-image_size/pkg-comment1
-rw-r--r--graphics/ruby-image_size/pkg-descr4
-rw-r--r--graphics/ruby-image_size/pkg-plist6
6 files changed, 62 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f8cdf9b1e8e1..cf93aa01b2ee 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -285,6 +285,7 @@
SUBDIR += ruby-gdk_pixbuf
SUBDIR += ruby-gimp
SUBDIR += ruby-graph
+ SUBDIR += ruby-image_size
SUBDIR += ruby-imlib2
SUBDIR += ruby-libpng
SUBDIR += ruby-ming
diff --git a/graphics/ruby-image_size/Makefile b/graphics/ruby-image_size/Makefile
new file mode 100644
index 000000000000..f5101a099a35
--- /dev/null
+++ b/graphics/ruby-image_size/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: image_size
+# Date created: 13 May 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= image_size
+PORTVERSION= 0.0.20020105
+CATEGORIES= graphics ruby
+MASTER_SITES= http://www.rubycgi.org/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}.${PORTVERSION:E}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DOCS= readme.en.html
+DOCS_JA= readme.ja.rd readme.ja.html
+
+do-build:
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC}; \
+ ${RUBY_RD} image_size.rb > readme.en.html
+ @cd ${WRKSRC}; \
+ ${RUBY_RD} readme.ja.rd > readme.ja.html
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/image_size.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ruby-image_size/distinfo b/graphics/ruby-image_size/distinfo
new file mode 100644
index 000000000000..7b53a65160bd
--- /dev/null
+++ b/graphics/ruby-image_size/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/image_size.20020105.tgz) = f6e7e45230ac6208e00313321d7212ad
diff --git a/graphics/ruby-image_size/pkg-comment b/graphics/ruby-image_size/pkg-comment
new file mode 100644
index 000000000000..f528ab2d9b76
--- /dev/null
+++ b/graphics/ruby-image_size/pkg-comment
@@ -0,0 +1 @@
+A Ruby library to measure the size of a given image file
diff --git a/graphics/ruby-image_size/pkg-descr b/graphics/ruby-image_size/pkg-descr
new file mode 100644
index 000000000000..1f251e23e7aa
--- /dev/null
+++ b/graphics/ruby-image_size/pkg-descr
@@ -0,0 +1,4 @@
+This is a Ruby library to measure the size of a given image file.
+
+Author: Keisuke Minami <keisuke@rccn.com>
+WWW: http://www.rubycgi.org/tools/index.en.htm
diff --git a/graphics/ruby-image_size/pkg-plist b/graphics/ruby-image_size/pkg-plist
new file mode 100644
index 000000000000..974d34af527f
--- /dev/null
+++ b/graphics/ruby-image_size/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITELIBDIR%%/image_size.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/image_size/readme.en.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/image_size/ja/readme.ja.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/image_size/ja/readme.ja.html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/image_size/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/image_size