aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-10-30 10:25:40 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-10-30 10:25:40 +0800
commitabfb3501ea3723445e9e465560e905583fce7430 (patch)
treecf8918f24192f80ceee16afe6b2d513e8a55a9df
parent8eec93a89f3ae844e015247a68444ded9d54901a (diff)
downloadfreebsd-ports-gnome-abfb3501ea3723445e9e465560e905583fce7430.tar.gz
freebsd-ports-gnome-abfb3501ea3723445e9e465560e905583fce7430.tar.zst
freebsd-ports-gnome-abfb3501ea3723445e9e465560e905583fce7430.zip
www/libevhtp: update 1.2.9 -> 1.2.10 and assorted fixes
- Update PORTVERSION, GH_TAGNAME, and distinfo for 1.2.10 - include/onigposix.h in PLIST when EVHTP_DISABLE_REGEX is not selected - include/evthr.h when option EVHTP_DISABLE_EVTHR is not selected - Add patch to ensure symbol gets exported from evhtp.h - Recreated patch files for portlint PR: 204054 Submitted by: trasz (original patch, multiple changes from maintainer) Approved by: Ricky Gallamore <ultima1252@gmail.com> (maintainer)
-rw-r--r--www/libevhtp/Makefile16
-rw-r--r--www/libevhtp/distinfo4
-rw-r--r--www/libevhtp/files/patch-evhtp.c6
-rw-r--r--www/libevhtp/files/patch-evhtp.h11
4 files changed, 25 insertions, 12 deletions
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
index df8b842ee49e..43bdb37b57d5 100644
--- a/www/libevhtp/Makefile
+++ b/www/libevhtp/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libevhtp
-PORTVERSION= 1.2.9
-PORTREVISION= 3
+PORTVERSION= 1.2.10
CATEGORIES= www
MAINTAINER= ultima1252@gmail.com
@@ -15,10 +14,10 @@ LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
USE_GITHUB= yes
GH_ACCOUNT= ellzey
-GH_TAGNAME= 3886506
+GH_TAGNAME= ba4c44e
USES= cmake:outsource
-USE_LDCONFIG= YES
+USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:PATH=include/event2 \
-DCMAKE_LIBRARY_PATH:PATH=lib/event2
CMAKE_BUILD_TYPE= Release
@@ -46,15 +45,18 @@ OPTIONS_DEFAULT= EVHTP_BUILD_SHARED
.include <bsd.port.options.mk>
-PLIST_FILES= include/evhtp.h\
+PLIST_FILES= include/evhtp.h \
include/evhtp-config.h \
- include/evthr.h \
include/htparse.h
-.if !exists(${LOCALBASE}/include/onigposix.h)
+.if !exists(${LOCALBASE}/include/onigposix.h) && !${PORT_OPTIONS:MEVHTP_DISABLE_REGEX}
PLIST_FILES+= include/onigposix.h
.endif
+.if !${PORT_OPTIONS:MEVHTP_DISABLE_EVTHR}
+PLIST_FILES+= include/evthr.h
+.endif
+
.if ${PORT_OPTIONS:MEVHTP_BUILD_SHARED}
PLIST_FILES+= lib/libevhtp.so
.else
diff --git a/www/libevhtp/distinfo b/www/libevhtp/distinfo
index 73c62a589eff..66d5a4f175c6 100644
--- a/www/libevhtp/distinfo
+++ b/www/libevhtp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ellzey-libevhtp-1.2.9-3886506_GH0.tar.gz) = b012587dfbf3e12fb2939d4f4856f966513c754bd6f0accffff8d8edef3b629d
-SIZE (ellzey-libevhtp-1.2.9-3886506_GH0.tar.gz) = 360681
+SHA256 (ellzey-libevhtp-1.2.10-ba4c44e_GH0.tar.gz) = d5b022e2a3847ed7344bc7bca7ac7feb6b4a7e877d12452a15a96ba1c760d25a
+SIZE (ellzey-libevhtp-1.2.10-ba4c44e_GH0.tar.gz) = 373482
diff --git a/www/libevhtp/files/patch-evhtp.c b/www/libevhtp/files/patch-evhtp.c
index 465ef1e2132f..53bd18f7adf8 100644
--- a/www/libevhtp/files/patch-evhtp.c
+++ b/www/libevhtp/files/patch-evhtp.c
@@ -1,5 +1,5 @@
---- evhtp.c.orig 2014-03-23 11:50:50.000000000 +0000
-+++ evhtp.c 2014-09-13 12:37:11.000000000 +0000
+--- evhtp.c.orig 2015-02-24 07:55:55 UTC
++++ evhtp.c
@@ -7,6 +7,7 @@
#include <strings.h>
#include <inttypes.h>
@@ -8,7 +8,7 @@
#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/tcp.h>
-@@ -2740,7 +2741,14 @@
+@@ -3170,7 +3171,14 @@ evhtp_bind_sockaddr(evhtp_t * htp, struc
sock = evconnlistener_get_fd(htp->server);
diff --git a/www/libevhtp/files/patch-evhtp.h b/www/libevhtp/files/patch-evhtp.h
new file mode 100644
index 000000000000..963bdc8ec90b
--- /dev/null
+++ b/www/libevhtp/files/patch-evhtp.h
@@ -0,0 +1,11 @@
+--- evhtp.h.orig 2015-10-29 19:51:50 UTC
++++ evhtp.h
+@@ -1285,7 +1285,7 @@ EVHTP_EXPORT evhtp_connection_t *
+ evhtp_connection_new(evbase_t * evbase, const char * addr, uint16_t port);
+
+ #ifndef DISABLE_SSL
+-evhtp_connection_t * evhtp_connection_ssl_new(evbase_t * evbase, const char * addr, uint16_t port, evhtp_ssl_ctx_t * ctx);
++EVHTP_EXPORT evhtp_connection_t * evhtp_connection_ssl_new(evbase_t * evbase, const char * addr, uint16_t port, evhtp_ssl_ctx_t * ctx);
+ #endif
+
+