aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-10-29 12:25:09 +0800
committermaho <maho@FreeBSD.org>2007-10-29 12:25:09 +0800
commitad3347d56c918e3b522d97e600e24cdd6f7ada7d (patch)
tree3cf52f328c2b06dfe1075c9f05406702ab8b5814
parent812d26970cc88850fa2843051b46adb544570428 (diff)
downloadfreebsd-ports-gnome-ad3347d56c918e3b522d97e600e24cdd6f7ada7d.tar.gz
freebsd-ports-gnome-ad3347d56c918e3b522d97e600e24cdd6f7ada7d.tar.zst
freebsd-ports-gnome-ad3347d56c918e3b522d97e600e24cdd6f7ada7d.zip
Fix build on package cluster. Actually we needed
X display with GL support to compile. Submitted by: pav
-rw-r--r--graphics/f90gl/Makefile8
-rw-r--r--graphics/f90gl/files/extra-disable-mkfppinc11
-rw-r--r--graphics/f90gl/files/glopt.h22
3 files changed, 41 insertions, 0 deletions
diff --git a/graphics/f90gl/Makefile b/graphics/f90gl/Makefile
index 134ab64bb855..6d72354af86b 100644
--- a/graphics/f90gl/Makefile
+++ b/graphics/f90gl/Makefile
@@ -43,6 +43,10 @@ PLIST_SUB= WITH_EXAMPLES="@comment "
PLIST_SUB= WITH_EXAMPLES=""
.endif
+.if !defined (OPENGL_DISPLAY)
+EXTRA_PATCHES= ${PATCHDIR}/extra-disable-mkfppinc
+.endif
+
post-patch:
${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
@@ -67,6 +71,10 @@ pre-build:
-e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC_SHARED}/examples/mf8lnt
do-build:
+.if !defined (OPENGL_DISPLAY)
+ ${CP} ${FILESDIR}/glopt.h ${WRKSRC}/util
+ ${CP} ${FILESDIR}/glopt.h ${WRKSRC_SHARED}/util
+.endif
cd ${WRKSRC} ; ${MAKE} -f mf8lim7
cd ${WRKSRC_SHARED} ; ${MAKE} -f mf8lim7
cd ${WRKSRC_SHARED}/examples ; ${MAKE} -f mf8lnt
diff --git a/graphics/f90gl/files/extra-disable-mkfppinc b/graphics/f90gl/files/extra-disable-mkfppinc
new file mode 100644
index 000000000000..203ae57be405
--- /dev/null
+++ b/graphics/f90gl/files/extra-disable-mkfppinc
@@ -0,0 +1,11 @@
+--- util/mfmost~ 2004-01-27 01:16:24.000000000 +0900
++++ util/mfmost 2007-10-29 12:59:07.000000000 +0900
+@@ -5,7 +5,7 @@
+
+ mkfppinc: mkfppinc.c
+ $(CC) $(CFLAGS) $(OGLINC) -o mkfppinc mkfppinc.c $(OGLLIBDIR) $(OGLLIB) $(X11LIBDIR) $(X11LIB)
+- ./mkfppinc
++ #./mkfppinc
+ cat glopt.h $(F90PPR_INC) > fpprinc.h
+
+ clean:
diff --git a/graphics/f90gl/files/glopt.h b/graphics/f90gl/files/glopt.h
new file mode 100644
index 000000000000..b25e9f434e39
--- /dev/null
+++ b/graphics/f90gl/files/glopt.h
@@ -0,0 +1,22 @@
+#define GL_EXT_abgr
+#define GL_EXT_blend_color
+#define GL_EXT_blend_logic_op
+#define GL_EXT_blend_minmax
+#define GL_EXT_blend_subtract
+#define GL_EXT_color_table
+#define GL_EXT_paletted_texture
+#define GL_EXT_point_parameters
+#define GL_EXT_polygon_offset
+#define GL_EXT_rescale_normal
+#define GL_EXT_shared_texture_palette
+#define GL_EXT_subtexture
+#define GL_EXT_texture3D
+#define GL_EXT_texture_object
+#define GL_EXT_vertex_array
+#undef GL_SGIS_multisample
+#define GL_MESA_resize_buffers
+#define GL_MESA_window_pos
+#define OPENGL_1_0
+#define OPENGL_1_1
+#define OPENGL_1_2
+#define OPENGL_1_3