aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 07:35:55 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 07:35:55 +0800
commitb07777467458ed83985215db14c2c57b604012e7 (patch)
treec24350bc9acbe5f8d1af8b1bf441ff8a5a830ba6
parentf67f6b170736ff580f751ae452fad56e52432d76 (diff)
downloadfreebsd-ports-gnome-b07777467458ed83985215db14c2c57b604012e7.tar.gz
freebsd-ports-gnome-b07777467458ed83985215db14c2c57b604012e7.tar.zst
freebsd-ports-gnome-b07777467458ed83985215db14c2c57b604012e7.zip
New port: Prerelease version of libICE from freedesktop.org:
Inter Client Exchange library for X11 Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libICE/Makefile32
-rw-r--r--x11/libICE/distinfo1
-rw-r--r--x11/libICE/files/patch-Makefile.in11
-rw-r--r--x11/libICE/pkg-descr6
-rw-r--r--x11/libICE/pkg-plist12
6 files changed, 63 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d307389a1247..2557905a8038 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -72,6 +72,7 @@
SUBDIR += kdelibs3
SUBDIR += keylaunch
SUBDIR += kgamma
+ SUBDIR += libICE
SUBDIR += libX11
SUBDIR += libXau
SUBDIR += libXtrans
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
new file mode 100644
index 000000000000..ddfa336da5c7
--- /dev/null
+++ b/x11/libICE/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libICE
+# Date Created: 09 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libICE
+PORTVERSION= 6.3.1.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Inter Client Exchange library for X11
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xtrans.pc:${PORTSDIR}/x11/libXtrans \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.3.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libICE/distinfo b/x11/libICE/distinfo
new file mode 100644
index 000000000000..a687b08424d2
--- /dev/null
+++ b/x11/libICE/distinfo
@@ -0,0 +1 @@
+MD5 (libICE-6.3.1.p2.tar.bz2) = 4eb03a318ea5c884817de9c8e4be96b2
diff --git a/x11/libICE/files/patch-Makefile.in b/x11/libICE/files/patch-Makefile.in
new file mode 100644
index 000000000000..6c9439f8a395
--- /dev/null
+++ b/x11/libICE/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 21:20:38 2003
++++ Makefile.in Sun Nov 9 22:54:17 2003
+@@ -180,7 +180,7 @@
+ include/X11/ICE/ICEutil.h
+
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = ice.pc
+
+ EXTRA_DIST = ice.pc.in
diff --git a/x11/libICE/pkg-descr b/x11/libICE/pkg-descr
new file mode 100644
index 000000000000..8a75f1bb6efb
--- /dev/null
+++ b/x11/libICE/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the Inter Client Exchange library for X11.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libICE/pkg-plist b/x11/libICE/pkg-plist
new file mode 100644
index 000000000000..1cd16b2ffaba
--- /dev/null
+++ b/x11/libICE/pkg-plist
@@ -0,0 +1,12 @@
+include/X11/ICE/ICE.h
+include/X11/ICE/ICEconn.h
+include/X11/ICE/ICElib.h
+include/X11/ICE/ICEmsg.h
+include/X11/ICE/ICEproto.h
+include/X11/ICE/ICEtrans.h
+include/X11/ICE/ICEutil.h
+lib/libICE.a
+lib/libICE.la
+lib/libICE.so
+lib/libICE.so.6
+libdata/pkgconfig/ice.pc