aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-08-22 05:00:33 +0800
committerdougb <dougb@FreeBSD.org>2012-08-22 05:00:33 +0800
commitb27652b43bdb1dc4a973d1db0d0da523579e215b (patch)
tree687cc3167fd1d7bdcfa54b68496dfda41bdf40fa
parent0ebe4ddc54831b4e06084ce6d046dbba142175ce (diff)
downloadfreebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.tar.gz
freebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.tar.zst
freebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied.
-rw-r--r--mail/missey/Makefile1
-rw-r--r--net-mgmt/ipacctd/Makefile4
-rw-r--r--net/frickin/Makefile4
-rw-r--r--net/stund/Makefile5
-rw-r--r--net/yate/Makefile5
-rw-r--r--security/isakmpd/Makefile4
-rw-r--r--security/snortsam/Makefile4
-rw-r--r--sysutils/rsyncmanager/Makefile5
8 files changed, 22 insertions, 10 deletions
diff --git a/mail/missey/Makefile b/mail/missey/Makefile
index 34d5b0818317..42280a7b680f 100644
--- a/mail/missey/Makefile
+++ b/mail/missey/Makefile
@@ -29,6 +29,7 @@ USE_RC_SUBR= mps
post-extract:
@${MV} ${WRKDIR}/mps/src ${WRKSRC}
+ @${RM} -r ${WRKDIR}/mps
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
diff --git a/net-mgmt/ipacctd/Makefile b/net-mgmt/ipacctd/Makefile
index 5abeacb81035..411ede3422d4 100644
--- a/net-mgmt/ipacctd/Makefile
+++ b/net-mgmt/ipacctd/Makefile
@@ -16,13 +16,15 @@ COMMENT= IP accounting using divert socket
USE_RC_SUBR= ipacctd
-WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV+= BINDIR="${PREFIX}/sbin"
MAN8= ipacctd.8
MANLANG= "" ru.KOI8-R
MANCOMPRESSED= yes
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
diff --git a/net/frickin/Makefile b/net/frickin/Makefile
index d1596cd32063..40dd04ac7b8e 100644
--- a/net/frickin/Makefile
+++ b/net/frickin/Makefile
@@ -15,12 +15,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= asm@asm.kiev.ua
COMMENT= Frickin PPTP Proxy
-WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RC_SUBR= frickin
SUB_FILES= pkg-message
PORTDOCS= INSTALL LICENSE
PLIST_FILES= sbin/frickin2 etc/frickin.conf.sample
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g;' \
${WRKSRC}/src/Makefile.FreeBSD
diff --git a/net/stund/Makefile b/net/stund/Makefile
index 8038874c507b..f4557fc468be 100644
--- a/net/stund/Makefile
+++ b/net/stund/Makefile
@@ -15,12 +15,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sobomax@FreeBSD.org
COMMENT= A simple STUN (RFC 3489) server and client
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USE_GMAKE= yes
USE_RC_SUBR= stund
MAKE_ENV= "CXX=${CXX}"
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/sbin/stund
${INSTALL_PROGRAM} ${WRKSRC}/client ${PREFIX}/bin/stun_client
diff --git a/net/yate/Makefile b/net/yate/Makefile
index ceb5f445ad93..a2186787e0b0 100644
--- a/net/yate/Makefile
+++ b/net/yate/Makefile
@@ -25,8 +25,6 @@ USE_LDCONFIG= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/yate
-
CONFIGURE_ARGS= --without-fdsize \
--without-libqt4 \
--with-zlib=/usr
@@ -162,6 +160,9 @@ PLIST_SUB+= WITH_ALSA="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs
.endif
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-install:
@cd ${PREFIX}/etc/${PORTNAME}; \
for cfg in *.sample; do \
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index d039ca6bcb6e..3bf44d1f2db1 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -26,7 +26,6 @@ BUILD_DEPENDS+= keynote:${PORTSDIR}/security/keynote
.endif
USE_RC_SUBR= isakmpd
-WRKSRC= ${WRKDIR}/isakmpd
MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man LC_ALL=C
MAN5= isakmpd.conf.5 isakmpd.policy.5
@@ -41,6 +40,9 @@ OPENSSLINC?= /usr/include
OPENSSLLIB?= /usr/lib
MAKE_ENV+= OPENSSLINC="${OPENSSLINC}" OPENSSLLIB="${OPENSSLLIB}"
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-patch:
.for f in conf.h ike_auth.c isakmpd.8 isakmpd.conf.5 isakmpd.policy.5 policy.h
${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/${f}
diff --git a/security/snortsam/Makefile b/security/snortsam/Makefile
index 8baee38d07a6..14030bb3aba9 100644
--- a/security/snortsam/Makefile
+++ b/security/snortsam/Makefile
@@ -28,7 +28,6 @@ SUB_FILES= pkg-message \
HAS_CONFIGURE= yes
NO_BUILD= yes
CONFIGURE_SCRIPT= src/Makefile
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
CONFIG_DIR?= ${PREFIX}/etc/snortsam
@@ -55,6 +54,9 @@ EXTRA_PATCHES+= ${FILESDIR}/ssp_ipfw2_no_table_check.patch
DEBUG=-DDEBUG
.endif
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
pre-configure:
@${REINPLACE_CMD} -e "s|/etc/snortsam.conf|${CONFIG_DIR}/snortsam.conf|g" ${WRKSRC}/conf/snortsam.conf.sample
@${REINPLACE_CMD} -e "s|/etc/snortsam.conf|${CONFIG_DIR}/snortsam.conf|g" ${WRKSRC}/docs/README.conf
diff --git a/sysutils/rsyncmanager/Makefile b/sysutils/rsyncmanager/Makefile
index da6b107f3994..2e3038e8d9ac 100644
--- a/sysutils/rsyncmanager/Makefile
+++ b/sysutils/rsyncmanager/Makefile
@@ -15,8 +15,6 @@ COMMENT= Flexible rsync resource manager daemon written in ruby
RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USE_RUBY= yes
USE_RUBY_FEATURES= ruby18
@@ -27,6 +25,9 @@ PORTDOCS= README
USE_RC_SUBR= ${PORTNAME}
SUB_LIST= RUBY_WITHOUT_SUFFIX="${RUBY_WITHOUT_SUFFIX}"
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.rb ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/documentation/${PORTNAME}.xml ${PREFIX}/etc/${PORTNAME}.xml.sample