aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-09-27 22:23:28 +0800
committermnag <mnag@FreeBSD.org>2006-09-27 22:23:28 +0800
commitb2dccf1c1929d6f7eea3bce62ac2ad29f59fb697 (patch)
tree3fd3e5e1fe2922d5abc3d538c07be4aba2fa19e8
parentd7ea16af686751b8ed924bca229dca91c071f197 (diff)
downloadfreebsd-ports-gnome-b2dccf1c1929d6f7eea3bce62ac2ad29f59fb697.tar.gz
freebsd-ports-gnome-b2dccf1c1929d6f7eea3bce62ac2ad29f59fb697.tar.zst
freebsd-ports-gnome-b2dccf1c1929d6f7eea3bce62ac2ad29f59fb697.zip
- Apply fix to ulong problem. http://bugs.mysql.com/bug.php?id=22227
- Bump -client PORTREVISION - portlint Approved by: maintainer (ale)
-rw-r--r--databases/mysql50-client/Makefile1
-rw-r--r--databases/mysql50-server/Makefile2
-rw-r--r--databases/mysql50-server/files/patch-include__mysql_com.h21
3 files changed, 23 insertions, 1 deletions
diff --git a/databases/mysql50-client/Makefile b/databases/mysql50-client/Makefile
index 302a1133672f..5d093767548b 100644
--- a/databases/mysql50-client/Makefile
+++ b/databases/mysql50-client/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= mysql
+PORTREVISION= 1
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 0493e316ba96..7e647956d946 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -188,7 +188,7 @@ CONFIGURE_ARGS+=--without-server
.if ${OSVERSION} < 500000
PLIST_SUB+= ZLIB=""
.else
-PLIST_SUB+= ZLIB="@comment "
+PLIST_SUB+= ZLIB="@comment "
.endif
post-patch:
diff --git a/databases/mysql50-server/files/patch-include__mysql_com.h b/databases/mysql50-server/files/patch-include__mysql_com.h
new file mode 100644
index 000000000000..7ecc1d7e45ee
--- /dev/null
+++ b/databases/mysql50-server/files/patch-include__mysql_com.h
@@ -0,0 +1,21 @@
+#
+# Apply fix for MySQL bug http://bugs.mysql.com/bug.php?id=22227
+#
+--- include/mysql_com.h.orig Fri Aug 25 18:11:46 2006
++++ include/mysql_com.h Wed Sep 27 10:02:44 2006
+@@ -134,11 +134,11 @@
+ #define CLIENT_TRANSACTIONS 8192 /* Client knows about transactions */
+ #define CLIENT_RESERVED 16384 /* Old flag for 4.1 protocol */
+ #define CLIENT_SECURE_CONNECTION 32768 /* New 4.1 authentication */
+-#define CLIENT_MULTI_STATEMENTS (((ulong) 1) << 16) /* Enable/disable multi-stmt support */
+-#define CLIENT_MULTI_RESULTS (((ulong) 1) << 17) /* Enable/disable multi-results */
++#define CLIENT_MULTI_STATEMENTS (1UL << 16) /* Enable/disable multi-stmt support */
++#define CLIENT_MULTI_RESULTS (1UL << 17) /* Enable/disable multi-results */
+
+-#define CLIENT_SSL_VERIFY_SERVER_CERT (((ulong) 1) << 30)
+-#define CLIENT_REMEMBER_OPTIONS (((ulong) 1) << 31)
++#define CLIENT_SSL_VERIFY_SERVER_CERT (1UL << 30)
++#define CLIENT_REMEMBER_OPTIONS (1UL << 31)
+
+ #define SERVER_STATUS_IN_TRANS 1 /* Transaction has started */
+ #define SERVER_STATUS_AUTOCOMMIT 2 /* Server in auto_commit mode */