aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-06-27 04:31:46 +0800
committerohauer <ohauer@FreeBSD.org>2011-06-27 04:31:46 +0800
commitb37d40cb09da51c12a13b09a81cbb2bd027ba0a4 (patch)
treeb7c64be6c3f40f1806e5566958854c7315b8cb42
parentb05429ed3c40a5cf7c12eb394986a5a042c87fcb (diff)
downloadfreebsd-ports-gnome-b37d40cb09da51c12a13b09a81cbb2bd027ba0a4.tar.gz
freebsd-ports-gnome-b37d40cb09da51c12a13b09a81cbb2bd027ba0a4.tar.zst
freebsd-ports-gnome-b37d40cb09da51c12a13b09a81cbb2bd027ba0a4.zip
- fix USE_APACHE, should be exclusive 13 else the only port
depending on this one will fail if apache22 is set as default no version bump (apache22 is not the default at the moment) From the actual git repo: http://slashcode.git.sourceforge.net/git/gitweb.cgi?p=slashcode/slashcode;a=tree;h=refs/heads/live;hb=live Install: Apache: Version 1.3.34 (1.3.33). Since most of Apache 1.3.x's recent releases included security fixes, we wouldn't recommend running an earlier version. Slash is not compatible with Apache 2.x and we have no plans to port to 2.x (though we aren't excluding the possibility). mod_perl: Version 1.29. with hat apache@
-rw-r--r--www/p5-Bundle-Slash/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/www/p5-Bundle-Slash/Makefile b/www/p5-Bundle-Slash/Makefile
index 1624bedfdc91..24500ca1982d 100644
--- a/www/p5-Bundle-Slash/Makefile
+++ b/www/p5-Bundle-Slash/Makefile
@@ -37,11 +37,15 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
- ${SITE_PERL}/DBIx/Password.pm:${PORTSDIR}/databases/p5-DBIx-Password
+ ${SITE_PERL}/DBIx/Password.pm:${PORTSDIR}/databases/p5-DBIx-Password \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
+ ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI-mp1
+
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-USE_APACHE= 13+
+USE_APACHE= 13
USE_MYSQL= yes
.include <bsd.port.pre.mk>
@@ -49,14 +53,6 @@ USE_MYSQL= yes
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
-.if ${APACHE_VERSION} == 13
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
- ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI-mp1
-.else
-RUN_DEPENDS+= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI-mp2
-.endif
-
MAN3= Bundle::Slash.3
.include <bsd.port.post.mk>