aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-03-05 15:12:24 +0800
committerrm <rm@FreeBSD.org>2013-03-05 15:12:24 +0800
commitb3878a85db367a2995b27a6a38e9cf972a629ee5 (patch)
tree5b403d5125ac1fb093a8966406e443e1df61bf05
parent5099e1238843d8608bddd8d281d503577f31a176 (diff)
downloadfreebsd-ports-gnome-b3878a85db367a2995b27a6a38e9cf972a629ee5.tar.gz
freebsd-ports-gnome-b3878a85db367a2995b27a6a38e9cf972a629ee5.tar.zst
freebsd-ports-gnome-b3878a85db367a2995b27a6a38e9cf972a629ee5.zip
- replace deprecated devel/py-setuptools with devel/py-distribute
- change explicit dependency for the ports, that don't utilize USE_DISTUTILS feature - add UPDATING entry PR: 176142 Submitted by: rm (myself) Approved by: portmgr (miwi) Tested by: exp-run by miwi
-rw-r--r--Mk/bsd.python.mk5
-rw-r--r--UPDATING14
-rw-r--r--devel/trac-bitten/Makefile4
-rw-r--r--net-mgmt/net-snmp/Makefile4
4 files changed, 18 insertions, 9 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index f8951fc90f45..38f3d62c59bb 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -460,13 +460,8 @@ PYTHONPREFIX_SITELIBDIR= ${PYTHON_SITELIBDIR:S;${PYTHONBASE};${PREFIX};}
# setuptools support
.if defined(USE_PYDISTUTILS) && ${USE_PYDISTUTILS} == "easy_install"
-.if ${PYTHON_SUFFIX} < 30
-BUILD_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-.else
BUILD_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-distribute
RUN_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-distribute
-.endif
PYDISTUTILS_BUILD_TARGET?= bdist_egg
PYDISTUTILS_INSTALL_TARGET?= easy_install
diff --git a/UPDATING b/UPDATING
index ec837003c75c..74badd7be818 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130305:
+ AFFECTS: users of devel/py-setuptools (i.e you)
+ AUTHOR: rm@FreeBSD.org
+
+ devel/py-setuptools was replaced with devel/py-distribute. Please do
+ the following according to package manager used. py-setuptools port
+ will be removed shortly.
+
+ # portmaster -o devel/py-distribute devel/py-setuptools
+ or
+ # portupgrade -fo devel/py-distribute devel/py-setuptools
+ or
+ # pkg set -o devel/py-setuptools:devel/py-distribute
+
20130226:
AFFECTS: users of textproc/apache-solr
AUTHOR: vanilla@FreeBSD.org
diff --git a/devel/trac-bitten/Makefile b/devel/trac-bitten/Makefile
index 0ef8203cf7f9..dd61f68b064d 100644
--- a/devel/trac-bitten/Makefile
+++ b/devel/trac-bitten/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bitten
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel www python
MASTER_SITES= http://ftp.edgewall.com/pub/bitten/ \
LOCAL/glarkin
@@ -29,7 +29,7 @@ BITTEN_GID= 952
OPTIONS= BITTEN_MASTER "Build bitten master" ON
.include <bsd.port.options.mk>
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-distribute
.if defined(WITH_BITTEN_MASTER)
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
.endif
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index e5e852485ca9..a929d730090a 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -67,8 +67,8 @@ PYEASYUNINSTALL_UNINSTALLARGS?= -q -N -m -S ${PYTHON_SITELIBDIR} \
-s ${PYEASYINSTALL_BINDIR} \
${PYDISTUTILS_PKGNAME}
USE_PYTHON= yes
-RUN_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= easy_install:${PORTSDIR}/devel/py-distribute
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-distribute
CONFIGURE_ARGS+=--with-python-modules
PLIST_SUB+= WITH_PYTHON="" PYTHON_VER=${PYTHON_VER}
PLIST_SUB+= PYDISTUTILS_PKGVERSION=${PYDISTUTILS_PKGVERSION}