aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-07-10 23:40:54 +0800
committergerald <gerald@FreeBSD.org>2014-07-10 23:40:54 +0800
commitb4ba1c5c8b15cc58941857f416c70fa24351ea24 (patch)
tree2a685f14d6d140b8f4123a4770adc8701a31a81a
parenta48f1b79f23a6ba17ac129896a29f9252a18d036 (diff)
downloadfreebsd-ports-gnome-b4ba1c5c8b15cc58941857f416c70fa24351ea24.tar.gz
freebsd-ports-gnome-b4ba1c5c8b15cc58941857f416c70fa24351ea24.tar.zst
freebsd-ports-gnome-b4ba1c5c8b15cc58941857f416c70fa24351ea24.zip
Add a new OPTION named COMPHOLIO to include the Compholio patchset.
This is off by default for now and nicely moving towards increasing upstream integration. It will be needed for Pipelight support. Submitted by: kmoore Tested by: gerald, kmoore
-rw-r--r--emulators/wine-devel/Makefile17
-rw-r--r--emulators/wine-devel/distinfo2
-rw-r--r--emulators/wine-devel/pkg-plist1
3 files changed, 19 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 64c4d815523b..23097330a83e 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -8,6 +8,7 @@ CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
http://ibiblio.org/pub/linux/system/emulators/wine/
PKGNAMESUFFIX= -devel
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= Microsoft Windows compatibility environment
@@ -42,10 +43,11 @@ SHEBANG_FILES= tools/winemaker tools/winedump/function_grep.pl
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO X11
+OPTIONS_DEFINE= COMPHOLIO CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO X11
OPTIONS_DEFAULT=X11
OPTIONS_SUB= yes
+COMPHOLIO_DESC= Include the Compholio patchset, needed for Pipelight support
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
WINEMAKER_DESC= Fully support winemaker (requires Perl)
@@ -91,6 +93,19 @@ PORTDATA= l_intl.nls wine.inf
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MCOMPHOLIO}
+MASTER_SITES+= https://github.com/compholio/wine-compholio-daily/archive/:cho
+COMP_DIST= v${DISTVERSION}.tar.gz
+DISTFILES+= ${COMP_DIST}:cho
+USE_AUTOTOOLS= autoconf
+BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash \
+ git:${PORTSDIR}/devel/git
+
+pre-configure:
+ cd ${WRKSRC} && ${TAR} xf ${DISTDIR}/${COMP_DIST} --strip-components 1
+ cd ${WRKSRC} && ${MAKE_CMD} -C ./patches DESTDIR=${WRKSRC} install
+.endif
+
pre-build:
cd ${WRKSRC} && ${MAKE_CMD} depend
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index f5f23bdf31bd..dae6d38540aa 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,2 +1,4 @@
SHA256 (wine-1.7.21.tar.bz2) = a14723104135c21414c61e146144a2c527430057255f8c35a3a7d354e68b9401
SIZE (wine-1.7.21.tar.bz2) = 21635330
+SHA256 (v1.7.21.tar.gz) = 19b619599e1d00829ab7782e069551dede0feacfd918b168f0843bd4ab0cd0d2
+SIZE (v1.7.21.tar.gz) = 883807
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 860212e62934..435308a4b0f9 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -2179,6 +2179,7 @@ share/applications/wine.desktop
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.winedbg
%%PORTDOCS%%%%DOCSDIR%%/README.winedump
+%%COMPHOLIO%%%%X11%%%%DATADIR%%/fonts/arial.ttf
%%X11%%%%DATADIR%%/fonts/coue1255.fon
%%X11%%%%DATADIR%%/fonts/coue1256.fon
%%X11%%%%DATADIR%%/fonts/coue1257.fon