aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2001-08-24 07:43:09 +0800
committerjmz <jmz@FreeBSD.org>2001-08-24 07:43:09 +0800
commitb5bae9fc2f30837de6329310d8672bb49eba7968 (patch)
tree0bcce5a81fc4b7260d2b5c00bc73934e65298090
parent106f29142705eff18b6192b79149d7f269f582eb (diff)
downloadfreebsd-ports-gnome-b5bae9fc2f30837de6329310d8672bb49eba7968.tar.gz
freebsd-ports-gnome-b5bae9fc2f30837de6329310d8672bb49eba7968.tar.zst
freebsd-ports-gnome-b5bae9fc2f30837de6329310d8672bb49eba7968.zip
Fix a local DoS against xfs.
Submitted by: kris Obtained from: XFree86 CVS repository
-rw-r--r--x11/XFree86-4/Makefile2
-rw-r--r--x11/XFree86-4/files/patch-xfs292
2 files changed, 293 insertions, 1 deletions
diff --git a/x11/XFree86-4/Makefile b/x11/XFree86-4/Makefile
index 2dcafe7b144a..d68fbfd83677 100644
--- a/x11/XFree86-4/Makefile
+++ b/x11/XFree86-4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= XFree86
PORTVERSION= 4.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= 4.1.0
diff --git a/x11/XFree86-4/files/patch-xfs b/x11/XFree86-4/files/patch-xfs
new file mode 100644
index 000000000000..8ac159dd7603
--- /dev/null
+++ b/x11/XFree86-4/files/patch-xfs
@@ -0,0 +1,292 @@
+--- programs/xfs/difs/dispatch.c 2001/04/01 14:00:20 3.9
++++ programs/xfs/difs/dispatch.c 2001/06/21 01:15:44
+@@ -141,8 +141,10 @@
+ op = MAJOROP;
+ if (op >= NUM_PROC_VECTORS)
+ result = ProcBadRequest (client);
+- else
++ else if (*client->requestVector[op] != NULL)
+ result = (*client->requestVector[op]) (client);
++ else
++ result = FSBadRequest;
+ }
+ if (result != FSSuccess) {
+ if (client->noClientException != FSSuccess)
+@@ -202,8 +204,12 @@
+ return (client->noClientException = -2);
+ if (((*(char *) &whichbyte) && (prefix->byteOrder == 'B')) ||
+ (!(*(char *) &whichbyte) && (prefix->byteOrder == 'l'))) {
++ int status;
++
+ client->swapped = TRUE;
+- SwapConnClientPrefix(prefix);
++ status = SwapConnClientPrefix(client, prefix);
++ if (status != FSSuccess)
++ return (status);
+ }
+ client->major_version = prefix->major_version;
+ client->minor_version = prefix->minor_version;
+@@ -257,7 +263,16 @@
+ client_auth[i].name = (char *) ad;
+ ad += client_auth[i].namelen;
+ client_auth[i].data = (char *) ad;
++
+ ad += client_auth[i].datalen;
++
++ if (ad - (char *)auth_data > stuff->length -
++ (i < (int)prefix->num_auths) ? 8 : 0) {
++ int lengthword = stuff->length;
++
++ SendErrToClient(client, FSBadLength, (pointer)&lengthword);
++ return (FSBadLength);
++ }
+ }
+ num_alts = ListAlternateServers(&altservers);
+ for (i = 0, altlen = 0; i < num_alts; i++) {
+@@ -585,6 +600,13 @@
+ ad += acp[i].namelen;
+ acp[i].data = (char *) ad;
+ ad += acp[i].datalen;
++ if (ad - (char *)stuff + SIZEOF(fsCreateACReq) > stuff->length -
++ (i < (int)stuff->num_auths ? 8 : 0)) {
++ int lengthword = stuff->length;
++
++ SendErrToClient(client, FSBadLength, (pointer)&lengthword);
++ return (FSBadLength);
++ }
+ }
+
+ /* XXX needs work for AuthContinue */
+@@ -702,6 +724,13 @@
+ REQUEST(fsSetResolutionReq);
+ REQUEST_AT_LEAST_SIZE(fsSetResolutionReq);
+
++ if (stuff->length - SIZEOF(fsResolution) != stuff->num_resolutions *
++ sizeof(fsResolution)) {
++ int lengthword = stuff->length;
++
++ SendErrToClient(client, FSBadAlloc, &lengthword);
++ return FSBadLength;
++ }
+ new_res = (fsResolution *)
+ fsalloc(SIZEOF(fsResolution) * stuff->num_resolutions);
+ if (!new_res) {
+@@ -725,6 +754,13 @@
+ REQUEST(fsReq);
+ REQUEST_AT_LEAST_SIZE(fsReq);
+
++ if (stuff->length - SIZEOF(fsResolution) != client->num_resolutions *
++ sizeof(fsResolution)) {
++ int lengthword = stuff->length;
++
++ SendErrToClient(client, FSBadAlloc, &lengthword);
++ return FSBadLength;
++ }
+ reply.type = FS_Reply;
+ reply.num_resolutions = client->num_resolutions;
+ reply.sequenceNumber = client->sequence;
+--- programs/xfs/difs/fonts.c 2001/04/01 14:00:20 3.9
++++ programs/xfs/difs/fonts.c 2001/06/21 01:15:45
+@@ -709,8 +709,12 @@
+ }
+ }
+ if (validpaths < npaths) {
+- fplist = (FontPathElementPtr *)
++ FontPathElementPtr *ftmp = (FontPathElementPtr *)
+ fsrealloc(fplist, sizeof(FontPathElementPtr) * validpaths);
++
++ if (!ftmp)
++ goto bail;
++ fplist = ftmp;
+ npaths = validpaths;
+ }
+ if (validpaths == 0) {
+--- programs/xfs/difs/main.c 2001/04/01 14:00:20 3.7
++++ programs/xfs/difs/main.c 2001/06/21 01:15:45
+@@ -171,11 +171,14 @@
+ exit(0);
+ }
+
+-void
++int
+ NotImplemented(void)
+ {
+ NoopDDA(); /* dummy to get difsutils.o to link */
+- FatalError("Not implemented\n");
++ /* Getting here can become the next xfs exploit... so don't exit */
++ ErrorF("Not implemented\n");
++
++ return (FSBadImplementation);
+ }
+
+ static Bool
+--- programs/xfs/difs/swapreq.c 2001/01/17 23:45:29 1.5
++++ programs/xfs/difs/swapreq.c 2001/06/21 01:15:46
+@@ -135,8 +135,8 @@
+ return ((*ProcVector[stuff->reqType]) (client));
+ }
+
+-static void
+-swap_auth(pointer data, int num)
++static int
++swap_auth(ClientPtr client, pointer data, int num, int length)
+ {
+ unsigned char *p;
+ unsigned char t;
+@@ -158,16 +158,29 @@
+ p += 2;
+ p += (namelen + 3) & ~3;
+ p += (datalen + 3) & ~3;
++ if (p - (unsigned char *)data > length - (i < num ? 8 : 0)) {
++ int lengthword = length;
++
++ SendErrToClient(client, FSBadLength, (pointer)&lengthword);
++ return (FSBadLength);
++ }
+ }
++
++ return (FSSuccess);
+ }
+
+ int
+ SProcCreateAC(ClientPtr client)
+ {
++ int status;
++
+ REQUEST(fsCreateACReq);
+ stuff->length = lswaps(stuff->length);
+ stuff->acid = lswapl(stuff->acid);
+- swap_auth((pointer) &stuff[1], stuff->num_auths);
++ status = swap_auth(client, (pointer) &stuff[1],
++ stuff->num_auths, stuff->length);
++ if (status != FSSuccess)
++ return (status);
+ return ((*ProcVector[stuff->reqType]) (client));
+ }
+
+@@ -177,6 +190,8 @@
+ REQUEST(fsSetResolutionReq);
+ stuff->length = lswaps(stuff->length);
+ stuff->num_resolutions = lswaps(stuff->num_resolutions);
++ if ((int)stuff->length - (&stuff[1] - &stuff[0]) < stuff->num_resolutions)
++ return (FSBadLength);
+ SwapShorts((short *) &stuff[1], stuff->num_resolutions);
+
+ return ((*ProcVector[stuff->reqType]) (client));
+@@ -255,11 +270,14 @@
+ return ((*ProcVector[stuff->reqType]) (client));
+ }
+
+-void
+-SwapConnClientPrefix(fsConnClientPrefix *pCCP)
++int
++SwapConnClientPrefix(ClientPtr client, fsConnClientPrefix *pCCP)
+ {
++ REQUEST(fsFakeReq);
++
+ pCCP->major_version = lswaps(pCCP->major_version);
+ pCCP->minor_version = lswaps(pCCP->minor_version);
+ pCCP->auth_len = lswaps(pCCP->auth_len);
+- swap_auth((pointer) &pCCP[1], pCCP->num_auths);
++ return (swap_auth(client, (pointer) &pCCP[1],
++ pCCP->num_auths, stuff->length));
+ }
+--- programs/xfs/include/difs.h 1999/08/21 13:48:50 1.2
++++ programs/xfs/include/difs.h 2001/06/21 01:15:46
+@@ -83,6 +83,6 @@
+ #endif
+
+ /* difs/main.c */
+-extern void NotImplemented(void);
++extern int NotImplemented(void);
+
+ #endif
+--- programs/xfs/include/osstruct.h 2001/01/16 22:52:04 1.1.1.4
++++ programs/xfs/include/osstruct.h 2001/06/21 01:15:46
+@@ -49,16 +49,16 @@
+ #include "os.h"
+
+ typedef struct _alt_server {
+- char subset;
+- short namelen;
+- char *name;
++ char subset;
++ unsigned short namelen;
++ char *name;
+ } AlternateServerRec;
+
+ typedef struct _auth {
+- short namelen;
+- short datalen;
+- char *name;
+- char *data;
++ unsigned short namelen;
++ unsigned short datalen;
++ char *name;
++ char *data;
+ } AuthRec;
+
+ #endif /* _OSSTRUCT_H_ */
+--- programs/xfs/include/swapreq.h 1998/10/25 07:12:32 1.1
++++ programs/xfs/include/swapreq.h 2001/06/21 01:15:47
+@@ -48,7 +48,7 @@
+ extern int SProcResourceRequest(ClientPtr client);
+ extern int SProcSetResolution(ClientPtr client);
+ extern int SProcSimpleRequest(ClientPtr client);
+-extern void SwapConnClientPrefix(fsConnClientPrefix *pCCP);
++extern int SwapConnClientPrefix(ClientPtr client, fsConnClientPrefix *pCCP);
+ extern void SwapLongs(long *list, unsigned long count);
+ extern void SwapShorts(short *list, unsigned long count);
+
+cvs server: Diffing xc/programs/xfs/os
+--- programs/xfs/os/io.c 2001/01/17 23:45:32 3.12
++++ programs/xfs/os/io.c 2001/06/21 01:15:47
+@@ -127,14 +127,24 @@
+ int
+ ReadRequest(ClientPtr client)
+ {
+- OsCommPtr oc = (OsCommPtr) client->osPrivate;
+- ConnectionInputPtr oci = oc->input;
++ OsCommPtr oc;
++ ConnectionInputPtr oci;
+ fsReq *request;
+- int fd = oc->fd;
+- int result,
++ int fd,
++ result,
+ gotnow,
+ needed = 0;
+
++ if (client == NULL)
++ return -1;
++ oc = (OsCommPtr) client->osPrivate;
++ if (oc == NULL)
++ return -1;
++ oci = oc->input;
++ fd = oc->fd;
++ if (oci == NULL || fd < 0)
++ return -1;
++
+ if (AvailableInput) {
+ if (AvailableInput != oc) {
+ ConnectionInputPtr aci = AvailableInput->input;
+@@ -207,6 +217,8 @@
+ oci->bufcnt = gotnow;
+ }
+ /* fill 'er up */
++ if (oc->trans_conn == NULL)
++ return -1;
+ result = _FontTransRead(oc->trans_conn, oci->buffer + oci->bufcnt,
+ oci->size - oci->bufcnt);
+ if (result <= 0) {
+@@ -230,7 +242,7 @@
+ (oci->bufcnt < BUFSIZE) && (needed < BUFSIZE)) {
+ char *ibuf;
+
+- ibuf = (char *) fsrealloc(oci, BUFSIZE);
++ ibuf = (char *) fsrealloc(oci->buffer, BUFSIZE);
+ if (ibuf) {
+ oci->size = BUFSIZE;
+ oci->buffer = ibuf;
+
+
nome/commit/finance?h=gstreamer0.10-removal&id=640c95e99b684ed5e79633c5fc77c3ef3b385ee5'>Update to 2.4.1arved2006-04-162-4/+5 * - Update to 1.10pav2006-04-164-31/+4 * Reset mph due to no response to email about status, and maintainer-timeouts.linimon2006-04-151-1/+1 * Update to 0.8.3.lawrance2006-04-096-72/+26 * Update to 0.8.2.lawrance2006-04-0750-600/+174 * - update to 3.51leeym2006-04-033-14/+9 * Drop maintainershipmarkus2006-03-251-1/+1 * Mirror the source tarball.thierry2006-03-241-1/+3 * Tiny ERP is an open source application - written in python, powered bythierry2006-03-226-0/+1417 * Bump PORTREVISION on glib12/gtk12 consumer ports to ease the upgrade path.ade2006-03-072-1/+2 * Conversion to a single libtool environment.ade2006-02-2317-24/+85 * Remove deprecated USE_REINPLACEehaupt2006-02-191-1/+0 * Remove expired port finance/emmavs2006-02-099-181/+0 * - Add a php extension pfpro (PayFlow Pro).pav2006-02-012-0/+16 * Fix build when perl version < 5.6anray2006-01-291-0/+1 * Update to 2.6.6lth2006-01-293-5/+5 * SHA256ify (manually updated and checked)edwin2006-01-222-2/+2 * SHA256ifyedwin2006-01-2210-0/+10 * eplace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-221-11/+11 * Replace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-2233-92/+92 * Update to 1.11skv2006-01-213-13/+17 * - Don't remove mtree created symlinkspav2006-01-201-2/+0 * - Update to 1.9pav2006-01-202-4/+4 * - Update to 2.6.4lth2006-01-103-6/+6 * - update to 1.04leeym2006-01-092-7/+10 * - Fix buildpav2005-12-311-0/+11 * Add p5-Locale-Currency-Format 1.22, perl functions for formattinganray2005-12-285-0/+42 * Add p5-Finance-Currency-Convert-WebserviceX 0.05, lightweight currencyanray2005-12-285-0/+49 * Upgrade to 0.5.8.thierry2005-12-205-24/+30 * add LATEST_LINKedwin2005-12-051-0/+1 * Run pkg-message through SUB_FILES.edwin2005-12-012-4/+4 * New port for VeriSign's PayFlow SDKedwin2005-12-016-0/+74 * Add SHA256 hashes to my portsehaupt2005-11-301-0/+1 * DEPRECATED, this project doesn't exist anymore since 2004vs2005-11-291-0/+3 * - Fix ktoblzcheck dependency linepav2005-11-281-2/+2 * - Fix aqbanking dependency linepav2005-11-272-2/+2 * - Add SHA256pav2005-11-2716-0/+16 * - Unbreak, chase updated tarballlth2005-11-262-6/+5 * BROKEN: Size mismatchkris2005-11-261-0/+2 * - Update to 1.8.12pav2005-11-2616-196/+140 * - Add SHA256pav2005-11-262-0/+2 * - Add SHA256pav2005-11-2520-0/+20 * Update to 2.6.3lth2005-11-193-37/+72 * - Update to 1.8pav2005-11-193-4/+15 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-1510-11/+10 * Add SHA256 checksumlioux2005-11-113-0/+3 * * Add SHA256 checksums for maintainerless ports i added to the ports collectionarved2005-11-081-0/+1 * Chase gpgme updateoliver2005-11-061-1/+2 * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-055-3/+5 * Update to 1.03. Assign maintainership to perl@. Require perl fromtobez2005-11-032-6/+11 * Fix Perl dependencylth2005-11-031-1/+1 * - Unbreak on 4.x by USE_GCC=3.2+vs2005-11-031-2/+5 * Add sql-ledger 2.6.2, a double entry accounting system.lth2005-10-307-0/+2224 * - Update to 1.7pav2005-10-215-19/+31 * - Release maintainer to ports@ to be with gnucashahze2005-10-181-1/+1 * Change MAINTAINER address for my ports.ehaupt2005-10-061-1/+1 * Fix bogus ui files in preparation for Qt 3.3.5lofi2005-09-2942-0/+588 * search.cpan.org redirect reduction canonicalization project, pass 1:fenner2005-09-224-4/+4 * Reset maintainership of Seamus Venasse who has not responded for some time.erwin2005-09-202-2/+2 * - update to 1.02leeym2005-09-202-4/+4 * Chase mastersite.linimon2005-09-151-1/+1 * Remove obsolete mastersites.linimon2005-09-152-4/+0 * Reset maintainer after long period of inactivity.linimon2005-09-101-1/+1 * The CCard program is a program to validate credit card numbers.sem2005-09-044-0/+50 * - Chase libofx updatepav2005-09-014-4/+7 * - Update to 0.8.0pav2005-09-015-76/+141 * - Update to 0.6.3pav2005-08-302-6/+5 * - Update to 0.7.5sem2005-08-018-282/+744 * - add missing dependencyleeym2005-07-291-0/+2 * - Update to 1.00leeym2005-07-293-10/+8 * - Update to 1.04leeym2005-07-292-3/+3 * - Chase qhacc updatepav2005-07-271-2/+2 * - Update to 3.4pav2005-07-273-9/+9 * Update to 1.10skv2005-07-054-12/+27 * 'Ledger' is a command-line accounting program, which uses a simple text filedannyboy2005-07-046-0/+119 * Fix pkg-plistlawrance2005-06-121-0/+28 * Add AQBANKING option, fixes broken/incorrect dependency on openhbci.lawrance2005-06-082-4/+14 * Add aqbanking 1.0.11, online banking interface and financial datalawrance2005-06-085-0/+175 * Upgrade to 0.5.7.thierry2005-06-073-9/+9 * change the libtool version to use from 1.3 to 1.5oliver2005-06-023-11/+17 * Update to 0.10.tobez2005-05-242-3/+3 * Chase update of openhbcilawrance2005-05-171-1/+2 * Update to 0.9.17.2lawrance2005-05-175-36/+33 * Oops... Add new Spanish, Italian, Dutch, Polish and Romanian translations.thierry2005-05-151-2/+12 * Upgrade to 0.5.6.thierry2005-05-153-10/+9 * Relinquish maintainership back to ports@. Hopefully someone will give gnucashmarcus2005-05-122-2/+2 * Correct a typo in the previous commit, and use the right version libdb41.marcus2005-05-122-2/+2 * Fix the build with db41.marcus2005-05-122-4/+2 * Add JAVA_EXTRACT option that makes sure that java is available atlioux2005-05-111-0/+1 * Remove BROKEN status since the port is indeed fetchablelioux2005-05-091-2/+0 * BROKEN on 4.x: Does not compilekris2005-05-071-1/+7 * BROKEN: Unfetchablekris2005-05-071-0/+2 * - Add xtrader [1]ahze2005-04-175-0/+68 * s/ENV/SETENV/mi2005-04-161-1/+1 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-124-4/+4 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-114-4/+4 * Update to 3.15erwin2005-04-042-3/+3 * - Update to 0.32leeym2005-04-042-4/+4 * Update to 0.5.1.alioux2005-04-042-3/+4 * o Add patch forgotten when port was updated to 0.5alphalioux2005-03-301-0/+13 * Update to 0.5alpha; thus, fixing BROKEN statuslioux2005-03-282-5/+15 * BROKEN on ia64 and alpha: Does not compilekris2005-03-271-1/+7 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-126-5/+6 * Update to 0.09mat2005-03-093-3/+4 * - Update to 3.3.flz2005-03-033-8/+15 * - Update to 3.3.flz2005-03-033-10/+44 * Update to 0.08. Require 5.6 or 5.8, since one of its dependencies doestobez2005-03-032-8/+6 * As previously announced, remove ports that have reached their expiry date,kris2005-02-197-218/+0 * I hit 'x' too many times, and deleted the trailing 't' in gnometarget.marcus2005-02-131-1/+1 * * Fix the build on 4.Xmarcus2005-02-133-2/+92 * BROKEN: Does not buildkris2005-02-121-0/+2 * Chase the libofx shared lib version.marcus2005-02-121-2/+2 * Update to 1.8.11.marcus2005-02-126-16/+32 * Update to 0.7.0.marcus2005-02-125-192/+85 * Update to 0.05erwin2005-02-012-3/+3 * Split the postgresql ports into a server and a client part.girgen2005-01-311-2/+1 * Add patch to enter overdue scheduled paymentsvs2005-01-224-0/+64 * New port venice version 0.4alpha: Merchant Of Venice, a stock marketlioux2005-01-205-0/+105 * New port qtstalker version 0.28: Commodity and stock market chartinglioux2005-01-2010-0/+247 * Fix plist.thierry2005-01-122-3/+3 * Upgrade to 0.5.5.thierry2005-01-104-23/+23 * Fix build on 5.xarved2005-01-102-7/+24 * Update to 0.07mat2005-01-082-3/+12 * Upgrade to 0.5.4.thierry2004-12-282-3/+3 * This port is scheduled to be removed on 2005-02-18 if it is stillkris2004-12-191-0/+2 * Clean up handling of locale directories at deinstall-time:kris2004-12-162-0/+4 * Software developers fixed double-entry account field in transactionkrion2004-12-161-2/+2 * Software developers fixed double-entry account field inkrion2004-12-161-2/+2 * Add p5-Finance-Currency-Convert-XE, a currency conversion module thattobez2004-12-155-0/+51 * Update to version 3.2.3krion2004-12-123-13/+4 * Update to version 3.2.3krion2004-12-127-231/+81 * Update to 0.28.tobez2004-12-062-3/+3 * Upgrade to 0.5.3.thierry2004-11-293-7/+11 * Mark BROKEN on alpha for the time being. The build causes xsltproc tomarcus2004-11-291-1/+7 * Add missing libtool droppingskris2004-11-261-0/+8 * Use new INSTALLS_OMF.mezz2004-11-232-6/+1 * BROKEN: Does not compilekris2004-11-181-0/+2 * Update to 1.8.4ahze2004-11-123-129/+157 * Bump PORTREVISIONS for all ports that depend on atk or pango to ease in themarcus2004-11-082-0/+2 * Update to 0.6.4arved2004-11-058-40/+10 * Upgrade to 0.5.2.thierry2004-10-183-29/+48 * Make these stylesheets XSLT compliant by making sure templates with the samemarcus2004-10-172-0/+34 * Kill off automake18, switching to automake19. Requiem Mors Pacem.ade2004-10-161-1/+1 * Update to 0.04erwin2004-10-142-3/+3 * Update to 3.14erwin2004-10-142-3/+3 * Update to version 3.2.1krion2004-10-122-3/+4 * Update to version 3.2.1krion2004-10-122-3/+3 * Increase USE_GCC to 3.4 for those ports which compile with it.kris2004-09-301-1/+1 * BROKEN on 5.x: Does not compilekris2004-09-191-1/+7 * Chase print/latex-ucs moving to texmf-local.thierry2004-09-121-1/+1 * Fix build with gcc 3.4arved2004-08-231-0/+46 * Fix build with gcc 3.4arved2004-08-171-0/+10 * Update to version 3.2krion2004-08-1416-1644/+218 * Fix build with gcc-3.4krion2004-08-111-0/+134 * Update to version 1.0krion2004-08-034-8/+12 * Upgrade Grisbi to 0.5.1.thierry2004-08-023-11/+3 * Fix US-ASCII encoding problem with the PostgreSQL backend. US-ASCII will bemarcus2004-07-274-0/+34 * Add kmymoney2 a KDE personal finance assistantarved2004-07-2511-0/+313 * Drop maintainershiplioux2004-07-211-1/+1 * - Update to 2.6.9vs2004-07-147-39/+23 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-102-2/+2 * Add myBudget, a nifty Gtk+-2 personal finance thinger.adamw2004-07-055-0/+105 * Update to 2.01erwin2004-07-042-4/+3 * Autotools cleanup. Remove autoconf257 (259), automake17 (18), andade2004-07-021-1/+1 * Remove this expired port.kris2004-06-215-73/+0 * Remove expired ports, plus the three ports that depended on them.kris2004-06-211-1/+0 * Update to 1.8.9.marcus2004-06-206-8/+46 * Don't use Makefile.kde anymoremarkus2004-06-061-3/+1 * Remove an extraneous dependency towards popt.thierry2004-05-291-0/+8 * - Update to version 3.0krion2004-05-296-58/+159 * Upgrade to 0.5.0 and de-gnomify.thierry2004-05-258-92/+99 * Revert previous commit; maintainer is merely having email trouble.linimon2004-05-191-1/+1 * Reset bouncing maintainer address.linimon2004-05-181-1/+1 * Reduce time and traffic by pinning distfiles to their sites.linimon2004-05-181-4/+4 * - Update to version 2.6.9krion2004-05-103-10/+10 * Fix pkg-plist.thierry2004-04-292-1/+5 * These broken ports are scheduled for deletion on June 18 if they arekris2004-04-191-0/+2 * Add missing dirrmerwin2004-04-151-0/+1 * Add missing dirrmerwin2004-04-151-0/+1 * - Update to version 1.7.9krion2004-04-104-436/+497 * - Update to version 2.9.9krion2004-04-102-3/+3 * Upgrade to 0.4.5: bug fixes.thierry2004-04-082-4/+3 * unzip is an EXTRACT_DEPENDS, not BUILD_DEPENDSkris2004-04-061-1/+1 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-054-1/+4 * - Support PTHREAD_CFLAGS properlykrion2004-04-032-12/+412 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+3 * upgrade to 0.3.5ijliao2004-04-02